Po przestawieniu kontrolera na RAID system nie wstaje


(Szustka66) #1

Obecnie mam dysk SSD z windows 8.1 i drugi ssd mały na inne rzeczy.

 

Kupiłem dwa dyski HDD 1T i chciałbym z nich zrobić RAID 1 i trzymać na nich dane. Oczywiście z SSD nie chcę nic robić.

 

Moje mobo z uefi: Gigabyte GA-Z97X-Gaming 5, Z97

 

MOBO obsługuje hardwerowy RAID i z tego chcę skorzystać. Wg instrukcji powinienem przełączyć kontroler SATA z AHCI na RAID, by mieć opcje macierzowe. Pozostałe dyski powinny wtedy pracować normalnie jak na AHCI. Ale po przełączeniu na RAID system się niby ładuje i restart. 

 

 

Druga sprawa, że nie wiem co zrobić i czy ma to jakiekolwiek znaczenie:

Mam windowsa 8.1 na SSD ale zainstalowany bez uefi (czyli przy instalacji nie było zaznaczone boot CD UEFI czy jakoś tak). Jakie ma to plusy, minusy? Czy można przekonwertować bez reinstalacji systemu, czego bardzo nie chcę robić.

Wszystkie partycje obecnie to MBR, ogromnych dysków i partycji nie mam, więc GPT chyba nie potrzebne

 

Jak najlepiej rozwiązać tą całą sytuację, by było porządnie i dobrze?


(system) #2

Te restarty mogą być wynikiem braku sterowników do raid w systemie, zasadniczo przy instalacji systemu pada monit o podanie sterowników. Teraz może być to lekki problem.

 

Napisze jak to jest ogólnie, bo korzystam z takiego raid tyle, że nie intela.

 

W większości płyt jest tak:

sata 1-2 - Tu IDE jeśli podłączony czytnik DVD lub AHCI jeśli dodatkowy dysk.

sata 3-6 - tu ustawia się RAID

 

Teraz aby system nie zdychał a dał monit o sterowniki, trzeba by dysk z systemem podłączyć na 1 lub 2, aby nie startował z kontrolera w trybie RAID.

Po instalacji sterowników, będzie można go nawet podłączyć na 3-6.

 

To tylko taka ogólna zasada.

Chodzi o to aby system choć raz się uruchomił nie będąc na tych portach na których jest ustawiony tryb RAID ale przy włączonym RAID.


(Szustka66) #3

 

Nie widzę opcji ustawienia trybu kontrolera dla poszczególnych tylko slotów SATA. W jednym miejscu mogę tylko globalnie zmienić. Tak jak to widać tutaj na screenie str. 64: http://download.gigabyte.us/FileList/Manual/mb_manual_ga-z97x-gaming5_e.pdf

 

Sterowniki tak czy owak wszystkie instalowałem do windowsa, które tylko były na płycie.

 

Obecnie dysk z systemem mam na porcie SATA 0


(system) #4

Tak ale instalowałeś sterowniki zanim był odpalony RAID. Pytanie jak mu zapodać teraz ? Bo napisane jest, że dla 8/8.1 wymagane.

Na stronie 75 opisują jak to zrobić ale przed instalacją windows.


(Szustka66) #5

Ok, jednak reinstalację zrobiłem. W przy konfiguracji RAID manual kazał wyłączyć CSM. Wygląda na to, że innego systemu (Linux), już nie będę mógł postawić obok.