Po update systemy wysypały mi sie x-xy


(tomi001) #1

Mam taki problem chciałem zainstalować nowszą wersję kadu więc żeby to zrobić dodałęm do repozytoriów żródło więc musiał uaktualnić dużą porcję pakietów, ale po tej czynności x-xy mi się wysypały więc dałem polecenie apt-get install kdm i mam tylko takie namiastkę środowiska graficznego, ale postanowiłem zainstalować kde więc dałem polecenie apt-get install kde-full to wyskakuje komunikat że np. kde-plasma wymaga nowszego pakietu i teraz nie wiem jak to kde zainstalować.


(pocolog) #2
  1. zasada nie baw się W grzebanie w repozytoriach jeżeli nie wiesz co robisz.

 

Najłatwiej byłoby odinstalować wszystko co wrzuciło Kadu i usunąć wpis ppa, Ale ty oczywiście nie wiesz co zainstalowałeś bo po co Tracić czas na takie bzdury lepiej wszystko klepnąć dalej dalej dalej jak na łyndołsie :wink:

 

Wyrzuć ten wpis ppa, odinstaluj kadu oraz kde (kadu z purge, kde bez purge) pozniej autoremove autoclean I ponownie zainstaluj kde.

Może to pomoże jeżeli nie namieszałeś za bardzo w systemie 


(Domker) #3

Welcome to HELL.

Teraz przynajmniej wiesz, co to piekło zależności :stuck_out_tongue:

Dobrym nawykiem jest robienie kopii zapasowej, gdy nie wiemy do końca co robimy.

 

Dlatego m. in. porzuciłem “debiono podobne” dystrybucje.

Na Arch / Manjaro łatwiej jest wrócić do stanu np. sprzed aktualizacji lub jakiejś fatalnej instalacji pakietu z repo.


(tomi001) #4

Usunąłem kde, ale nie wiem czy się do końca uusnęło, chciałem wybrać jakiś pakiet z kde do usunięcia do chciało mi usunąć kdm, a bez tego nie uruchomię serwera Xorg, ten sam problem występuje w przypadku innych pakietów takich jak libreoffice też pojawia się komunika, że potrzebne są paczki

libreoffice-core.

Może się przerzucę na Manjaro tylko jak tam obsługą pakietów deb ?


(pocolog) #5

Wywal KDE ze wszystkimi zależnościami i pozostałości (autoremove). Pewnie xorg też poleci, ale konsola będzie działać, a zalogować się w konsoli na roota i uruchomić instalacje KDE chyba potrafisz.


(Domker) #6

@tomi001To inna bajka, inna dystrybucja, tu nie ma pakietów DEB tylko “tar.xz” :stuck_out_tongue:

https://wiki.manjaro.org/index.php?title=Spis_treści

Na początku ciężko się przestawić z nawyków dystrybucji opartych o Debiana.


(tomi001) #7

Czyli paczki podobne do tych jakie ma slackware ?


(pocolog) #8

Arch czy Manjaro nie jest żadnym remedium na brak myślenia i oczywiście tam taki scenariusz jaki kolega przeprowadził tutaj również jest możliwy.

Ważne żeby się nauczył na błędach, a skakanie z distro na distro niczego go nie nauczy.

Polecanie osobie nieobeznanej z Linuksami mało popularnej dystrybucji też uważam za szkodliwe tak dla tej osoby jak i dla tych którzy będą musieli rozwiązywać jego problemy bo gotowców sam tak łatwo nie znajdzie w google.

 

Poza tym nie jest to rozwiązanie problemu, ani dyskusja na temat.


(tomi001) #9

A prostotą bardziej zbliża do ubuntu czy do slackware bo ja kiedyś używałem slakcware jeszcze jak miałem stacjonarnego kompa.


(Domker) #10

Prawie całkowicie się z tobą zgadzam pocolog.  Wspomniałem tylko, że w przypadku w. w. scenariusza jest nieco łatwiej wybrnąć na Manjaro. (sudo pacman -S downgrade  //i wsio)

A, że tomi001 pociągnął temat to mu najzwyczajniej w świecie odpowiedziałem.

Powiem, Ci szczerze, że skakanie z distro na disto dużo wiele mnie nauczyło, a przynajmniej zdjęło klapki na oczach i ślepą wiarę w automatyzacje i zachęciło do nauczenia czegoś więcej.

Co do gotowców to niestety się nie zgodzę. Manjaro jest przyjazne (może w mniejszym stopniu niż Ubuntu/Mint) dla początkujących, a gotowców jest masa z tego względu, że to distro ma wiele wspólnego z Archem. Masz rację, to nie temat, żeby się rozpisywać w tej kwestii.

 

Co to problemu to:

  1. Usuń wpis repo, które dodałeś, aby zainstalować Kadu

sudo apt-get update && sudo apt-get install --reinstall plasma-desktop && sudo apt-get -f install

//powinno pomóc


(tomi001) #11

@Domker

A czy dysktrybucja Manjaro obsługuje grafikę intel bo mi nowa wersja kubuntu nie chciała z tego powodu ruszyć, bo ja są problemy z grafiką intela to może starsza wersja Manjaro jak ta to jak ?


(marcin82) #12

Dystrybucja Manjaro obsługuje grafikę Intel.

 

Najpierw pobierz ostatnie stabilne wydanie. Jeśli będą problemy z uruchomieniem środowiska graficznego w trybie livecd - sprawdź opcję “nomodeset”.