Po włamaniu hakera nie działa mi PA w Joomli


(Uphate1) #1

Witam po włamaniu hakera nie działa mi panel administracyjny wszystkie pliki są, wgrywałem katalog administration parę razy może zła wersja? Jak wersje sprawdzic gdy wchodze do administration pokazuje się komunikat

 

Warning  : require_once(/home/mizar/ftp/www/libraries/cms.php) [ function.require-once ]: failed to open stream: No such file or directory in /home/mizar/ftp/www/administrator/includes/framework.php   on line   41  


(tomeeek64) #2

Zrób kopię zapasową bazy danych i całego konta FTP (wszystkich plików). Pobierz paczkę Joomli (http://www.joomla.org/download.html), usuń z niej plik konfiguracyjny i taką paczką bez pliku konfiguracyjnego nadpisz pliki na FTP (zamiast tamtych, mają być te z paczki + te na serwerze, których nie było w paczce).


(GioWDS) #3

Z paczki joomli dograj plik:

/libraries/cms.php

Obecny błąd oznacza, że brakuje tego pliku.

Dogranie tego pliku pozwoli się uruchomić systemowi - jednak nie załatwi problemu. Jakoś ktoś się włamał.

Ogólnie jestem zwolennikiem korzystania z publicznie dostępnych systemów przez osoby nie mające pojęcia oprogramowaniu - jednak trzeba pamiętać o aktualizowaniu takich systemów - ze względu na ogólnie dostępny kod są one bardziej podatne na włamania po upublicznieniu poprawki.