Po zainstalowaniu sterowników do karty graficznej problem z migotaniem ekranu w ubuntu


(Mariuszsmoka12345) #1

Witam a więc nie owijajmy w bawełnę mam problem na ubuntu 14.04 a więc to było tak:

Na stronie amd znalazłem sterowniki do mojej zintegrowanej karty graficznej ati radeon x1250 klikłem donwload i w przeglądarce pokazał się skrypt ważący 80mb zrobiony w makeshell i gdy czekałem aż się zainstaluje wyłączyli mi prąd gdy prąd przyszedł włączyłem pc i weszłem na strone tam gdzie pobierałem sterownik i kazali mi pobrać plik.run pobrałem go i odpaliłem instalator (wcześniej kiedy włączyłem pc czyli jak mi prąd włączyli i polowa stera się zainstalowała komputer przy logowaniu pięknie chodził lecz doznawał czarnego migotania ekranu)teraz gdy doinstalowałem te resztki sterownika komputer zachowuje się tak samo (myślę że to przez to że źle zainstalowałem) nwm co mam robić mogę nawet reinstall zrobić tylko stare chcę usunąc a nwm jak może ktoś zna inne rozwiązanie??


(nintyfan) #2
aticonfig --uninstall

I ponownie zainstaluj


(Latający Turban) #3

Nie zainstalujesz sterowników od ati do tej karty na tym ubuntu. Chyba, że masz kernel 3.4 i jakiegoś starego xorga, w co wątpię. Twoim jedynym wyjściem jest używanie sterowników dostarczonych wraz z systemem albo możesz zainstalować debiana stable. On chyba jeszcze ma odpowiedni kernel i xorg.


(saturno) #4

 

Wbrew pozorom Debian stable nie ma aż tak starych pakietów.

Ostatnią wersją Debiana na której ruszyłyby zamknięte sterowniki dla tej karty był Lenny.


(Mariuszsmoka12345) #5

Zrobiłem tak zmieniłem system na elementary os bazujący na ubuntu i nadal to samo nawet po zainstalowaniu sterowników myślę że to przez częstotliwość odświeżania nie wiem jak ją zmienić ponieważ podczas generowania xorg.conf szukałem jak to zrobić na stronach różnych pisze w konsoli /etc/init.d/gmc stop nawet kdc nie pomaga i przez to nie wiem jak zatrzymać srodowisko graficzne oczywiście robie to naciskając ctr+alt+F1


(Latający Turban) #6

Zapytam tak: Na otwartych sterownikach Ci nie migocze ?


(Mariuszsmoka12345) #7

Powiem ci tak z sterownikami czy bez migocze nwm jak to jest z otwartymi prosiłbym o linka obecnie mam zamknięte i tu problem nie umiem usunąc zamkniętych ponieważ komenda aticonfig nie istnieje jak mniemam zamknięte to te ze strony producenta...

Migotanie występuje ostro przy uruchomieniu i ładowaniu się środowiska graficznego po wejściu w ustawienia ekran i podczas bardzo żadko uruchamiania okien no mówie wam że to albo częstotliwość lub otwarte stery musze mieć tylko link bym prosił:slight_smile:


(Latający Turban) #8

Na początek spróbuj

sudo sh /usr/share/ati/fglrx-uninstall.sh (jeżeli nie będzie to odpal po prostu instalator z którego instalowałeś sterowniki z dodanym parametrem na końcu --uninstall)

później sudo apt-get remove --purge fglrx fglrx_* fglrx-amdcccle* fglrx-dev*

 

Jeżeli, którychś pakietów nie będzie to się nie przejmuj.

 

Nie wiem jak to tam w elementary, raczej wątpie, żeby był jakiś plik xorg.conf ale możesz wpisać w konsolę

sudo rm /etc/X11/xorg.conf

najwyżej ci wyświetli, że nie ma takiego pliku

 

W internetach jeszcze podają, żeby przeinstalować xorg, ja nie jestem pewien czy to jest takie konieczne ale możesz spróbować

sudo apt-get install --reinstall xserver-xorg-core libgl1-mesa-glx:i386 libgl1-mesa-dri:i386 libgl1-mesa-glx:amd64 libgl1-mesa-dri:amd64

Później musisz przeprowadzić ponowną konfigurację xorg

 

sudo dpkg-reconfigure xserver-xorg

 

następnie restart

 

Co do otwartych sterowników, to ich nie pobiera się ze strony masz je wbudowane w system. Co najwyżej wraz z nowym jądrem, może być dodawane nowe funkcje i poprawki, ale dla twojej karty wątpie aby były dodawane jakieś szczególne nowości. W sumie powiem Ci, że na jednym komputerze mam trochę nowszą kartę niż ty bo 2600 i mam straszny problem z otwartymi sterownikami. Różnych cudów już próbowałem i im dalej w las tym jest gorzej. Także jeżeli będziesz chciał jakoś zwiększyć wydajnośc swojej karty, to Ci za bardzo nie pomogę.


(Mariuszsmoka12345) #9

Xorga to ja domyślnie nie mam spróbuje przeinstalowac ale nie jest u mnie możliwe wygenerowanie xorga conf bo musze zamknąć srodowisko graficzne gmd ani kmd stop nic nie dają xorg configure tak naprawdę nie generuje pliku poprawnego ponieważ sekcje są za krótkie i wiele w nich brakuje np section zrobiłem modeline wcisłem ją w sekcje monitor (modelina poprawna) i monitor wyświetlał brak sybnału


(Latający Turban) #10

w elementary jest chyba ubuntowski lightdm, więc jak chcesz go zamknąć to ctrl + alt + f1 i etc/init.d/lightdm stop i wtedy spróbuj


(Mariuszsmoka12345) #11

Dzięki

Wygenerował się ale wracając do tego migania jak bym mógł to naprawić coś dopisać w xorg.conf??


(nintyfan) #12

Zamiast kmd czy gmd nie powinno być kdm/gdm?


(Mariuszsmoka12345) #13

Nie bonto ma lightdm ale już wygenerowałem