Po zmianie rozdzielczości nie mogę uruchomić Urban Terror


(Spectator) #1

Ostatnio naszła mnie ochota na popykanie w urban terror, ściągnąłem, rozpakowałem, uruchomiłem, skonfigurowałem jak dla mnie wygodnie, ustawiłem rozdzielczość i od tamtej pory nie mogę uruchomić gry.

Żeby dowiedzieć się dlaczego nie uruchamia się postanowiłem go uruchomić z terminala i po kolejnej nieudanej próbie uruchomienia gry w terminalu został taki oto komunikat:

ioQ3 1.35urt linux-i386 Dec 20 2007

----- FS_Startup -----

Going through search path...


----------------------

8032 files in pk3 files

execing default.cfg

execing q3config.cfg

execing autoexec.cfg

Hunk_Clear: reset the hunk ok

----- Client Initialization -----

Couldn't read q3history.

----- Initializing Renderer ----

-------------------------------

QKEY found.

----- Client Initialization Complete -----

----- R_Init -----

...loading libGL.so.1:

Calling SDL_Init(SDL_INIT_VIDEO)...

SDL_Init(SDL_INIT_VIDEO) passed.

Initializing OpenGL display

...setting mode 8: 1280 1024

X Error of failed request: BadValue (integer parameter out of range for operation)

  Major opcode of failed request: 134 (XFree86-VidModeExtension)

  Minor opcode of failed request: 10 (XF86VidModeSwitchToMode)

  Value in failed request: 0x8b

  Serial number of failed request: 133

  Current serial number in output stream: 135

Sterowniki wszystkie mam poprawnie poinstalowane i kompletnie nie rozumiem dlaczego ta gra mi się nie uruchamia tymbardziej, że ściągnąłem wersję pod linuksa, żeby nie było, że windowsową próbuję uruchomić bez wine’a.

Grę pobrałem stąd:

http://www.urbanterror.net/page.php?6

a sterowniki do karty graficznej zainstalowałem za pomocą narzędzia envy ng. Distro i wersja: Ubuntu 8.04.


(maniooo) #2

Witam,

zerknij na 5 post:

http://ubuntuforums.org/showthread.php?t=758604


(Spectator) #3

Postępując według podanych tam wskazówek… Usunięcie configa dało tyle, że uruchomiłem grę na domyślnych ustawieniach, a po zmianie rozdzielczości to samo. Ręczne wyedytowanie configa według porady jednego z userów w tamtym wątku niestety nic nie dało.


(matiit) #4

Czy jesteś pewien, że envy ng zainstalował najnowsze dostępne sterowniki?

Jeśli zainstalował nienajnowsze, to skopiuj sobie xorg.conf, wywal sterownik z env’ovski, zainstaluj najnowsze sterowniki ze stron AMD i jeśli by sie Xy nie uruchamiały to podmień xorg.conf na tego co sobie na początku skopiowałeś.


(Spectator) #5

Jak instaluję sterownik ze strony amd to potem pozostaje jedynie reinstalacja ubuntu, bo w żaden sposób nic nie mogę z nim zrobić, a przynajmniej nie potrafię, po reboocie ekran jest czarny i tyle mojej przygody z zainstalowanymi sterownikami inaczej niż przez envy.


(matiit) #6

No to Ci mówię… Jeśli poprawnie zainstalowałeś sterownik i masz czarny ekran przy starcie, to najprawdopodobniej masz źle skonfigurowany xorg.conf.

Dlatego teraz byś zrobił sobie kopie i później ją wkleił na miejsce tego xorg.confa zastąpionego przez instalator Catalystów.


(Spectator) #7

Tylko jak po instalacji catalystów przywrócić cokolwiek skoro pojawia się czarny ekran i nic innego… Sterownik przez envy jest jak nabardziej poprawnie zainstalowany, bo wszystko działa jak należy i zresztą nie o sterownik tu chodzi tylko o samą grę, nie rób tu ot-ów.

Może ktoś inny pomoże?


(matiit) #8

Może to akurat wina sterowników? Warto mieć najnowszą wersje (licząc że jeśli to błąd sterowników, to jest w nowszej wersji naprawiony…)

Jak przywrócić cokolwiek jak jest czarny ekran?

Tryb tekstowy, alt ctrl f1, logujesz sie i kopiujesz zabackupowany plik na miejsce właściwego.