Pobieranie zdjęć z aparatu


(Centrumopowiastek) #1

Próbowałem ściągnąć zdjęcia z aparatu, wydałem w konsoli polecenie "gphoto2"

Dostałem listę:

Składnia: gphoto2 [-?] [-?|--help] [--usage] [--debug] [--quiet]

        [--force-overwrite] [-v|--version] [--list-cameras] [--list-ports]

        [--stdout] [--stdout-size] [--auto-detect] [--port=path]

        [--speed=speed] [--camera=model] [--filename=filename]

        [--usbid=usbid] [-a|--abilities] [-f|--folder folder] [-R|--recurse]

        [--no-recurse] [-l|--list-folders] [-L|--list-files]

        [-m|--mkdir ŁAŃCUCH] [-r|--rmdir ŁAŃCUCH] [-n|--num-files]

        [-p|--get-file ŁAŃCUCH] [-P|--get-all-files]

        [-t|--get-thumbnail ŁAŃCUCH] [-T|--get-all-thumbnails]

        [--get-raw-data=ŁAŃCUCH] [--get-all-raw-data]

        [--get-audio-data=ŁAŃCUCH] [--get-all-audio-data]

        [-d|--delete-file ŁAŃCUCH] [-D|--delete-all-files]

        [-u|--upload-file ŁAŃCUCH] [--config] [--capture-preview]

        [--capture-image] [--capture-movie] [--capture-sound]

        [--show-exif=ŁAŃCUCH] [--show-info=ŁAŃCUCH] [--summary] [--manual]

        [--about] [--shell]

Chciałem ściągnąć wszystkie zdjęcia, więc wpisałem "gphoto2 -P" Dostałem:

**Error***

Could not detect any camera

***Error (-105: 'Unknown model')***


For debugging messages, please use the --debug option.

Debugging messages may help finding a solution to your problem.

If you intend to send any error or debug messages to the gphoto

developer mailing list , please run

gphoto2 as follows:


    env LANG=C gphoto2 --debug -P


Please make sure there is sufficient quoting around the arguments.

Zgodnie z "prośbą" konsoli(:wink:), wpisałem "env LANG=C gphoto2 --debug -P"

Dostałem kupę komunikatów kończących się na "Make sure this device is connected to the computer"(nie wiem czy podawać cały, bo sporo tego jest?) i zakończony tym komunikatem co przy poprzednim poleceniu.

Mam Camedię(Olympusa) C-860L, który jest na liście "supportowanych" przez gphoto, jest dobrze podłączona i włączona :wink:

Co robię źle/co mam zrobić?


(Czarno to widzę...) #2

digiKam (eng, pl)


(Centrumopowiastek) #3

Dzięki. Właśnie próbuje je ściągnąć(mogę zrobić "widok", ale pobrać nie chce) .

A tak przy okazji-jest jakiś graficzny program do rozpakowywania rar'ów?


(Czarno to widzę...) #4

digikam-0.7.2.tar.bz2

Ark, Karchiver, File Roller...


(Centrumopowiastek) #5

Korzystam z arka do rozpakowywania zipów, tarów etc., ale chyba nie ma tam opcji rozpakowywania rarów.


(Czarno to widzę...) #6

Poszukaj na rpm.pbone.net pakietu unrar.


(Centrumopowiastek) #7

Zwracam honor, w ark'u rzeczywiście jest opcja rozpakowywania rar'ów(tylko nie przy prawo kliku z którego korzystałem :wink: ).


Przy instalacji digikam'a dostaje komunikat:

checking for X... configure: error: Can't find X includes. Please check your installation and add the correct paths!

Że co? :?


(Czarno to widzę...) #8

Poszukaj develi dla qt.

Albo przy konfiguracji podaj ścieżkę do folderu KDE: --prefix=/opt/kde (sprawdź, gdzie masz ten katalog - ja tak mam w Slacku).

Możesz też poszukać gotowego pakietu RPM digikam - to będzie chyba najwygodniejsze rozwiązanie. No, chyba że zależy Ci na najnowszej wersji... W takim przypadku musisz kompilować/kombinować. :smiley:


(Centrumopowiastek) #9

Kiedy mam to wpisać?

W katalogu opt nie mam żadnych katalogów, mam w /home/ja/.kde i katalog /usr/lib/kde3...

Nie, przecież to Ty podałeś link do najnowszej wersji :slight_smile:


(Czarno to widzę...) #10

W katalogu opt nie mam żadnych katalogów, mam w /home/ja/.kde i katalog /usr/lib/kde3...

No tak, z tym że to są źródła, które trzeba sobie skompilować.

Najnowsza wersja to 0.7.2, a RPM dla Mandrake'a (o ile mnie pamięć nie myli, tej dystrybucji właśnie używasz) to 0.5.1:

http://mesh.dl.sourceforge.net/sourcefo ... k.i586.rpm

Jeśli nie masz chęci bawić się digikam, spróbuj jeszcze raz z gphoto. DigiKam to w końcu "tylko" nakładka graficzna na gphoto2.


(Centrumopowiastek) #11

A ja odinstalowałem DigiKama myśląc, że link do nowszej wersji podałeś, dlatego, bo jest tam rozwiązany ten problem :wink: Ale jeśli nie ma różnicy, to zainstaluję pakiet.


(Czarno to widzę...) #12

No różnice są znaczące:

in minus: stare to jest :smiley:

in plus: nie trzeba samemu kompilować :smiley: