Pod jaką wersją wine będą działaly gry motocross madness 2 i supreme comander?


(tomi001) #1

Mam takie pytanie nie wiecie może pod jaką wersją wine będą działały takie gry jak w temacie posiadam kubuntu 13.10 i moja wersja wine to 1.7.18 bo z informacji jakie posoiadam wygląda, że supreme comander powinno działać, a tymczasem jak uruchamiam to muzyka jest nie ma tylko obrazu, a jak uruchamiam motocros madness 2 to logo gry się pokazuje a dalej gra się wyłącza.


(Latający Turban) #2

Pierwsza sprawa to zaktualizuj to kubuntu bo jest mocno przestarazałe, jak chcesz kde4 to do 14.04 jak 5 to do 16.04, po drugie to na stronie appdb.winehq.org powinno być podane jakiej wersji użył tester i co dodatkowo zainstalował aby mu ta gra hulała, prawdopodobnie musisz odpalic jakiś direct bądź bibliotekę przez winetricks. Wątpie aby było ci to potrzebne przy tych grach ale podobno wersja wine-staging z włączonym csmt znacznie poprawia wydajność, poczytaj sobie o tym w goglu :wink:


(Szeryfuniu) #3

Ja od siebie polecam PlayOnLinux.

Jest tam gotowa konfiguracja do Supreme Commander.


(tomi001) #4

A jak zainstalować bilioteki windowsowe do wine wiem, że się je kopioje do katalogu system32, ale czy można je jakoś automatycznie zainstalować ?


(Latający Turban) #5

a przez winetricks próbowałeś ?

albo tak jak kolega napisał, playonlinux ma gotowe skrypty i powinien dociągnąć to co trzeba


(tomi001) #6

Próbowałem, ale wystąpił błąd teraz go nie podam bo bym musiał znowu to ponowić, a jest za dzisiaj za późno już mogło to być spowodowane tym komunikatem jak myślicie ?

 

You are using a 64-bit WINEPREFIX. If you encounter problems, please retest in a clean 32-bit WINEPREFIX before reporting a bug.

 


(Latający Turban) #7

Hm no za dużo to nie mówi. Nie mam teraz pod ręką ale tam w inetricks powinieneś mieć taką opcję jak create a clean wine prefix wtedy ustawiasz wersję na 32-bit i próbujesz od nowa


(tomi001) #8

Już wiem jaki był tam błąd chodziło o to, że jak chcę zainstalować daną bibliotekę to musze najpierw zainstalować mono, a przy próbie instalacji mono czyli jak próbowało mi się zainstalowac to pojawił się komunikat, że nie może się zainstalować na systemie 64 bitowym.


(bart86) #9

W repozytoriach ubuntu pakiet wine-mono jest w repozytoriach od wersji 14.04.


(tomi001) #10

Chciałem zainstalować wersje kubuntu 15.10, ale po instalcji był tylko system tekstowy to była wina tego, że ta wersja kubuntu nie wspiera sterówników nvidia. Najlepsze jest to, że wine-mono jest zainstalowane.


(Latający Turban) #11

no 15.10 też jest stare, dlaczego nie spróbujesz z 14.04 albo 16.04


(tomi001) #12

No bo zawsze jak aktualizowałem to coś mi sie psuło, a nie chcę mi się nowej instalacji robić.


(bart86) #13

kiedyś trzeba, albo przejdź na inne distro, Debian nigdy nie ma problemów z aktualizacją

a co do kubuntu i sterownikach nvidii to da się http://askubuntu.com/questions/698730/installing-nvidia-driver-on-kubuntu-15-10x64-the-distribution-provided-pre-inst


(tomi001) #14

A czy taka aktualizacja sudo apt-get dist-upgrade załatwi problem ?


(bart86) #15

najpierw wykonujesz “apt-get dist-upgrade” na swoim systemie aby się w pełni zaktulizował, potem dokonujesz odpowiednio aktualizację, 13.10 chyba musisz aktualizować do 14.04


(tomi001) #16

Jak miałem Kubuntu 15.04 w przeszłości to były błędy w niektórych pakietach.


(bart86) #17

teraz już jest 16.04 ale jeszcze radzę z tą wersją poczekać bo zaraz po wydaniu system ma pełno błędów ale za miesiąc nie powinno być problemów

i przy ubuntu nikt cie na silę nie trzyma