Podczas instalacji Ubu 14.04 nie widzi Windowsa 8.1


(Tojuzkoniecc) #1

Podczas instalacji Ubu 14.04 instalator nie widzi Windowsa 8.1 (pisze, że nie ma żadnego OSa). Co robić?

 


(tomeeek64) #2

Masz włączone UEFI czy Legacy BIOS? Jeżeli UEFI to Secure Boot jest aktywny czy nie?


(system) #3

Ja pamiętam jak instalowałem Ubuntu 13.10 przy włączonym Secure Boot. SB nie ma tu nic do gadania - on wcale nie przeszkadza Ubuntu. U mnie też nie wykrywał 8.1(nawet przy wyłączonym SB). W UEFI nieco inaczej już jest z bootloaderami. Nie ma już czegoś takiego jak MBR, każdy bootloader siedzi sobie w osobnym katalogu na partycji EFI. Przy uruchamianiu komputera poprostu wywołujemy boot menu i wybieramy tam system(a raczej bootloader), który chcemy uruchomić. Nie wybieraj automatycznego partycjonowania, bo najprawdopodobniej pożegnasz się z Windows. Zrób to ręcznie, to wtedy będziesz miał pewność, że nic ci nie namiesza.


(Tojuzkoniecc) #4

Mam UEFI Dual BIos. Płyta Gigabyte  H61M-DS2 DVI.

 

W ogóle jakieś “syfy” miałem w UEFI - na pierwszym miejscu miał wpisane, że powinien mi się ładować ubuntu  :), a z drugiego miejsca UEFI, z trzeciego napęd dvd. Ja tam właśnie coś namieszałem i musiałem  wczoraj reinstalować system Windows. Miałem tam inne linuksy zainstalowane i chciałem zrobić porządek. Natomiast teraz jestem ostrożny i zobaczę czy w ogóle zainstaluje Ubuntu obok Windowsa :(. Kiedyś to bez żadnych problemów szło…Popróbuję dzisiaj i jutro i dam znać…


(system) #5

Do kasowania systemu z UEFI ja akurat robię to tak - kasuję partycje z systemem i potem ręcznie uzyskuje dostęp do partycji EFI i kasuje z niej bootloader. Jeszcze nic nie zepsułem tym sposobem i komp dalej działa dobrze :slight_smile:


(Tojuzkoniecc) #6

Ale co ja mam konkretnie zrobić? Dysk mam 500GB i mam na nim zainstalowanego Windowsa 8.1.  Podzieliłem na Win 8 dwie partycje około 300GB (NTFS) i  około 150GB (exFAT).

Włączam płytę z Ubuntu 14.04 i resetuje kompa. Ubuntu nie widzi nic - brak systemu, a nawet nie widzi partycji. Instalator widzi tylko 500GB czystego dysku. Jak coś w ten sposób zainstaluję to chyba pożegnam się z Windowsem, a tego nie chcę.

 

W necie jest sporo podobnych wątków, ale nie widać sensownego rozwiązania… :frowning:

 

PS

A opcję Secure Boot każdy ma? Bo ja tego nie umiem znaleźć…

 

 

Chyba, że najpierws zainstaluję Ubuntu, a później Windowsa, ale nie wiem czy mi się aż tak babrać w to :frowning: Chyba w takiej kolejności byłoby łatwiej?


(marcin82) #7

Uruchom livecd, potem konsolę, podnieś uprawnienia:

sudo su -

Podaj wynik poleceń:

fdisk -l

parted -l

(Tojuzkoniecc) #8
ubuntu@ubuntu:~$ sudo su -
root@ubuntu:~# fdisk -l

WARNING: GPT (GUID Partition Table) detected on '/dev/sda'! The util fdisk doesn't support GPT. Use GNU Parted.


Disk /dev/sda: 500.1 GB, 500107862016 bytes
255 heads, 63 sectors/track, 60801 cylinders, total 976773168 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 4096 bytes
I/O size (minimum/optimal): 4096 bytes / 4096 bytes
Disk identifier: 0xa775c29e

   Device Boot Start End Blocks Id System
/dev/sda1 * 2048 718847 358400 7 HPFS/NTFS/exFAT
/dev/sda2 718848 627048447 313164800 7 HPFS/NTFS/exFAT
/dev/sda3 627048448 976769023 174860288 7 HPFS/NTFS/exFAT
root@ubuntu:~# parted -l
Warning: /dev/sda contains GPT signatures, indicating that it has a GPT table.
However, it does not have a valid fake msdos partition table, as it should.
Perhaps it was corrupted -- possibly by a program that doesn't understand GPT
partition tables. Or perhaps you deleted the GPT table, and are now using an
msdos partition table. Is this a GPT partition table?
Yes/No?

(A2710373) #9

Masz partycje GPT zastosuj taki myk

1.Proszę utwórz partycję " BIOS-Boot" (większą niż>1MB, nie formatuj tej partycji, bios_grub flaga). Możesz to osiągnąć używając na przykład: Gparted (z liveUSB). Następnie spróbuj ponownie instalacji ale nie wybieraj automatycznego partycjonowania . Pamiętaj że możesz mieć tylko 4 partycje podstawowe na jednym dysku

 

2.Wyłącz tez Fastboot w Biosie

 

3.Zainstaluj System na dysku.  Gdyby Ubuntu nie wstał uruchom LiveUSB z Ubuntu 14.04 i wykonaj polecenie które powinno naprawic Gruba na dysku

sudo add-apt-repository ppa:yannubuntu/boot-repair
sudo sed 's/trusty/saucy/g' -i /etc/apt/sources.list.d/yannubuntu-boot-repair-trusty.list
sudo apt-get update
sudo apt-get install -y boot-repair && (boot-repair &)

https://help.ubuntu.com/community/Boot-Repair#A2nd_option_:_install_Boot-Repair_in_Ubuntu


(system) #10

@UP: Po co ma tworzyć partycję EFI(inaczej też BIOS Boot), skoro ma Windows 8.1, który już napewno też korzysta z takiej partycji.

 

Jak ja instalowałem Ubuntu(wersje 13.10, w 14.04 powinno być tak samo) to przed uruchomieniem instalatora wydzieliłem miejsce z partycji Windows, potem uruchomiłem instalator, przy partycjonowaniu wybrałem ręczne, utworzyłem partycję / na wolnym miejscu(jak masz mniej niż jakieś 3GB RAM, albo chcesz mieć hibernacje, to utwórz też partycję swap, do hibernacji musi mieć ona taki rozmiar jak ilość RAM), wogóle nie ruszałem innych partycji, potem dałem dalej i się zainstalowało. W UEFI nieco inaczej działa wybór systemu. Domyślnie uruchamia się Windows 8, jak chcesz uruchomić Linux, to musisz wcisnąć klawisz odpowiedzialny za boot menu i w nim wybrać odpowiednią pozycję, co uruchomi GRUB’a. Niestety nie mam pojęcia jak ustawić, aby GRUB startował domyślnie.


(Jusko) #11

 

Tu nie będzie problemu - wystarczy podczas uruchomienia komputera wskoczyć jak biosu, i ustalić kolejność bootowania. Ale nie odpowiadam za wszystkie (U)EFI tego świata :wink:


(A2710373) #12

@to_juz_koniec

 

Możesz pokazać nam zrzut ekranu z Gparted to się przekonamy jak wygląda ta partycja  EFI u ciebie