Połączenie poprzez OpenVPN


(Uzi123) #1

Wyjechałem na tydzień do Francji i próbuje się połączyć z hotelu przez VPN (korzystam z OpenVPN+GUI) Uruchamiam jak zawsze GUI, podaje hasło, następuje próba logowania i koniec, program próbuje się bezskutecznie połączyć. Wcześniej korzystałem dokładnie tak samo z VPN w kilku miejscach w Polsce i Dani, nigdy nie miałem problemu. Nie posiadam logów z tamtych logowań, więc nie za bardzo mam z czym porównać. Obecnie logi są następujące:

Mon Sep 20 19:55:45 2010 OpenVPN 2.1_rc7 Win32-MinGW [SSL] [LZO2] [PKCS11] built on Jan 29 2008

Mon Sep 20 19:55:45 2010 WARNING: No server certificate verification method has been enabled. See http://openvpn.net/howto.html#mitm for more info.

Mon Sep 20 19:55:48 2010 LZO compression initialized

Mon Sep 20 19:55:48 2010 Control Channel MTU parms [L:1542 D:138 EF:38 EB:0 ET:0 EL:0]

Mon Sep 20 19:55:48 2010 Data Channel MTU parms [L:1542 D:1450 EF:42 EB:135 ET:0 EL:0 AF:3/1]

Mon Sep 20 19:55:48 2010 Local Options hash (VER=V4): '41690919'

Mon Sep 20 19:55:48 2010 Expected Remote Options hash (VER=V4): '530fdded'

Mon Sep 20 19:55:48 2010 Socket Buffers: R=[8192->8192] S=[8192->8192]

Mon Sep 20 19:55:48 2010 UDPv4 link local: [undef]

Mon Sep 20 19:55:48 2010 UDPv4 link remote: abc.abc.ab.ab:1194

Mon Sep 20 19:56:48 2010 TLS Error: TLS key negotiation failed to occur within 60 seconds (check your network connectivity)

Mon Sep 20 19:56:48 2010 TLS Error: TLS handshake failed

Mon Sep 20 19:56:48 2010 TCP/UDP: Closing socket

Mon Sep 20 19:56:48 2010 SIGUSR1[soft,tls-error] received, process restarting

Mon Sep 20 19:56:48 2010 Restart pause, 2 second(s)

Mon Sep 20 19:56:50 2010 WARNING: No server certificate verification method has been enabled. See http://openvpn.net/howto.html#mitm for more info.

Mon Sep 20 19:56:50 2010 Re-using SSL/TLS context

Mon Sep 20 19:56:50 2010 LZO compression initialized

Mon Sep 20 19:56:50 2010 Control Channel MTU parms [L:1542 D:138 EF:38 EB:0 ET:0 EL:0]

Mon Sep 20 19:56:50 2010 Data Channel MTU parms [L:1542 D:1450 EF:42 EB:135 ET:0 EL:0 AF:3/1]

Mon Sep 20 19:56:50 2010 Local Options hash (VER=V4): '41690919'

Mon Sep 20 19:56:50 2010 Expected Remote Options hash (VER=V4): '530fdded'

Mon Sep 20 19:56:50 2010 Socket Buffers: R=[8192->8192] S=[8192->8192]

Mon Sep 20 19:56:50 2010 UDPv4 link local: [undef]

Mon Sep 20 19:56:50 2010 UDPv4 link remote: abc.abc.ab.ab:1194

Ping do serwera abc.abc.ab.ab działa bez problemów. Nie za bardzo wiem w czym może być problem. W ostatnim czasie nie instalowałem nic na komputerze. Nie miałem też informacji o zmianach od administratora serwerów (ale nie mogę tego jednoznacznie wykluczyć).


(Bor1904) #2

Co jeśli router w hotelu nie obsługuje VPN passthrow albo ma to wyłączone?


(Uzi123) #3

Też się spodziewałem, że może być to wina routera. Czy da się to jakoś sprawdzić/obejść?


(Bor1904) #4

W sprawach VPN jestem tylko teoretykiem, jednak wszystko mi mówi, że będzie cieżko coś takiego obejść...

pzdr


(Monczkin) #5

uzi123 , nazwij proszę temat konkretnie, bez zbędnych problemów w tytule. Inaczej wyciągnę konsekwencje. Przeczytaj proszę ten temat. viewtopic.php?f=16&t=394978