Polskie znaki HTML- problem


(Igorbugajski2) #1

Mam problem.

Otóż moja strona nie wyświetla poprawnie polskich znaków.

Nagłówek wygląda tak:

STCG.pl - O grze

Jeśli ktoś do stwierdzenia, w czym leży problem, potrzebuje więcej kodu, niech napisze. Może być nawet cały, jest dość krótki. :wink: Dodam jeszcze, że strona główna wyświetla wszystko poprawnie, linijkę

(bo doczytałem się, że to ona jest odpowiedzialna za polskie znaki :wink:) wykasowałem i wkleiłem ze strony głównej.

Nie pomogło. :frowning:


(kamil_w) #2

A plik html jaki ma format znaków? Sama deklaracja nie wystarczy. Trzeba również plik tekstowy zapisać z danym formatem znaków.

Zmień

na

Otwórz plik w Notepadzie++

Z paska menu wybierz "Format", a następnie "konwertuj do UTF-8".

Zapisz plik.

Powinno działać.


(pain3hp) #3
charset=utf8

(Igorbugajski2) #4

Wciąż nie działa. :frowning:


(kamil_w) #5

A tam nie działa. Wyślij mi na PW plik z kodem.


(Igorbugajski2) #6

A co to PW? :lol: :lol: :smiley:


(R@z0r) #7

Jak nie działa to robisz coś, źle, musi działać. Zmieniłeś znaki po samym zmienianiu kodowania. Najlepiej wszystko wyciąć zmienić kodowanie i wkleić z powrotem.


(Igorbugajski2) #8

R@z0r, uratowałeś moją stronę. :lol:


(kamil_w) #9

Kliknij w nazwę mojego konta i tam masz PW: Wyślij prywatną wiadomość.

Ewentualnie wrzuć tu link do pliku.


(system) #10

TUTAJ

"charset=iso-8859-2"

zmień "iso-8859-2"

na UTF-8

w iso nie ma polskich znaków, a w UTF są. zobacz w notatniku


(kamil_w) #11

@GuiiHz

Piszesz tylko po to, żeby sobie zwiększyć ilość wypowiedzi? Przecież:

a. już wcześniej poleciliśmy zmianę na utf8,

b. w iso-8859-2 są polskie znaki więc głupoty piszesz.


(system) #12

tam było utf8.

Ja napisałem utf-8,

a to co innego