Polskie znaki w "ostanio na forum" phpbb3


(Feelek3) #1

Witam,

Znalazłem taki skrypt:

<?php


// USTAWIENIA


// (t) ilość wyświetlanych tematów

$default_tps_number = 10;

// (w) długość tytułów

$default_tps_title_width = 60;

// (s) miejsce, w jakim zostanie otwarty temat; topic - początek tematu, post - ostatni post

$default_tps_show = 'post';

// (p) miejsce wyświetlania tematu

$default_tps_display_place = '_blank';

// (a) pokazuje liczbe odpowiedzi; 1 - tak, 0 - nie

$default_show_answers = 1;

// (u) pokazuje autora postu; 2 - ostatniego, 1 - pierwszego, 0 - nie pokazuje autora

$default_show_posters = 0;

// (f) pokazuje nazwę forum, w którym znajduję się temat; 1 - tak, 0 - nie

$default_show_forumname = 0;


$adres_forum = 'http://adresforum.pl';

// adres forum bez końcowego "/", z "http://" na początku


// KONIEC USTAWIEN


if($_GET['t']) { $t = $_GET['t']; } else { $t = $default_tps_number; }

if($_GET['w']) { $w = $_GET['w']; } else { $w = $default_tps_title_width; }

if($_GET['s']) { $s = $_GET['s']; } else { $s = $default_tps_show; }

if($_GET['p']) { $p = $_GET['p']; } else { $p = $default_tps_display_place; }

if($_GET['a']) { $a = $_GET['a']; } else { $a = $default_show_answers; }

if($_GET['u']) { $u = $_GET['u']; } else { $u = $default_show_posters; }

if($_GET['f']) { $f = $_GET['f']; } else { $f = $default_show_forumname; }


include 'config.php';


if(!$db = mysql_connect($dbhost, $dbuser, $dbpasswd)) {

echo 'Błąd!
Nie można połączyć się z bazą!';

}

if(!mysql_select_db($dbname, $db)) {

echo 'Błąd!
Nie można wybrać bazy danych!';

}


$result = mysql_query("SELECT * FROM `". $table_prefix ."topics` WHERE forum_id ORDER BY `topic_last_post_id` DESC LIMIT 0 , ". $t);


while($row = mysql_fetch_array($result))

{

   $out_title = ''. $row['topic_title'] .'';

   if( $f ) {

      $result_forum = mysql_query("SELECT `forum_name` FROM `". $table_prefix ."forums` WHERE `forum_id` = '". $row['forum_id'] ."'");

      $row['forum_name'] = mysql_result($result_forum, 0);

      $out_forum = '['. $row['forum_name'] .'] ';

   }

   if( $a ) {

      $out_answers = ' ';

   }

   if( $u ) {

      switch($u) {

         case 2:

         $poster[0] = $row['topic_last_poster_id'];

         $poster[1] = $row['topic_last_poster_name'];

         break;


         case 1:

         $poster[0] = $row['topic_poster'];

         $poster[1] = $row['topic_first_poster_name'];

         break;

      }

      $out_poster = ' ['. $poster[1] .']';

   }

   if(strlen($row['topic_title']) > $w) { $row['topic_title'] = substr($row['topic_title'], 0, $w); }


   $output .= $out_forum . $out_title . $out_answers . $out_poster .'
';

}


echo $output;

mysql_close($db);

?>[/code]

Niestety nie mam pojęcia jak zrobić polskie znaki :frowning:

Siedzę już przed tym kilka godzin. Próbowałem zmieniać kodowanie z ISO-8859-2 na UTF-8, niestety to nic nie dało :frowning:

Próbowałem też dodawać to, lub z UTF-8 (zależy od kodowanie strony)

[code]

Próbowałem też zmienienia kodowanie w pliku session.php forum, niestety bez skutku.

Pozdrawiam i liczę na pomoc :slight_smile:


(Paweł3779) #2

Jeśli nie próbowałeś tego to spróbuj kodować to w UTF-8 (bez BOM).

Kodowanie musi być takie same jak w plikach forum. :slight_smile:


(Feelek3) #3

Niestety to nic nie dało :frowning: