Pomocy przy instalowaniu sterownków


(wojownik) #1

witam walcze z ubuntu tym razem6.12

za nic nie mogę zainstalować sterownikow do grafiki (gf6150) prubowałem wszelakich spowobów, recepty z google, linki wszystko,

automatixy easyubuntu hakix i nic nie pomaga

zrobilem tak jak wczoraj mi napisano

wojownik@wojownik:~$ sudo apt-get install nvidia-glx

Czytanie list pakietów... Gotowe

Budowanie drzewa zależności

Reading state information... Gotowe

Sugerowane pakiety:

nvidia-settings nvidia-kernel-source

Zostaną zainstalowane następujące NOWE pakiety:

nvidia-glx

0 aktualizowanych, 1 nowo instalowanych, 0 usuwanych i 713 nieaktualizowanych.

Konieczne pobranie 3294kB archiwów.

Po rozpakowaniu zostanie dodatkowo użyte 10,9MB miejsca na dysku.

UWAGA: Następujące pakiety nie mogą zostać zweryfikowane!

nvidia-glx

Zainstalować te pakiety bez weryfikacji [t/N]? t

Pob: 1 http://ftp.debian.org etch/non-free nvidia-glx 1.0.8776-4 [3294kB]

Pobrano 3294kB w 1m20s (41,1kB/s)

Zaznaczenie poprzednio niezaznaczonego pakietu nvidia-glx.

(Odczytywanie bazy danych ... 94938 plików i katalogów obecnie zainstalowanych.)

Rozpakowanie nvidia-glx (z .../nvidia-glx_1.0.8776-4_i386.deb) ...

Konfigurowanie nvidia-glx (1.0.8776-4) ...

Creating NVIDIA TLS links... done.

pomocy! !!


(Vader481) #2

Może skrypt envy ci pomoże?? Ten skrypt jest całkiem fajny - i oszczędza nerwy :smiley:


(matiit) #3
sudo gedit /etc/X11/xorg.conf

zmień nv na nvidia

poszukaj load "dri" i load "GLcore"

może ale nie musi być i wywal je albo daj przed nimi #


#4

wojownik , z tego co pokazałeś wynika, że sterowniki się zainstalowały. Zmień teraz w /etc/X11/xorg.conf wpis dotyczący sterownika (nv lub vesa - nie wiem co miałeś wcześniej) na nvidia i powinno działać.


(wojownik) #5

u mnie nie było -nv-tylko -vensa- ,zastapilem,usunelem load dri ,tego 2 co podałeś nie widzialem ,plik zapisalem wygląda tak

/etc/X11/xorg.conf (xorg X Window System server configuration file)

This file was generated by dexconf, the Debian X Configuration tool, using

values from the debconf database.

Edit this file with caution, and see the /etc/X11/xorg.conf manual page.

(Type "man /etc/X11/xorg.conf" at the shell prompt.)

This file is automatically updated on xserver-xorg package upgrades *only*

if it has not been modified since the last upgrade of the xserver-xorg

package.

If you have edited this file but would like it to be automatically updated

again, run the following command:

sudo dpkg-reconfigure -phigh xserver-xorg

Section "Files"

FontPath "/usr/share/X11/fonts/misc"

FontPath "/usr/share/X11/fonts/cyrillic"

FontPath "/usr/share/X11/fonts/100dpi/:unscaled"

FontPath "/usr/share/X11/fonts/75dpi/:unscaled"

FontPath "/usr/share/X11/fonts/Type1"

FontPath "/usr/share/X11/fonts/100dpi"

FontPath "/usr/share/X11/fonts/75dpi"

FontPath "/usr/share/fonts/X11/misc"

path to defoma fonts

FontPath "/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType"

EndSection

Section "Module"

Load "i2c"

Load "bitmap"

Load "ddc"

Load "dri"

Load "extmod"

Load "freetype"

Load "glx"

Load "int10"

Load "type1"

Load "vbe"

EndSection

Section "InputDevice"

Identifier "Generic Keyboard"

Driver "kbd"

Option "CoreKeyboard"

Option "XkbRules" "xorg"

Option "XkbModel" "pc105"

Option "XkbLayout" "pl"

Option "XkbOptions" "lv3:ralt_switch"

EndSection

Section "InputDevice"

Identifier "Configured Mouse"

Driver "mouse"

Option "CorePointer"

Option "Device" "/dev/input/mice"

Option "Protocol" "ExplorerPS/2"

Option "ZAxisMapping" "4 5"

Option "Emulate3Buttons" "true"

EndSection

Section "InputDevice"

Identifier "Synaptics Touchpad"

Driver "synaptics"

Option "SendCoreEvents" "true"

Option "Device" "/dev/psaux"

Option "Protocol" "auto-dev"

Option "HorizScrollDelta" "0"

EndSection

Section "InputDevice"

Driver "wacom"

Identifier "stylus"

Option "Device" "/dev/wacom" # Change to

/dev/input/event

for USB

Option "Type" "stylus"

Option "ForceDevice" "ISDV4" # Tablet PC ONLY

EndSection

Section "InputDevice"

Driver "wacom"

Identifier "eraser"

Option "Device" "/dev/wacom" # Change to

/dev/input/event

for USB

Option "Type" "eraser"

Option "ForceDevice" "ISDV4" # Tablet PC ONLY

EndSection

Section "InputDevice"

Driver "wacom"

Identifier "cursor"

Option "Device" "/dev/wacom" # Change to

/dev/input/event

for USB

Option "Type" "cursor"

Option "ForceDevice" "ISDV4" # Tablet PC ONLY

EndSection

Section "Device"

Identifier "Generic Video Card"

Driver "nvidia"

BusID "PCI:0:5:0"

EndSection

Section "Monitor"

Identifier "Generic Monitor"

Option "DPMS"

EndSection

Section "Screen"

Identifier "Default Screen"

Device "Generic Video Card"

Monitor "Generic Monitor"

DefaultDepth 24

SubSection "Display"

Depth 1

Modes "1024x768" "800x600" "640x480"

EndSubSection

SubSection "Display"

Depth 4

Modes "1024x768" "800x600" "640x480"

EndSubSection

SubSection "Display"

Depth 8

Modes "1024x768" "800x600" "640x480"

EndSubSection

SubSection "Display"

Depth 15

Modes "1024x768" "800x600" "640x480"

EndSubSection

SubSection "Display"

Depth 16

Modes "1024x768" "800x600" "640x480"

EndSubSection

SubSection "Display"

Depth 24

Modes "1024x768" "800x600" "640x480"

EndSubSection

EndSection

Section "ServerLayout"

Identifier "Default Layout"

Screen "Default Screen"

InputDevice "Generic Keyboard"

InputDevice "Configured Mouse"

InputDevice "stylus" "SendCoreEvents"

InputDevice "cursor" "SendCoreEvents"

InputDevice "eraser" "SendCoreEvents"

InputDevice "Synaptics Touchpad"

EndSection

Section "DRI"

Mode 0666

EndSection

Złączono Posta : 22.03.2007 (Czw) 20:11

oczywiście nie mogę ustawić oświerzania


#6

A zrestartowałeś iksy?

EDIT:

Czasami restart iksów nic nie daje, ponieważ nie jest załadowany moduł nvidia. W takim wypadku można załadować go ręcznie (modprobe nvidia) lub po prostu zrestartować system)


(matiit) #7

to będzie coś z monitorem pewnie

Jaki masz monitor ??

Trzeba zmienić hsync i vsync


(wojownik) #8

używam laptopa takiego jak w opiosie ,przekatna 15 cali

Złączono Posta : 22.03.2007 (Czw) 20:17

nie nie wiem co to nawet oznacza zrestartować iksy -jak ?

prosze pomóż


(matiit) #9

hmmm a po wykonaniu tych czynności w ogóle zresestowałeś Xy ??

naciśnij alt+ctrl+delete

poprawka alt+ctr+backspace

dzięki za poprawę areh

przyzwyczajenie :smiley: - duzo cześciej w życiu naciskałem alt+ctrl+delete


#10

Raczej backspace. Dodatkowo alt i ctrl lewe.


(wojownik) #11

nie zdążyłem zrobić tak jak napisaliscie uruchomilem ponownie

bębęki zagrały i wszystko jest na czarno,co dalej czy to już koniec czy tak miało być a ja nie wiem co dalej


#12

Czyli zmieniło Ci rozdzielczość, tylko na tak, której Twoja matryca nie obsługuje. Odpal system w trybie safemode (czy jak to się tam w Ubuntu nazywa) i popraw wpisy dotyczące rozdzielczości w /etc/X11/xorg.conf


(wojownik) #13

ale co poprawić i na co :frowning:

Złączono Posta : 22.03.2007 (Czw) 20:49

mam recowery mode klikam na niego na ekranie pojawiaja sie jakieś cyfry sa caly czas takie same , w dól ,informacje o kompie, a na dole jest migający kursor, nic nie można tam napisac

jak przejść do trybu graficznego czy do konsoli by poprawic wpis ,i co na co mam zamienić ???????????

Złączono Posta : 23.03.2007 (Pią) 23:23

czemu nikt nie chce mi pomóc


(Klaudiuszwitczak) #14

Może to ci pomoże UBUNTU.PL. A bliżej to prawdopodobnie TEGO szukasz.