Poniżej 60 fps , lekkie przycinki , czym są spowodowane?


(Kubusiek 01onet Eu) #1

witam, mam taki problem , gdy gram w borderlands 2 i jest 60 fps to chodzi płynnie a gdy spadnie po niżej 60 to się przycina , czym to jest spowodowane ?

sprzęt :

gtx 660 ti

intel i 5 3470

8gb ram .

z góry dzięki za pomoc .

-- Dodane 19.11.2013 (Wt) 22:07 --

i dodam, że występowało to jeszcze w kilku gierkach, występuję to chyba wtedy gdy jest poniżej 60 fps , a przecież zacinanie powinno być od 25 fps .


(adamok) #2

Wyłącz synchronizację pionową w grach ( VSYNC ).


(sadaj72) #3

To nie do końca prawda, ale to już pewnie sam kiedyś zauważysz.

Wyłączenie synchronizacji powinno pomóc, ale możesz spotkać się z tearingiem.


(Zelazkom) #4

Witaj,

Całkowita płynność przy monitorze 60Hz to tylko i wyłącznie 60FPS.

Liczba 24FPS to granica płynności - poniżej tej wartości można mówić co najwyżej o pokazie slajdów. Do tego dochodzi jeden ważny warunek - dla tej wartości odstępy pomiędzy każdą klatką muszą być równe.

W przypadku gier komputerowych, kiedy karta nie wyrabia (czyli nie da rady wyświetlać stałych 60FPS), pojawia się efekt tzw. micro stuttering - czyli efekt zwalniania, pomimo teoretycznie wysokiej liczby klatek/sekundę np. 55. Bierze się to z faktu, że program wyświetlający wartość FPS liczy średnią z całej sekundy, ale odstępy pomiędzy klatkami nie są równe. Dajmy na to:

Przez pierwsze 0,5 sekundy obraz wyświetlał się ze średnio 90FPS

Przez drugie 0,5 sekundy obraz wyświetlał się ze średnio 20FPS

Średnia z całej sekundy wynosi (90 + 20) / 2 = 110 / 2 = 55FPS

Jak widać powyżej, mimo 55FPS efekt końcowy renderowania sceny nie będzie zbyt zadowalający, z powodu lagów co 0,5 sekundy.


(Kubusiek 01onet Eu) #5

a może być to wina monitora ? bo mam stary , z 6 lat ma :slight_smile: LG flatron l1753s.

-- Dodane 20.11.2013 (Śr) 17:13 --

i zauważyłem, że występuję to na minimalnych jak i najwyższych ustawieniach, wyłaczenie vsync nic nie dało. oczywiście chodzi mi o grę borderlands 2, i spadek fpsów jest kolosalny dopiero w momencie jakiejś akcji... a nie powinno ciąć na taki sprzęcie .

p.s przy akcji fps`y spadają z ponad 100 do 40 i zaczyna się cięcie ( oczywiście po akcji , wszystko wraca do normy)

-- Dodane 20.11.2013 (Śr) 17:14 --

Wielkość plamki 0,264 mm

Zalecana rozdzielczość obrazu 1280 x 1024 pikseli

Częst. odświeżania przy zalecanej rozdzielczości 60 Hz

Częstotliwość odchylania poziomego 30-83 kHz

Częstotliwość odchylenia pionowego 56-75 Hz

Czas reakcji matrycy 5 ms

to są parametry z mojego monitora .

-- Dodane 20.11.2013 (Śr) 17:40 --

czyli moja karta jest za słaba na tą grę ?


(Zelazkom) #6

Nie sądzę żeby karta była za słaba na tą grę. Odpowiedziałem tylko na pytanie.

Spróbuj zmniejszyć ustawienia graficzne. VSync zostawiłbym włączony.


(Kubusiek 01onet Eu) #7

zmiana ustawień graficznych nic nie daję , i tak gdy zaczyna się akcja zaczyna się klatkowanie .


(X Zdzislawx) #8

Po pierwsze - zaktualizuj sterowniki do karty graf -> http://www.nvidia.pl/Download/index.aspx?lang=pl

Po drugie - wyłącz VSYNC również w panelu ustawień karty graficznej (bo tam możesz mieć też ustawione).

Tak się zastanawiam nad "obliczeniami" thegroke

Z jakiej racji na koniec dzielisz przez 2? Przecież skoro przez 0,5s jest 90FPS, a później przez 0,5s jest 20 FPS to łącznie daje to 110FPS i już się tego nie dzieli na 2! !!


(Kubusiek 01onet Eu) #9

Stery najnowsze, spróbuję z Tym Vsync w panelu, a co wgl daję ten vsync ?

-- Dodane 22.11.2013 (Pt) 14:46 --

i pytanie , jak to wyłączyć w tym panelu ? : >

-- Dodane 22.11.2013 (Pt) 14:50 --

A i wyłączenie vsync w grze nic nie daję , pewna osoba podrzuciła mi pomysł, aby wyłączyć antywirusa, jak to zrobić ? bo nie widzę takiej opcji a w procesach nie ma ( AVG antywirus)


(X Zdzislawx) #10

W panel wchodzisz następująco: obok zegarka masz taki znaczek nvidii lub strzałkę rozwijasz i kilkasz. Tam w opcjach już poszukaj, pewnie będzie coś w stylu ustawienia gier, szukaj czegoś o nazwie VSYNC lub synchronizacja pionowa. Co do antywirusa, to najlepszą metodą będzie wyłączenie go z autostartu: uruchom -> msconfig -> uruchamianie -> tam znajdujesz i odznaczasz (tylko później nie zapomnij znowu włączyć). Kolejna możliwość to przegrzewanie się podzespołów. Pobierz HWMonitor, odpal i pozostaw włączonego, pograj dość sporo i jeśli będzie się ścinać to po dłuższej chwili zobacz na temperatury z kolumny Max. Co do VSYNC to nie chce mi się już tego tłumaczyć... wpisz sobie w google albo wiki.


(Kubusiek 01onet Eu) #11

nie mam takiej opcji z VSYNC :frowning: w żadnym paneliz nvidia , zarówno w wpanelu sterowania nvidia jak w nvidia experience .


(Zelazkom) #12

(Kubusiek 01onet Eu) #13

temperatura po jakichś 30 min grania to :

procek maximum 50 *C

grafika : 54 *C

-- Dodane 23.11.2013 (So) 12:48 --

ustawienia Physix ? a gdzie takie coś zmienię ?


(Zelazkom) #14

Ostatnia opcja (PhysX Effects) na tym rysunku: Borderlands 2 Video Settings


(Kubusiek 01onet Eu) #15

aa w grze, niestety nic to nie pomagało :slight_smile: gra chodzi na najwyższych tak samo jak na najniższych . :slight_smile:

-- Dodane 23.11.2013 (So) 14:04 --

aa w grze, niestety nic to nie pomagało :slight_smile: gra chodzi na najwyższych tak samo jak na najniższych . :slight_smile:

-- Dodane 25.11.2013 (Pn) 18:21 --

Nikt już nie ma pojęcia na ten temat ? :frowning: