Poprawna aktualizacja manjaro 15.12 KDE


(izok1980) #1

Witam wczoraj naszła mnie cheć na system Manjaro pobrałem najnowsze stabilne wydanie 15.12 KDE system się zainstalował ale problem miłem z aktualizacjami chodziło o jakiś pęk kluczy skorzystałem z tego poradnika http://manjaro.pl/forum/topic/aktualizacja-systemu-sypie-bledami/ niestety bez rezultatu...tu kolejne niby rozwiązanie i identyczne błędy http://manjaro.pl/forum/topic/problem-z-aktualizacja/  również nie przyniosło to efektu instalowałem system wczoraj dwa razy aktualizacje zawsze się kończyły błędami. Aktualizacja z terminala też bez rezultatu.Dzisiaj zainstalowałem 3 raz system na czyto bez aktualizowania octopi pokazuje,że jest 676 aktualizacji i miga na czerwono ten "ludzik" ktoś zechciał by pomóc ?

Pozdrawiam.


(rpm) #2

Nie wiem skąd pobrałeś to stabilne wydanie, ale na  ich stronie głównej pokazuje że stabilnym wydaniem Manjaro-KDE jest wersja 16.06.

http://manjaro.github.io/download/


(izok1980) #3

Pobrałem ze strony linuxiarze.pl i jeśli nawet mam 15.12 to powinno się zaktualizować bez problemu do 16.06

Edycja: aktualizuję system za pomocą polecenia sudo pacman -Syyu dam znać co wyszło.


(ubuuser) #4

Manjaro 16.06 będzie (jak sam numer wskazuje) wydane w czerwcu. Teraz to jest Manjaro 16.06 pre 3. Mimo że to jeszcze pre, jest stabilne i można używać.

Autor tematu niech spojrzy tutaj:

http://www.wykop.pl/wpis/17189423/zainstalowalem-manjaro-przy-aktualizacji-systemu-w/


(izok1980) #5

Dziękuję za odp ale ten wątek też wczoraj własnie przeglądałem niestety system się nie zaktualizował.Natknąłem sie jeszcze na taki trik i też nie wiem czy zda egzamin obecnie aktualizuję system za pomocą terminala komendą sudo pacman -Syyu zobaczymy co wyjdzie bo za pomocą octopi nie da się zaktualizować na milion procent.

 

Zanim system zaczął się aktualizować w terminalu widnieją takie wpisy

Ufamy, że lokalny administrator udzielił odpowiedniego szkolenia.
Zwykle sprowadza się ono do tych trzech rzeczy:

    1) należy respektować prywatność innych,
    2) należy myśleć przed pisaniem,
    3) z dużą władzą wiąże się duża odpowiedzialność.

[sudo] hasło użytkownika spejson:
:: Synchronizowanie baz danych z pakietami…
 core                     135,8 KiB  77,3K/s 00:02 [###################] 100%
 extra                   1935,7 KiB   293K/s 00:07 [###################] 100%
 community                  3,7 MiB   184K/s 00:21 [###################] 100%
 multilib                 186,9 KiB  93,7K/s 00:02 [###################] 100%
:: Some packages should be upgraded first…
rozwiązywanie zależności…
szukanie sprzecznych pakietów…

Pakiety (1) manjaro-system-20160301-1

Do pobrania:             0,02 MiB
Do zainstalowania:       0,00 MiB
Zmiana po aktualizacji:  0,00 MiB

:: Kontynuować instalację? [T/n] t
:: Pobieranie pakietów…
 manjaro-system-2016…    15,9 KiB  36,4K/s 00:00 [###################] 100%
(1/1) sprawdzanie kluczy w bazie                   [###################] 100%
(1/1) sprawdzanie spójności pakietów               [###################] 100%
(1/1) wczytywanie listy plików                     [###################] 100%
(1/1) sprawdzanie konfliktów plików                [###################] 100%
(1/1) aktualizowanie manjaro-system                [###################] 100%
==> Fix sddm …
rozwiązywanie zależności…
szukanie sprzecznych pakietów…

Pakiety (1) sddm-0.13.0-2.3

Do pobrania:             3,85 MiB
Do zainstalowania:       5,07 MiB
Zmiana po aktualizacji:  0,13 MiB

:: Kontynuować instalację? [T/n]
:: Pobieranie pakietów…
pobieram sddm-0.13.0-2.3-x86_64.pkg.tar.xz…
pobieram sddm-0.13.0-2.3-x86_64.pkg.tar.xz…
pobieram sddm-0.13.0-2.3-x86_64.pkg.tar.xz…
pobieram sddm-0.13.0-2.3-x86_64.pkg.tar.xz…
pobieram sddm-0.13.0-2.3-x86_64.pkg.tar.xz…
sprawdzanie bazy kluczy…
sprawdzanie spójności pakietów…
wczytywanie plików pakietu…
sprawdzanie konfliktów plików…
aktualizowanie sddm…
ostrzeżenie: brakująca blokada pliku /var/lib/pacman/db.lck

:: Rozpoczynanie pełnej aktualizacji systemu…
:: Zastąpić akonadi-client przez extra/akonadi? [T/n] t
:: Zastąpić kcm-msm przez extra/manjaro-settings-manager-kcm? [T/n] t
:: Zastąpić oxygen-cursors przez extra/oxygen? [T/n] t
rozwiązywanie zależności…
szukanie sprzecznych pakietów…
ostrzeżenie: wykryto cykl zależności:
ostrzeżenie: freetype2 zostanie zainstalowane przed zależnościami harfbuzz
ostrzeżenie: wykryto cykl zależności:
ostrzeżenie: freetype2 zostanie zainstalowane przed zależnościami harfbuzz
ostrzeżenie: wykryto cykl zależności:
ostrzeżenie: lib32-harfbuzz zostanie zainstalowane przed zależnościami lib32-freetype2
ostrzeżenie: wykryto cykl zależności:
ostrzeżenie: lib32-harfbuzz zostanie zainstalowane przed zależnościami lib32-freetype2

 

Niestety aktualizacja się nie powiodła wynik z konsoli :

(725/725) sprawdzanie kluczy w bazie               [###################] 100%
pobieranie potrzebnych kluczy…
błąd:  key “8DB9F8C18DF53602” could not be looked up remotely
błąd:  brak wymaganego klucza w pęku kluczy
błąd:  nie udało się dokonać transakcji (niespodziewany błąd)
Wystąpiły błędy, nie zaktualizowano żadnego pakietu.
[spejson@spejson-pc ~]$

Edycja: rozwiązaniem problemu okazało się:

sudo pacman -Sy archlinux-keyring manjaro-keyring

sudo pacman -Syu