Poprawne uruchomienie Ipla na Openboksie + Arch


(Adrian 1987) #1

Witam.

Udało mi się uruchomić Ipla Lite na Archu + Openbox jednak nie do końca bo wygląda tak:

screenshot2010021116142.th.jpga z uruchomionym xcompmgr całkiem nie widać.

Błędy jakie wypluwa to:

Uruchamiam przez:

cd /opt/ipla

adobe-air iplalite.air

lub

/opt/adobe-air-sdk/bin/adl -nodebug /opt/ipla/META-INF/AIR/application.xml /opt/ipla

Nie pluje się, że to nie GNOME/KDE bo do autostartu dodałem :

export GNOME_DESKTOP_SESSION_ID="openbox"

i przed uruchomieniem w konsoli wpisuję:

source /etc/X11/xinit/xinitrc.d/30-dbus

Ciekawe dlaczego nie ma

/etc/opt/Adobe/certificates/crypt//config.xml

.

Tak sobie myślę, że jeśli udało się uruchomić to coś można zakombinować aby uruchomić poprawnie.

Nie piszę na polskim forum Arch bo nie mogę się zalogować a odzyskiwanie hasła też nie pomaga.


(roobal) #2

Miałem kiedyś próbować uruchomić Iplę na Fluxboksie ale nie mam za bardzo na to czasu. Gdy uruchamiasz Iplę pod Openboksem to Ipla korzysta z GnomeKeyRings? Być może to jest kluczem do sukcesu :slight_smile:

Pozdrawiam!


(Adrian 1987) #3

Tak, korzysta. To raczej Adobe Air wymaga gnomekeyrings, tak mi się kojarzy bo na KDE Adoba Air uruchamia kdewallet (czy jak mu tam). Wpisuję hasło i uruchamia się czarna Ipla. Kiedy g.keyrings się niu uruchamiał to też wyskakiwało w terminalu.

-- Dodane 14.06.2010 (Pn) 23:07 --

Ipla działa już na menadżerach okien innych niż z GNOME i KDE SC !!

Wystarczy zrobić to co jest napisane w pierwszym poście.

Najlepiej dodać w menu ścieżkę do pliku wykonywalnego o treści: