Portal w trybie mobilnym, blogi i błąd 404 przy próbie przejścia do komentarzy


(pocolog) #1

Przeglądarka BlackBerry w trybie mobilnym na głównej stronie portalu częstuje mnie błędem serwera nr 404, kiedy próbuję przejść bezpośrednio ze strony głównej do komentarzy. Przy innych publikacjach (np. newsy) nie ma tego problemu.
Nie wiem, czy błąd się powtarza na innych przeglądarkach. Ktoś próbował?


(darek719) #2

Tak u mnie to samo (windows mobile 10) miałem to zgłosić jakiś czas temu ale mi wyleciało z głowy. Problem jest od dawna, w zasadzie zawsze gdy próbuję przejść bezpośrednio ze strony głównej do komentarzy na blogu.


(krystian3w) #3

Też tak mam (Opera 47 z włączonym widokiem mobilnym ręcznie) - błąd wynika, z tego że w mobilnym szablonie nie zaktualizowali budowy linka na taki sam jak na pełnej wersji (zastąpienie starego systemu komentarzy tym nowym - zamiast bezpośredniego linku do podstrony to kotwica pod artykuł).


(Seba228215) #4

U mnie czasami, ale też czasami miałem to samo na forum, a nie tylko na portalu.


(krystian3w) #5

Nie może czasami jak są wyróżnione notki blogowe na głównej - nie mają podstrony “Komentarze,Publikacja” - do poprawki w szablonie mobilnym lub rozbudowania bloga będzie kierowało na stronę błędu 404.


(tomekb) #6

@Lisek ? :slight_smile:


(Seba228215) #7

Wchodzisz w artykuł, i komentarze, albo pobierz program i dostajesz 404 not found. To samo. Wszedłem w jakiś temat na forum, chciałem dodać post pod wątkiem i w trakcie 404 not found wyskoczyło lub nie można znaleźć zawartości strony. Tak więc tutaj wszystko możliwe.

A blogi, to też podobne błędy.


(Lisek) #8

Naprawione, dzięki za info.


(Seba228215) #9

Może co do blogów źle ująłem. Z głównej jak bierzesz zakładkę blog i z blogów wybierasz konkretny do poczytania, to wtedy wyskakiwało 404 not found albo podana strona nie istnieje. :slight_smile: