Powolna praca komputera + lagi


(Frems88) #1

Witam. Od pewnego czasu zajmuję się robieniem krótkometrażowego filmu dotyczącego pewnej gry. Wykonywanie pewnych czynności takich jak renderowanie, przetwarzanie tysięcy plików .bmp w .avi i tym podobnych mocno obciąża komputer, więc to zdaje się być przyczyną moich problemów. Otóż wziąłem się dziś za robienie filmiku, zacząłem od zrzucania sekwencji w grze do .bmp i w tym momencie zauważyłem, że coś jest nie tak. Proces się często zatrzymywał, zacinał i trwał dużo wolniej. Następnie zwróciłem uwagę, że proces przetwarzania plików .bmp w .avi trwa o wiele za długo (porównywalnie do poprzednich zgrywań). Uruchomiłem ponownie komputer, na wstępie Windows (bootowanie) ładował się chyba z 2 minuty, potem zawiesił się w pulpicie zanim cokolwiek zdążyłem zrobić. Restart komputera, znowu bardzo powolne ładowanie systemu. Odpalam grę (Counter-Strike 1.6) - laguję, strasznie. Mniej więcej zacięcie co 2 sekundy, podobnie w innych grach. Sprawdziłem ile trwa renderowanie sprawdzonych plików, okazało się, że stanowczo za długo. Generalnie rzecz biarąc, mój komputer nagle zaczął chodzić jak żółw i się zacinać. Wybaczcie ze ten niezgrabny i długi opis, nie znam się za bardzo na komputerach, a chciałem dobrze zobrazować sytuację. Mój sprzęt to:

Windows XP SP3

Pentium 4 HT 3.0GHz

ECS P4M890T-M

GIGABYTE NVidia GeForce 8500GT

2x1GB DC DDR2 800MHz

Seagate Barracuda 250 GB S-ATA

Maxtor 30GB IDE

Te problemy pojawiły się dopiero dziś, a intensywne prace nad filmem prowadzę już od ponad tygodnia. Proszę o pomoc/sugestię.


(Michal Kolatek) #2

Na początek otwórz kompa i zobacz czy wentylatory chodzą, czy nie są zapchane kurzem, sprawdź temp.

Przydała by się też defragmentacja, jak ciągle coś się przemieszcza po dysku to bałagan zostaje.


(Frems88) #3

Wentylatory czyste - dbam o komputer. Z tego co się orientuję defragmentacja nie wiele zmienia przy większych dyskach i systemie plików NTFS, aczkolwiek używam programu Diskeeper Pro więc dysk mi się automatycznie defragmentuje kiedy zachodzi potrzeba. Niestety nie mam pojęcia gdzie sprawdzić temperaturę i czego? Proszę jednak o bardziej szczegółowe odpowiedzi, bo powyższa nie pomogła nic, a była raczej "nabiciem" posta. Pozdrawiam


(ybu) #4

Do sprawdzenia temperarury: http://dobreprogramy.pl/index.php?dz=2& ... +4.50.1330

(zakładka Komputer>czujnik)

viewtopic.php?t=76580


(Frems88) #5

Dzięki. W obecnej chwili wygląda to tak:

Płyta główna: 53 *C

Procesor: 38 *C

GPU Diode 48 *C

Seagate ST3250410AS 33 *C

Dodam, że moje problemy pojawiły się nagle podczas wykonywania prac związanych z filmikiem, więc nie sądzę, aby była to wina braku defragmentacji i tym podobnych. Nie dawno również miałem formatowany dysk twardy, więc system również w miarę świeży.

Edit: Zwróciłem uwagę na jeszcze jeden szczegół. Nie robiąc kompletnie nic, bez programów działających w tle, w pulpicie zużycie procesora nie przekraczało mi nigdy 5% Teraz utrzymuje się na poziomie około 30%. Nie wiem czy ma to jakieś znaczenie.


(Scypion) #6

tempy - ok.

zużycie procesora w stanie spoczynku stanowczo za wysokie. sprawdź jaki proces tyle bierze.

jeżeli to inny niż jakis systemowy to wystarczy go zamknąć i po sprawie.

jeżeli jakiś systemowy to proponuje użyć spybot search&destroy lub podobnego - najprawdopodobniej korzystałeś z internetu(www) a tam są różne małe śmieci które mimo użycia najlepszego antywirusa i tak Ci się wgrają. Usuń i już.

Inny sposób z którego ja bym skorzystał to ogolne sprawdzenie wszystkiego czyli (moja metoda na wiekszosc problemow - skuteczność ok.75%):

  1. sprawdzenie czy dysk nie zawiera bledow

  2. defrag

  3. spybot search&destroy

  4. regcleaner

  5. ccleaner

punkt 4i5 robią podobne rzeczy ale coz - lepsza ostrożność.

edit.: sprawdz netmeterem poziom transferu z internetem i do. powinien być zerowy jeżeli nic nie przeglądasz w innym wypadku coś działa w tle.


(Frems88) #7

Z tego co wiem, to w menedżerze urządzeń w zakładce procesy podaje tylko ile, jaki proces zajmuje pamięci, nie jak mocno zużywa procesor, tak czy owak wklejam screen, może coś na nim znajdziecie:

procesy.png

Co do punktów jakie zasugerowałeś:

  1. Dyski sprawdzone, wolne od błędów.

  2. Defragmentacja automatyczna poprzez program Diskeeper Pro, nie wymaga interwencji użytkownika.

  3. Przeskanowałem. Wynik to 4 wpisy (doubleclick, fastclick itp.) Wszystko rodzaj "cookie"

  4. i 5. Sprawdziłem najpierw CCleaner'em, następnie Eusing Free Registry Cleaner'em.Wynik standardowy, parę wpisów, które pojawiają się właściwie zawsze.

Netmeter pokazuje 0 gdy nic nie robię w internecie.

Ja się na tym nie znam, ale wydaje mi się, że problem tkwi w hardware, bo to jak się teraz zachowuje komputer, to jest po prostu katastrofa, nie wiem jak bardzo trzeba by mieć skopany system, żeby aż tak diametralnie się zmienił w jednej chwili. Jak już wspomniałem w pierwszym poście, wszystko to zaczęło się zgrywając sekwencje gry Counter-Strike 1.6 do plików bmp za pomocą komendy "startmovie". Dodam, że usunąłem sterowniki karty graficznej, następnie zainstalowałem najnowszy - nie pomogło. Komputer chodzi jakby miał 32mb ramu i 200MHz procesor... Wciąż proszę o pomoc.


(Scypion) #8

propo tego co napisales to:

w miejscu gdzie jest CPU pisze %-towo ile dany proces zużywa CPU - na twoim zdjeciu brakuje koncówki. (bardzo waznej bo to co powyzej daje 2% a nie 38%). uzupelnij dane.

analizujac drugą strone - uszkodzenie fizyczne to:

wykonaj tezt 3dmarkiem i napisz czy są jakieś zmiany w pkt. Jezeli sie wysypie to znaczy że coś nie gra z grafika.

sprawdź czy windows podaje prawdziwe wartości taktowania procesora.

mozesz choc watpie czy to to - zeskanować memtestem RAM (gdyby byl wadliwy to komputer mialby czeste restarty ale warto mimo to sprawdzic)

jezeli masz windows xp pro to w panelu sterowania narzedzia administracyjne bedziesz mial podglad zdarzen co nie gra w kompie. Najlepiej jakbys przeslal obraz z tymi co są na czerwono w liście.

dalej to musze dłużej pomyśleć.


(Frems88) #9

Zanim posprawdzam 3dmarkiem dokładnie (bo już go odpalałem i działał, fps = ok.8, ale ja zawsze mało miałem) i te inne to wkleję to, bo wydaje mi się, że coś tu jest faktycznie nie tak:

procesy2.png


(Scypion) #10

jak narazie to bym stawial na usluge która jest podczepiona pod jakis dll systemu.

spróbuj jeszcze uruchomić system w trybie awaryjnym i wtedy sprawdzić stan. - klawisz F8 podczas uruchamiania kompa katuj.

wtedy nic niepotrzebnego się nie załaduje i jeżeli to coś w systemie to zużycie proca powinno być jak dawniej.


(Frems88) #11

Oto screen z systemu awaryjnego:


(Scypion) #12

użycie procka 1% więc jakiś proces podczepiony pod system w zwykłym trybie bierze ci te 33.

napewno wszystko z hardware ok jak dla mnie. Teraz nalezy szukac uslugi która bierze ci tą reszte.

wspominales o jakims defragmentatorze ktory dziala w tle - na poczatek wylacz go i zobacz ile jest % uzycia procka.

postaraj sie tak robic z kolejnymi uslugami.

tzn. jezeli na liscie proces ktory bierze ci procek nie jest wyswietlony to jest to jakas usluga ktora dziala z systemem.

po wlaczeniu w tryb awaryjny ona sie nie wlaczyla - teraz musisz tylko znalezc tą usluge/program.

pokombinuj i napisz co wyszlo. ewentualnie potem mozemy sprobowac przez teamviewer(program do zdalnego sterowania kompem) zabezpieczajac polaczenie haslem.

wydaje mi sie ze i tak nic teraz nie wymysle - musze przejrzec co tam na tym kompie masz co moze byc wlaczone w tle - sam wiesz pewnie najlepiej, wypisz to co wiesz ze dziala w tle.


(Frems88) #13

1% to był akurat przypadek, bo poziom zużycia utrzymywał się na ok. 8% Zrobiłem tak jak powiedziałeś, wyłączałem po kolei wszystkie procesy użytkownika. Po wyłączeniu większości z nich, zużycie spadło do około 25%, ale za to po wyłączeniu DKService.exe (Diskeeper - defragmentator dysku) użycie procka spadło do właśnie około 8%. Tak więc odinstalowałem DK, przeczyściłem rejestr, restart kompa i niestety, ale praca komputera bez zmian. Owszem, użycie procka ~8%, ale "Proces bezczynności systemu" dalej bierze ~99 z CPU i komp dalej chodzi jakby chciał, a nie mógł. Program Teamview znam, korzystałem nie raz, ale teraz już za późno na zabawę z tym, to najwyżej jutro. Jeszcze coś pokombinuje wieczorem, ewentualne efekty dopiszę, natomiast nadal czekam na pomoc, być może jest inne rozwiązanie aniżeli format dysku (co w tej chwili jest dla mnie ostatecznością).


(Scypion) #14

pisalem wczesniej abys przejrzał jeszcze :

panel sterowania -> narzędzia administracyjne -> podgląd zdarzeń

i stamtąd wypisal pare tych co są na czerwono, może coś z tamtąd tak paskudzi.

a 8% mniej zuzycia proca to juz cos.

aha proces bezczynnosci zawsze tyle bierze, wydaje mi sie ze te 99% to jest z 33% ktore akurat procek ma. zreszta to jest usluga systemowa czyli stos jakis uslug. wylanczanie procesow moglo pomoc, choc nie musialo.

mozesz jeszcze poprobowac z wylanczaniem uslug tj. panel sterowania -> narzedzia administracyjne -> uslugi

aha tylko tu nie wylanczaj czasem za duzo bo czesc z uslug jest wymagana do poprawnej pracy systemu.

inny pomysl to odpalenie ubuntu w wersji live cd - jak sie bedzie mulic to znaczy ze winny sprzet.


(Frems88) #15

Ok, problem "rozwiązany", ale za pomocą formatu. Tak, wcześniej zaznaczałem, że format to ostateczność, bo mam na dysku ważne dane, ale udało mi się pożyczyć od znajomego dysk twardy, więc skopiowałem wszystkie potrzebne mi pliki. Mimo tego, problem nadal owiany jest tajemnicą i z chęcią dowiedziałbym się przyczyny wcześniejszych zdarzeń. Oto co znalazłem wtedy w Podglądzie Zdarzeń w zakładce "System" i co niestety wystąpiło również zaraz po całkowitym formacie:

(screen po formacie)

podgldzdarze.png

Z tego co udało mi się przeczytać na stronie Microsoft są to chyba uszkodzone sektory dysku. Bardzo mnie to dziwi, bo dysk kupiłem stosunkowo nie dawno :confused: Jak już pisałem, jest to Seagate Barracuda 7200 250GB Interfejs SATA II


(Scypion) #16

a mowielem :slight_smile:

  1. punkt bledy dysku - jestem ciekaw czy zeskanowales powierzchnie dysku czy tylko bledy systemu plikow.

to powyzej chyba jest odpowiedzia.

aha jesli masz baracude v.11 to mozliwe ze masz skopaną bo jest o niej duuuuzo negatywnych opinii.

aha kliknij dwa razy w komunikat i prze4pisz tu to co tam pisze


(Frems88) #17

Nazwa dysku to "Barracuda 7200. 10 250410" więc chyba nie jest to v11, chyba że ta "10" oznacza co innego i palnąłem właśnie głupotę :slight_smile: Oto co zawiera komunikat błędu:

beztytuu-2.jpg

Nie wiem czy to też chciałeś, ale daję:

0000: 0f 00 68 00 01 00 b6 00 ..h...¶.

0008: 00 00 00 00 07 00 04 c0 .......À

0010: 00 01 00 00 9c 00 00 c0 ......À

0018: 00 00 00 00 00 00 00 00 ........

0020: 00 90 ec 12 08 00 00 00 .ì.....

0028: 37 39 00 00 00 00 00 00 79......

0030: ff ff ff ff 00 00 00 00 ÿÿÿÿ....

0038: 40 00 00 84 02 00 00 00 @......

0040: 00 20 0a 12 08 01 20 00 . .... .

0048: 00 00 00 00 1e 00 00 00 ........

0050: 00 00 00 00 d8 98 c9 89 ....ØÉ

0058: 00 00 00 00 08 d0 c4 89 .....ÐÄ

0060: 01 00 00 00 00 00 00 00 ........

0068: 2f 00 04 09 76 48 00 01 /...vH..

0070: 48 00 00 00 00 00 00 00 H.......

0078: f0 00 03 00 00 00 00 0b ð.......

0080: 00 00 00 00 00 00 00 00 ........

0088: 00 00 00 00 00 00 00 00 ........

W jaki sposób zeskanować powierzchnię dysku? Wnioskuję, że systemowy CheckDisk sprawdza tylko system plików.


(Scypion) #18

nie tylko system plikow.

ogolnie to wyglada to tak:

wchodzisz do moj komputer, klikasz prawym myszy, potem szykasz sprawdzenie i tam zaznaczasz system plikow + probuj odzyskac uszkodzone sektory. wtedy dopiero bedzie caly skan.

komputer wtedy powinien nadpisac w MBR nową tablice dysku tzn. z ominięciem zepsutych sektorów.

baracude masz 10 - miales racje.

a teraz rada na przyszlosc:

nie uzywaj programow do defragmentacji w trybie online(jako rezydenci) !!

dlaczego?

zwiekszaja zuzycie dysku i to dosc znacznie a dziala to tak:

ty cos robisz np. kopiujesz film/muze/zdjecia hq ale wiesz ze po tygodniu sie ich pozbedziesz. twoj programik ci je pouklada czyli zuzyje troszke dysk. Jeszcze gorzej sytuacja wyglada gdy ty czesto zmieniasz zawartosc folderow - twoj programik do defragmenatcji od razu robi zmiany. W calosci chodzi o to ze on wywoluje czasem niepotrzebny ruch na dysku.

Dysk chodzi ogolnie szybciej bo na biezaco jest zdefragmentowany ale jego żywotność jest znacznie krótsza niż byś robil defragmentacje raz na miesiąc normalnym programem.

aha co do dysku to radze jeszcze przejrzec dane SMART - windows ich nie podaje a tam zazwyczaj kryją się wszystkie usterki dysku.

sprawdz np. everestem czy twoje dane SMART dla tego dysku mieszcza się w normie.

jak jakies pytania to pisz. topic mam w zakladkach wiec co jakis czas czytam.


(Vonmod) #19

Z opisu widzę, iż mam ten sam problem, jednakże, format partycji systemowej na nie wiele się zdał... U mnie problem ze skokiem zużycia procka pojawia się, gdy chcę coś zainstalować, a zwłaszcza przeskanować, wtedy zużycie jest dużo większe nawet od 30%. Proces bezynności wskazuje 98%-99%. Mam pytanie, czy frems, tak, jak ja formatował tylko partycję systemową, czy cały komputer. Oczywiście proszę też o wszelkie wskazówki, jak rozwiązać problem.