[Problem] Nie mogę zainstalować DirectaX


(Rafor4) #1

Witam. Miałem zainstalowanego DirectX 10 (tą podrobioną wersje) na windowsie xp. Przez to wywalało mi różne błedy, że nie może znależć _handler... coś tam w jakimś tam pliku (bibliotece windows). Nie dało się w żaden sposób zainstalować directa 9, ani usunać 10, a więc pobrałem jakiegoś deinstallatora i usunął mi całkowicie directa. Nie mogę teraz wpisać w uruchom dxdiag (bo nie mam directa). Przy instalacji jakiego kolwiek wywala błąd wewnętrzny i żebym sprawdził logi w folderze windows, ale nawet ich tam nie ma.


(nnick) #2

No to masz teraz nauczkę żeby w takie kuglarstwo się nie bawić. Spróbuj naprawę systemu z płyty instalacyjnej.


(Rafor4) #3

Zobaczyłem, że w karcie graficznej piszę, że obsługuje direct x 10, to chciałem na siłę go zainstalować. Jak naprawić z płyty ?


(nnick) #4

Wkładasz płytę instalacyjną, odpalasz z niej komputer i postępujesz zgodnie z instrukcjami.


#5

rafor4 , proszę zapoznaj się z tą stroną oraz tym tematem, a następnie,używając przycisku image.php?album_id=20&image_id=4038


(Rafor4) #6

Co się działo z directx to trzeba by baaardzo długo opowiadać, ponieważ komputer na directx 10 chodził przez rok bez szwanku. Potem gdy odinstalowałem AVG internet security system zaczął się sypać. Nie mogłem zainstalować żadnego antywirusa, jednak na forum podałem logi i były "czyste". Jakiś czas potem zaczął się pojawiać błąd svchost.exe 0x000000 odnosi się do 0x000000 (nie wiem co to kurde za różnica ale ok). Również wtedy po raz 2 podałem logi i też były czyste. Uruchomiłem combofixa, bo pisali, że usunie ten problem, jednak to nic nie dało. Po 3 miesiącach od błędu svchost.exe zaczęły się pojawiać błędy dotyczące właśnie directax (_handler). Grzebałem, grzebałem aż błąd svchost.exe zniknął (dodam, że musiałem siedzieć z otwartym oknem błedu, bo inaczej po naciśnięciu OK siadał system, co mnie zresztą bardzo irytowało), ale niestety doprowadziłem do 3x częstszych błędów directx w prawie każdej aplikacji i przy uruchamianiu w RUNDLL32 i RundLL32 co mnie wkurzało jeszcze bardziej. Do tego system mulił strasznie przy włączaniu od czasów błędu svchost.exe (3minuty zanim się wczytał użytkownik, nawet jeśli wyłączyłem prawie wszystkie programy autostart). Czyszczenie ccleanerem, programami do naprawy rejestru nic nie dawały. Logi na forum nic nie zmieniały, aż czytałem co zrobił z tym błędem z directax. Pisali że tylko format to zacząłem grzebać i znalazłem dezinstallatora directax to co mi szkodziło jak i tak system się sypał :slight_smile: Nie mogłem od błędu svc instalować prawie żadnych programów (tzn. mogłem ale chodziły nie poprawnie) związanych z internetem np. VirtualBox, Hamachi, VirtualPC, Zapora Systemu. Probowałem wiele nic nie dawało. DirectX poszedł w piz...u i było jeszcze gorzej, wtedy napisałem na forum :smiley: naprawy nie dało się zrobić z powodu, że przy naprawie również wywalało błedy o bibliotekach i stanęło przy instalacji "Sterowników sieci". Czekałem 30minut, a pasek się nie ruszał. Zainstalowałem windowsa na tej samej partycji (bez formatu) przeniosłem folder od użytkownika, zainstalowałem programy i wszystkie problemy zniknęły :smiley: podsumowując po przeinstalowaniu Windowsa wszystko działa poprawnie.