Problem - Oxygen Transparent - "The CXX compiler identification is unknown"


(Adrianvpl) #1

Hej. Od zawsze korzystałem z Windowsa, ale teraz postanowiłem przenieść się na Linuxa. Wybrałem system Fedora 20. Środowisko graficzne to KDE 4.11.4. Próbuję zainstalować temat Oxygen-Transparent, uruchamiam plik .pl pobrany z tego miejsca: http://kde-look.org/content/show.php?content=127752. I pojawia się taki błąd:

cmake -DCMAKE_INSTALL_PREFIX=kde4-config --prefix -DCMAKE_BUILD_TYPE=release /home/adrian/oxygen/src
-- The C compiler identification is GNU 4.8.2
-- The CXX compiler identification is unknown
-- Check for working C compiler: /bin/cc
-- Check for working C compiler: /bin/cc -- works
-- Detecting C compiler ABI info
-- Detecting C compiler ABI info - done
CMake Error: your CXX compiler: "CMAKE_CXX_COMPILER-NOTFOUND" was not found. Please set CMAKE_CXX_COMPILER to a valid compiler path or name.
CMake Error at /usr/share/cmake/Modules/FindKDE4.cmake:98 (message):
ERROR: cmake/modules/FindKDE4Internal.cmake not found in
/root/.kde/share/apps;/usr/share/kde-settings/kde-profile/default/share/apps;/usr/share/kde4/apps
Call Stack (most recent call first):
CMakeLists.txt:3 (find_package)

CMake Warning (dev) in CMakeLists.txt:
No cmake_minimum_required command is present. A line of code such as

cmake_minimum_required(VERSION 2.8)

should be added at the top of the file. The version specified may be lower
if you wish to support older CMake versions for this project. For more
information run "cmake --help-policy CMP0000".
This warning is for project developers. Use -Wno-dev to suppress it.

-- Configuring incomplete, errors occurred!
See also "/home/adrian/oxygen/build/CMakeFiles/CMakeOutput.log".
See also "/home/adrian/oxygen/build/CMakeFiles/CMakeError.log".
system cmake -DCMAKE_INSTALL_PREFIX=kde4-config --prefix -DCMAKE_BUILD_TYPE=release /home/adrian/oxygen/src>&1 failed: 256

Zawartość CMakeError.log to:

Compiling the CXX compiler identification source file "CMakeCXXCompilerId.cpp" failed.
Compiler: CMAKE_CXX_COMPILER-NOTFOUND
Build flags:
Id flags:

The output was:
No such file or directory

Compiling the CXX compiler identification source file "CMakeCXXCompilerId.cpp" failed.
Compiler: CMAKE_CXX_COMPILER-NOTFOUND
Build flags:
Id flags: -c

The output was:
No such file or directory

Checking whether the CXX compiler is IAR using "" did not match "IAR .+ Compiler":

A CMakeOutput:

The system is: Linux - 3.12.5-302.fc20.x86_64 - x86_64
Compiling the C compiler identification source file "CMakeCCompilerId.c" succeeded.
Compiler: /bin/cc
Build flags:
Id flags:

The output was:
0

Compilation of the C compiler identification source "CMakeCCompilerId.c" produced "a.out"

The C compiler identification is GNU, found in "/home/adrian/oxygen/build/CMakeFiles/2.8.12.1/CompilerIdC/a.out"

Determining if the C compiler works passed with the following output:
Change Dir: /home/adrian/oxygen/build/CMakeFiles/CMakeTmp

Run Build Command:/bin/gmake "cmTryCompileExec4048089643/fast"
/bin/gmake -f CMakeFiles/cmTryCompileExec4048089643.dir/build.make CMakeFiles/cmTryCompileExec4048089643.dir/build
gmake[1]: Wejście do katalogu /home/adrian/oxygen/build/CMakeFiles/CMakeTmp'
/usr/bin/cmake -E cmake_progress_report /home/adrian/oxygen/build/CMakeFiles/CMakeTmp/CMakeFiles 1
Building C object CMakeFiles/cmTryCompileExec4048089643.dir/testCCompiler.c.o
/bin/cc -o CMakeFiles/cmTryCompileExec4048089643.dir/testCCompiler.c.o -c /home/adrian/oxygen/build/CMakeFiles/CMakeTmp/testCCompiler.c
Linking C executable cmTryCompileExec4048089643
/usr/bin/cmake -E cmake_link_script CMakeFiles/cmTryCompileExec4048089643.dir/link.txt --verbose=1
/bin/cc CMakeFiles/cmTryCompileExec4048089643.dir/testCCompiler.c.o -o cmTryCompileExec4048089643 -rdynamic
gmake[1]: Opuszczenie katalogu
/home/adrian/oxygen/build/CMakeFiles/CMakeTmp'

Detecting C compiler ABI info compiled with the following output:
Change Dir: /home/adrian/oxygen/build/CMakeFiles/CMakeTmp

Run Build Command:/bin/gmake "cmTryCompileExec3936788786/fast"
/bin/gmake -f CMakeFiles/cmTryCompileExec3936788786.dir/build.make CMakeFiles/cmTryCompileExec3936788786.dir/build
gmake[1]: Wejście do katalogu /home/adrian/oxygen/build/CMakeFiles/CMakeTmp'
/usr/bin/cmake -E cmake_progress_report /home/adrian/oxygen/build/CMakeFiles/CMakeTmp/CMakeFiles 1
Building C object CMakeFiles/cmTryCompileExec3936788786.dir/CMakeCCompilerABI.c.o
/bin/cc -o CMakeFiles/cmTryCompileExec3936788786.dir/CMakeCCompilerABI.c.o -c /usr/share/cmake/Modules/CMakeCCompilerABI.c
Linking C executable cmTryCompileExec3936788786
/usr/bin/cmake -E cmake_link_script CMakeFiles/cmTryCompileExec3936788786.dir/link.txt --verbose=1
/bin/cc -v CMakeFiles/cmTryCompileExec3936788786.dir/CMakeCCompilerABI.c.o -o cmTryCompileExec3936788786 -rdynamic
Using built-in specs.
COLLECT_GCC=/bin/cc
COLLECT_LTO_WRAPPER=/usr/libexec/gcc/x86_64-redhat-linux/4.8.2/lto-wrapper
Target: x86_64-redhat-linux
Configured with: ../configure --prefix=/usr --mandir=/usr/share/man --infodir=/usr/share/info --with-bugurl=http://bugzilla.redhat.com/bugzilla --enable-bootstrap --enable-shared --enable-threads=posix --enable-checking=release --with-system-zlib --enable-__cxa_atexit --disable-libunwind-exceptions --enable-gnu-unique-object --enable-linker-build-id --with-linker-hash-style=gnu --enable-languages=c,c++,objc,obj-c++,java,fortran,ada,go,lto --enable-plugin --enable-initfini-array --enable-java-awt=gtk --disable-dssi --with-java-home=/usr/lib/jvm/java-1.5.0-gcj-1.5.0.0/jre --enable-libgcj-multifile --enable-java-maintainer-mode --with-ecj-jar=/usr/share/java/eclipse-ecj.jar --disable-libjava-multilib --with-isl=/builddir/build/BUILD/gcc-4.8.2-20131212/obj-x86_64-redhat-linux/isl-install --with-cloog=/builddir/build/BUILD/gcc-4.8.2-20131212/obj-x86_64-redhat-linux/cloog-install --with-tune=generic --with-arch_32=i686 --build=x86_64-redhat-linux
Thread model: posix
gcc version 4.8.2 20131212 (Red Hat 4.8.2-7) (GCC)
COMPILER_PATH=/usr/libexec/gcc/x86_64-redhat-linux/4.8.2/:/usr/libexec/gcc/x86_64-redhat-linux/4.8.2/:/usr/libexec/gcc/x86_64-redhat-linux/:/usr/lib/gcc/x86_64-redhat-linux/4.8.2/:/usr/lib/gcc/x86_64-redhat-linux/
LIBRARY_PATH=/usr/lib/gcc/x86_64-redhat-linux/4.8.2/:/usr/lib/gcc/x86_64-redhat-linux/4.8.2/../../../../lib64/:/lib/../lib64/:/usr/lib/../lib64/:/usr/lib/gcc/x86_64-redhat-linux/4.8.2/../../../:/lib/:/usr/lib/
COLLECT_GCC_OPTIONS='-v' '-o' 'cmTryCompileExec3936788786' '-rdynamic' '-mtune=generic' '-march=x86-64'
/usr/libexec/gcc/x86_64-redhat-linux/4.8.2/collect2 --build-id --no-add-needed --eh-frame-hdr --hash-style=gnu -m elf_x86_64 -export-dynamic -dynamic-linker /lib64/ld-linux-x86-64.so.2 -o cmTryCompileExec3936788786 /usr/lib/gcc/x86_64-redhat-linux/4.8.2/../../../../lib64/crt1.o /usr/lib/gcc/x86_64-redhat-linux/4.8.2/../../../../lib64/crti.o /usr/lib/gcc/x86_64-redhat-linux/4.8.2/crtbegin.o -L/usr/lib/gcc/x86_64-redhat-linux/4.8.2 -L/usr/lib/gcc/x86_64-redhat-linux/4.8.2/../../../../lib64 -L/lib/../lib64 -L/usr/lib/../lib64 -L/usr/lib/gcc/x86_64-redhat-linux/4.8.2/../../.. CMakeFiles/cmTryCompileExec3936788786.dir/CMakeCCompilerABI.c.o -lgcc --as-needed -lgcc_s --no-as-needed -lc -lgcc --as-needed -lgcc_s --no-as-needed /usr/lib/gcc/x86_64-redhat-linux/4.8.2/crtend.o /usr/lib/gcc/x86_64-redhat-linux/4.8.2/../../../../lib64/crtn.o
gmake[1]: Opuszczenie katalogu
/home/adrian/oxygen/build/CMakeFiles/CMakeTmp'

Parsed C implicit link information from above output:
link line regex: [^( |.[/])(ld|([^/]+-)?ld|collect2)[^/]*( |$)]
ignore line: [Change Dir: /home/adrian/oxygen/build/CMakeFiles/CMakeTmp]
ignore line: []
ignore line: [Run Build Command:/bin/gmake "cmTryCompileExec3936788786/fast"]
ignore line: [/bin/gmake -f CMakeFiles/cmTryCompileExec3936788786.dir/build.make CMakeFiles/cmTryCompileExec3936788786.dir/build]
ignore line: [gmake[1]: Wejście do katalogu `/home/adrian/oxygen/build/CMakeFiles/CMakeTmp']
ignore line: [/usr/bin/cmake -E cmake_progress_report /home/adrian/oxygen/build/CMakeFiles/CMakeTmp/CMakeFiles 1]
ignore line: [Building C object CMakeFiles/cmTryCompileExec3936788786.dir/CMakeCCompilerABI.c.o]
ignore line: [/bin/cc -o CMakeFiles/cmTryCompileExec3936788786.dir/CMakeCCompilerABI.c.o -c /usr/share/cmake/Modules/CMakeCCompilerABI.c]
ignore line: [Linking C executable cmTryCompileExec3936788786]
ignore line: [/usr/bin/cmake -E cmake_link_script CMakeFiles/cmTryCompileExec3936788786.dir/link.txt --verbose=1]
ignore line: [/bin/cc -v CMakeFiles/cmTryCompileExec3936788786.dir/CMakeCCompilerABI.c.o -o cmTryCompileExec3936788786 -rdynamic]
ignore line: [Using built-in specs.]
ignore line: [COLLECT_GCC=/bin/cc]
ignore line: [COLLECT_LTO_WRAPPER=/usr/libexec/gcc/x86_64-redhat-linux/4.8.2/lto-wrapper]
ignore line: [Target: x86_64-redhat-linux]
ignore line: [Configured with: ../configure --prefix=/usr --mandir=/usr/share/man --infodir=/usr/share/info --with-bugurl=http://bugzilla.redhat.com/bugzilla --enable-bootstrap --enable-shared --enable-threads=posix --enable-checking=release --with-system-zlib --enable-_cxaatexit --disable-libunwind-exceptions --enable-gnu-unique-object --enable-linker-build-id --with-linker-hash-style=gnu --enable-languages=c,c++,objc,obj-c++,java,fortran,ada,go,lto --enable-plugin --enable-initfini-array --enable-java-awt=gtk --disable-dssi --with-java-home=/usr/lib/jvm/java-1.5.0-gcj-1.5.0.0/jre --enable-libgcj-multifile --enable-java-maintainer-mode --with-ecj-jar=/usr/share/java/eclipse-ecj.jar --disable-libjava-multilib --with-isl=/builddir/build/BUILD/gcc-4.8.2-20131212/obj-x86_64-redhat-linux/isl-install --with-cloog=/builddir/build/BUILD/gcc-4.8.2-20131212/obj-x86_64-redhat-linux/cloog-install --with-tune=generic --with-arch_32=i686 --build=x86_64-redhat-linux]
ignore line: [Thread model: posix]
ignore line: [gcc version 4.8.2 20131212 (Red Hat 4.8.2-7) (GCC)]
ignore line: [COMPILER_PATH=/usr/libexec/gcc/x86_64-redhat-linux/4.8.2/:/usr/libexec/gcc/x86_64-redhat-linux/4.8.2/:/usr/libexec/gcc/x86_64-redhat-linux/:/usr/lib/gcc/x86_64-redhat-linux/4.8.2/:/usr/lib/gcc/x86_64-redhat-linux/]
ignore line: [LIBRARY_PATH=/usr/lib/gcc/x86_64-redhat-linux/4.8.2/:/usr/lib/gcc/x86_64-redhat-linux/4.8.2/../../../../lib64/:/lib/../lib64/:/usr/lib/../lib64/:/usr/lib/gcc/x86_64-redhat-linux/4.8.2/../../../:/lib/:/usr/lib/]
ignore line: [COLLECT_GCC_OPTIONS='-v' '-o' 'cmTryCompileExec3936788786' '-rdynamic' '-mtune=generic' '-march=x86-64']
link line: [/usr/libexec/gcc/x86_64-redhat-linux/4.8.2/collect2 --build-id --no-add-needed --eh-frame-hdr --hash-style=gnu -m elf_x86_64 -export-dynamic -dynamic-linker /lib64/ld-linux-x86-64.so.2 -o cmTryCompileExec3936788786 /usr/lib/gcc/x86_64-redhat-linux/4.8.2/../../../../lib64/crt1.o /usr/lib/gcc/x86_64-redhat-linux/4.8.2/../../../../lib64/crti.o /usr/lib/gcc/x86_64-redhat-linux/4.8.2/crtbegin.o -L/usr/lib/gcc/x86_64-redhat-linux/4.8.2 -L/usr/lib/gcc/x86_64-redhat-linux/4.8.2/../../../../lib64 -L/lib/../lib64 -L/usr/lib/../lib64 -L/usr/lib/gcc/x86_64-redhat-linux/4.8.2/../../.. CMakeFiles/cmTryCompileExec3936788786.dir/CMakeCCompilerABI.c.o -lgcc --as-needed -lgcc_s --no-as-needed -lc -lgcc --as-needed -lgcc_s --no-as-needed /usr/lib/gcc/x86_64-redhat-linux/4.8.2/crtend.o /usr/lib/gcc/x86_64-redhat-linux/4.8.2/../../../../lib64/crtn.o]
arg [/usr/libexec/gcc/x86_64-redhat-linux/4.8.2/collect2] ==> ignore
arg [--build-id] ==> ignore
arg [--no-add-needed] ==> ignore
arg [--eh-frame-hdr] ==> ignore
arg [--hash-style=gnu] ==> ignore
arg [-m] ==> ignore
arg [elf_x86_64] ==> ignore
arg [-export-dynamic] ==> ignore
arg [-dynamic-linker] ==> ignore
arg [/lib64/ld-linux-x86-64.so.2] ==> ignore
arg [-o] ==> ignore
arg [cmTryCompileExec3936788786] ==> ignore
arg [/usr/lib/gcc/x86_64-redhat-linux/4.8.2/../../../../lib64/crt1.o] ==> ignore
arg [/usr/lib/gcc/x86_64-redhat-linux/4.8.2/../../../../lib64/crti.o] ==> ignore
arg [/usr/lib/gcc/x86_64-redhat-linux/4.8.2/crtbegin.o] ==> ignore
arg [-L/usr/lib/gcc/x86_64-redhat-linux/4.8.2] ==> dir [/usr/lib/gcc/x86_64-redhat-linux/4.8.2]
arg [-L/usr/lib/gcc/x86_64-redhat-linux/4.8.2/../../../../lib64] ==> dir [/usr/lib/gcc/x86_64-redhat-linux/4.8.2/../../../../lib64]
arg [-L/lib/../lib64] ==> dir [/lib/../lib64]
arg [-L/usr/lib/../lib64] ==> dir [/usr/lib/../lib64]
arg [-L/usr/lib/gcc/x86_64-redhat-linux/4.8.2/../../..] ==> dir [/usr/lib/gcc/x86_64-redhat-linux/4.8.2/../../..]
arg [CMakeFiles/cmTryCompileExec3936788786.dir/CMakeCCompilerABI.c.o] ==> ignore
arg [-lgcc] ==> lib [gcc]
arg [--as-needed] ==> ignore
arg [-lgcc_s] ==> lib [gcc_s]
arg [--no-as-needed] ==> ignore
arg [-lc] ==> lib [c]
arg [-lgcc] ==> lib [gcc]
arg [--as-needed] ==> ignore
arg [-lgcc_s] ==> lib [gcc_s]
arg [--no-as-needed] ==> ignore
arg [/usr/lib/gcc/x86_64-redhat-linux/4.8.2/crtend.o] ==> ignore
arg [/usr/lib/gcc/x86_64-redhat-linux/4.8.2/../../../../lib64/crtn.o] ==> ignore
remove lib [gcc]
remove lib [gcc_s]
remove lib [gcc]
remove lib [gcc_s]
collapse library dir [/usr/lib/gcc/x86_64-redhat-linux/4.8.2] ==> [/usr/lib/gcc/x86_64-redhat-linux/4.8.2]
collapse library dir [/usr/lib/gcc/x86_64-redhat-linux/4.8.2/../../../../lib64] ==> [/usr/lib64]
collapse library dir [/lib/../lib64] ==> [/lib64]
collapse library dir [/usr/lib/../lib64] ==> [/usr/lib64]
collapse library dir [/usr/lib/gcc/x86_64-redhat-linux/4.8.2/../../..] ==> [/usr/lib]
implicit libs: [c]
implicit dirs: [/usr/lib/gcc/x86_64-redhat-linux/4.8.2;/usr/lib64;/lib64;/usr/lib]
implicit fwks: []

Wszystko mam zaktualizowane, ale nadal nie działa. Ma ktoś jakieś pomysły, bo zależy mi na tej paczce.

Pozdrawiam,

AdiVPL


(MrQ) #2

Musisz zainstalować cmake.


(Adrianvpl) #3

Cmake mam zainstalowane. Zrobiłem reinstall komendą yum reinstall cmake, ale to nic nie pomogło. Moja wersja cmake to: 2.8.12.1-1.fc20.x86_64

Mam jeszcze jedno pytanie: Zainstalowałem na komputerze Fedorę 20 z GNOME. Jednak przeniosłem się na KDE i usunąłem gnome : sudo yum remove gnome-shell. Jednak nadal mam pozostałości po gnome np. w czasie logowania mam opcję uruchomienia w GNOME, ale to nie działa. Czy da się usunąć pozostałości po gnome jakąś komendą?

Miał ktoś taką sytuację/ albo jakieś rady jak to rozwiązać ( z Oxygen Transparent ). Problem z GNOME rozwiązany : usunąłem plik gnome.desktop z /usr/share/xsessions/

Proszę korzystać z opcji Edytuj , zamiast pisać post pod postem.

rgabrysiak


(rgabrysiak) #4

Dlatego też proszę, korzystając z przycisku EDYTUJ , który znajdziesz w prawym dolnym rogu swojego posta i opcji Użyj pełnego edytora, dokonać korekty tytułu, tak aby konkretnie mówił o problemie.

W przeciwnym razie trafi on do Kosza.


(enedil) #5

Po pierwsze

 

Po drugie

sudo yum groupremove "GNOME Desktop Environment"