Problem podczas nadawania chmod 666 dla pliku


(Evvka3000) #1

wiem gdzie ustawić ten parametr, ale nie mogę tego zrobić skutecznie do końca:

próbowałam zmienić właściwości pliku 'settings.php' na chmod 666, przez ftp, przez Windows Comander (na dysku i również na serwerze przez ftp), ale za każdym razem przez ftp pokazuje mi komunikat:

550 Nie można zmienić praw na settings.php

A Windows Comander po wpisaniu na pasku komend na dole "chmod 666 settings.php", wyskakuje mi komunikat, że Nie znaleziono pliku , chociaż ten plik jest w folderze

Podpowiedzcie co mam zrobić żeby to zmienić......

Ewa


(Airborn) #2

Na dysku nie masz co zmieniać tego nawet, bo chmod jest komendą uniksową/linuksową więc pod windowsem nie będzie działać. To samo może być przyczyną problemów po stronie serwera, być może działa on pod kontrolą windows'a. Inną opcją jest, że z jakichś względów bezpieczeństwa, nie masz takich uprawnień, powiedz co to za serwer.


(Fubbu) #3

Jak możesz zaloguj się przez SSH na swoje konto. :slight_smile:

Jeśli to Linux to proponuję:

chmod - służy do zmiany praw pliku pod warunkiem ze jesteś jego właścicielem

chown - zmienia właściciela pliku, spróbuj zmienić go na siebie.

polecam lekturę: manuala

man chmod

man chown

Jaki to serwer na Linuksie ?

Czasem przez Total Commandera nie da się tego zrobić.

Przez FTP też można zmieniać prawa plików.

Nie zmienisz właściwości pliku pliku 'settings.php' przez Windows Commander bo to program Windowsowy a w Windows takie polecenie chmod 666 nie istnieje !!


(Airborn) #4

przepraszam, które uwagi?


(Fubbu) #5

tzn.

Skąd wiesz jakiego ona serwera używa.


(Airborn) #6

fubbu nie mam zielonego pojęcia jakiego serwera używa, dlatego napisałem, że serwer stojący na Windowsie MOŻE być przyczyną problemów :wink:

Filezilla i Total Commander to też programy windowsowe, i?


(Fubbu) #7

Najbardziej zainteresowanej osoby już nie ma.

Wiec temat trzeba zamknąć...