Problem z aplikacjami Skype i VLC po aktyalizacji Ubuntu 14.04 do 16.10


(Jaziko) #1

Witam…
W poprzedniej dystrybucji obie apki działały , a teraz przy próbie instalacji Skypa czy VLC pojawia się komunikat o bliżej nieoreślonym wewnętrznym błędzie. Chciałbym wrócić do Ubuntu 14.04. ( zainstalowany obok Win. 10.)


(Domker) #2

Downgrade systemu raczej nie zrobisz - to nie Arch, czy Manjaro, gdzie pakiety są archiwizowane przy aktualizacji.

Bliżej nieokreślony błąd ? - możesz sprecyzować?
Spróbuj zainstalować przez terminal:

sudo apt-get install vlc

I powiedz, co się pojawia?

Być może trzeba sources.list doprowadzić do porządku.

Odnośnie Skype to w wersji 16.10 wyleciał z repo Ubuntu i jest w repo Canonical Partner:
https://help.ubuntu.com/stable/ubuntu-help/addremove-sources.html#canonical-partner

Musisz wpierw dodać i aktywować to repo, aby móc zainstalować Skype.

Jeżeli miałeś stare paczki VLC / Skype to odinstaluj je najpierw wraz z czyszczeniem konfiguracji tych programów:

sudo apt-get purge skype vlc


(Jaziko) #3

VLC pokazał się liście oprogramowania Ubuntu, klikając na zainstaluj nie reaguje.
Wynik z terminala:
Nie udało się zainstalować niektórych pakietów. Może to oznaczać,
że zażądano niemożliwej sytuacji lub użyto dystrybucji niestabilnej,
w której niektóre pakiety nie zostały jeszcze utworzone lub przeniesione
z katalogu Incoming (“Przychodzące”).
Następujące informacje mogą pomóc rozwiązać sytuację:

Następujące pakiety mają niespełnione zależności:
vlc : Wymaga: libgles1-mesa (>= 7.8.1) ale nie zostanie zainstalowany lub
libgles1
Wymaga: libgles2-mesa (>= 7.8.1) ale nie zostanie zainstalowany lub
libgles2
E: Nie udało się naprawić problemów, zatrzymano uszkodzone pakiety.
:~$ sudo apt-get purge skype vlc
Czytanie list pakietów… Gotowe
Budowanie drzewa zależności
Odczyt informacji o stanie… Gotowe
E: Nie udało się odnaleźć pakietu skype


(FadeMind) #4

Jaką masz Mesę obecnie zainstalowaną? :> pomieszane wersje bibliotek? :>


(Jaziko) #5

Nie rozumiem pytania


(GForce) #6

(GForce) #7

Przepraszam Panowie że się wtrącę w Waszą dyskusje, ale gdzie dokładnie są przechowywane te pliki, w jakim folderze ?


#8

Pokaż nam zawartość pliku sources.list. Prawdopodobnie masz coś mocno namieszane w repozytoriach. Dla 16.10 libgles1-mesa jest w wersji 12.0.3 (zob: http://packages.ubuntu.com/yakkety/libgles1-mesa). W najstarszym 12.04 jest wersja 8.04 (zob.: http://packages.ubuntu.com/search?keywords=libgles1-mesa&searchon=names&suite=all&section=all). Tak, czy inaczej - każda z nich spełnia minimalne wymagania vlc, które przedstawiłeś wyżej. Skąd zatem w Twoim 16.10 istnieje wersja <7.8.1 bóg jeden raczy wiedzieć.


(marcin82) #9

W katalogu /var/cache/pacman/pkg:
https://wiki.archlinux.org/index.php/pacman#Cleaning_the_package_cache .


(Jaziko) #10

Dziękuję za porady. Już sobie poradziłem. Zainstalowałem na czysto Ubuntu 16.04.01 , nastepnie Skype i VCL . Zajęło mi to 1/2 dżdżystego dnia i wsio chodzi jak należy. I to by było na tyle.