Problem z apt-get update


(Filipsko) #1

Witam. Dodałem repozytoria z http://easylinux.info/wiki/Ubuntu_dappe ... zytoria.3F

I przy wywoływaniu z terminalu sudo apt-get update i wpisaniu hasła po licznych komunikatach pojawia się:

Pobrano 9615B w 3s (2587B/s)

Czytanie list pakietów... Gotowe

W: GPG error: http://packages.freecontrib.org dapper Release: Następujące sygnatury nie mogły zostać zweryfikowane z powodu braku klucza publicznego: NO_PUBKEY F120156012B83718

W: Należy uruchomić apt-get update aby naprawić te problemy.

filips@w3bma5t3r:~$

Jak to naprawić? Uruchamiałem to 3 razy i ciągle to smao :expressionless:


(Mir Hag) #2

On tylko krzyczy, że nie dodałeś kluczy GPG. Można to zignorować i spokojnie korzystać z apta. To nie ma wpływu na działanie. Ale jeżeli bardzo chcesz się tego pozbyć http://forum.ubuntu.pl/viewtopic.php?t=2315

Poza tym zdecydowanie lepsza jest ta lista repo (na bierząco aktualizowana):

http://forum.ubuntu.pl/viewtopic.php?t=1591

Pozdrawiam


(Filipsko) #3

Dzięki hag. Jak skończy się instalacja Javy to sprawdzę jak to działa.

To normalne że J2SE zajmuje aż 84 MB? :o

Ps. Czy mimo tego komunikatu aktualizacje są mimo to pobierane? Czy przez niego coś się zmienia?

Chyba nie jak rozumiem ale wolę się upewnić :wink:


(Mir Hag) #4

Wydaje mi się, że raczej dużo.

https://sdlc5d.sun.com/ECom/EComActionS ... A27A881C4C

Ale może ściągasz nie tylko to co potrzebne do uruchamiania apletów, ale też do ich pisania (choć tu znowu trochę mało:) )

PS

sudo apt-get update - spowoduje uaktualnienie archiwum pakietów w apcie. W przypadku tych serwerów, których się czepia podczas późniejszej aktualizacji będziesz informowany, że część pakietów jest nieautoryzowana. Ale jeżeli wyrazisz na to zgodę to zostaną one pobrane.

System aktualizujesz przy pomocy

sudo apt-get upgrade (zwykła aktualizacja)

lub

sudo apt-get dist-upgrade (konieczne przy pakietach typu: nowe jądra itp).

Aktualizację wygodniej przeprowadzać z za pomocą graficznej nakładki (przynajmniej mi) ponieważ dostaniesz tam od ręki: opis pakietu, wielkość, możliwość wyboru które chcesz i będą też uwzględnione pakiety z dist-upgrade. Tylko w sytuacji gdy aktualizacja wymaga usunięcia jakiegoś pakietu będziesz musiał użyć Synaptica (lub Adepta) lub konsoli z dist-upgrade.


(Filipsko) #5

Bardzo dziękuję za pomoc, szybką odpowiedź i linki :slight_smile:

Pozdrawiam, FilipS.