Problem z błędem win32k.sys oraz pełnym rejestrem systemu


(B Stebel) #1

Nie wiedziałem gdzie dokładnie umieścić ten temat, a więc z góry przepraszam za problem. A więc tak, parę dni temu kupiłem Sims3 Nie z tego świata. Przed instalacją Sims3 chodziło mnie bez zastrzeżenia. Po zainstalowaniu, włączam grę (potwornie długo się ładuje). Po około półtorej minuty gra albo minimalizuję się i “włącza” bardzo małą rozdzielczość (duże ikony i bardzo widoczne pixele) albo czarny obraz, zacięty dźwięk a później niebieski ekran i błąd w win32k.sys. Po ponownym włączeniu komp. wyświetla się komunikat : System osiągnął maksymalny rozmiar dozwolony dla części systemowej rejestru. Dodatkowe żądania przydziału miejsca będą ignorowane.

Odinstalowałem nie potrzebne rzeczy. Zwolniło się dość dużo miejsca na dysku. “Przeczyściłem” komp CCleaner’em oraz NTREGOPT.

Gra ma dużo miejsca na dysko bo 67 gb jest wolne.

Mój komp: Intel Core2 Duo CPU E6550 @ 2.33 GHz, 3 gb RAM. Karta ATI Radeon HD 3850. Service Pack 2. Windows XP.

A więc, co należało by zrobić by nie wyskakiwały takie błędy? Co powoduje “zapchanie rejestru”? Należy reinstalować system?


(Merliner) #2

Wielkość pliku wymiany pagefile?

Jeśli jest standardowa to jak na grę sims3 za mała. Zwiększ ilość pamięci poprzez

prawy klik na mój komputer -> właściwości -> zaawansowane -> wydajność -> zaawansowane

Na dole jest “Pamięć wirtualna”, zmień jej wielkość na większą.


(system) #3

Chcesz oczyścić rejestr, użyj porządnego programu, np. Wise Registry Cleaner http://www.dobreprogramy.pl/Wise-Registry-Cleaner,Program,Windows,13347.html w ustawieniach domyślnych, ponieważ CCleaner w bardzo małym stopniu czyści rejestr. Jeśli rejestr został poważnie uszkodzony, to reinstalacja systemu faktycznie może być konieczna.


(B Stebel) #4

w pamięci wirtualnej mam 6142 mb więc wydaje mi się że to dość dużo, ale jest taka jedna rzecz która mnie interesuje bo te 6142 mb mam z opcji ROZMIAR KONTROLOWANY PRZEZ SYSTEM, jeżeli chce sam ustawić “wielkość” to wyskakuje mi komunikat “Wprowadź maksymalny rozmiar pliku stronicowania, który może być większy lub równy początkowemu rozmiarowi pliku stronicowania oraz mniejszy niż 4096 MB” - więc o co chodzi? xd że sam sobie ustawia 6142 a ja mogę max 4096?


(Merliner) #5

nie, ze nie może być mniejsza od RAM, i tyle pewnie masz w komputerze.

Wink32k.sys jest głównie związany z kartą graficzną i sterownikami. Często karta graficzna ma za wysoką temperaturę lub zły sterownik i przez to też wywala taki błąd. W problemach z tym plikiem warto szukać najpierw przyczyn z kartą graficzną.

Wink32k.sys może mieć wiele oznaczeń błędu - głównie to karta i jej sterownik a potem płyta gówna i jej sterownik.

Odinstaluj sterownik karty grafiki, restart, zainstaluj.

UAC powinno być wyłączone na czas reinstalacji.


(Agatonster) #6

KurushUrush ,

Zapoznaj się z tematem i popraw tytuł tematu na konkretny, mówiący o problemie. W celu dokonania zaleconej korekty proszę użyć przycisku Edytuj przy poście otwierającym ten temat.

Zignorowanie zalecenia będzie skutkowało przeniesieniem tematu do Kosza.


(B Stebel) #7

Więc tak, zaktualizowałem sterownik, wyczyściłem Wise Registry Cleaner’em kompa. I problem prawie zniknął… Tzn. już nie wywala mnie z gry podczas grania tylko podczas samego wyłączenia gry - znów błąd win32k.sys. Czy to oznacza że należy zainwestować w nową kartę graficzną?


(system) #8

Nie! To oznacza, że nadal uszkodzony jest system operacyjny. Zainstaluj koniecznie Service Pack 3 dla Windowsa XP! Może się naprawić!


(B Stebel) #9

No właśnie z instalacją service packa 3 też jest problem… tzn podczas końcówki instalacji wyskakuje “odmowa dostępu” i następuje przerwanie instalacji :C w tym przypadku już próbowałem “naprawić” windowsa (mam orginalnego windowsa).


(system) #10

No to nie pozostaje nic innego jak reinstalacja systemu i zaraz po niej (przed sterownikami!) zainstalowanie Service Pack’ów 2 i 3, ponieważ kłopot z plikiem systemowym “win32k.sys” często jest skutkiem braku kompletu Service Pack’ów.


(B Stebel) #11

gruntowny format naprawił wszystko ;p widocznie mój komp był zbyt zasyfiony, temat do zamknięcia.

Rozwiązanie problemu - format