Problem z DPKG - błąd przy aktualizacjach


(Andrzej_R.) #1

(UBUNTU 6.10)

Podczas instalowania aktualizacji zresetowało mi (podejżewam że sie nie powinno to stać) kompa i teraz jak chce zainstalować kolejne aktualizacje pisze :

AN ERROR OCCURED

THE FOLLOWING DETAILS ARE PROWIDED

E: dpkg was interrupdated, vol must manually run 'dpkg --configure -a' to correct the problem

uruchamiam terminal / wpisuje i..... i mruga goły kursor w nowej lini i nic więcej się nie dzieje, czasem pisze że nie mem uprawnień ale nie wiem jak je w terminalu wpisać,

prubowałem wpisywać według tego co znalazłem na forum polecenie z sudo dpkg --configure -a ale efekt podobny jak wyżej

jak chcę zainstalować jakieś innepakiety pisze że mam uruchomionego updata i nie moge nic więcej instalować

proszę o pomoc i dokładny opis postępowania bo to muj pierwszy linuks i jestem kompletnie zielony


(Rkolodziejak) #2

Spróbój tego (w konsoli):

sudo apt-get update

sudo apt-get install dpkg

sudo dpkg --configure -a

jeśli nie zadziała to skorzystaj z synaptica (menedżer pakietów) lub adepta. Znajdź pakiet dpkg i prawy klik >> reinstaluj (request reinstall)

Zobacz jakie będą efekty i napisz.


(Andrzej_R.) #3

sudo apt-get install dpkg

Pomogło, dość długo "myślał" aż wymyślił i działa ale jak i co to nie mam pojęcia.

Dzięki za pomoc.