Problem z DXVa przy mkv 1080p


(Kamilw93) #1

Witam.

Niedawno zmieniłem system z przestarzałego już win XP na win 7, przez co pojawił się problem z odtwarzaniem plików mkv w większych rozdzielczościach.

Problem postaram się wyjaśnić na przykładzie 2 plików:

[Coalgirls]_The_Disappearance_of_Haruhi_Suzumiya_(1280x720_Blu-ray_FLAC)_[46A8DFE0]

[Coalgirls]_The_Disappearance_of_Haruhi_Suzumiya_(1920x1080_Blu-ray_FLAC)_[237D6BB3]

I komputerze:

Pentium 4 3.0 Ghz (wersja z HT)

Radeon HD 3650 AGP

2 GB ram DDR1

Podczas używania windowsa XP korzystałem z Media player classic home cinema. Bez problemu radził sobie z dekodowaniem powyższych plików z użyciem DXVa i wspomaganiem sprzętowym karty graficznej.

Po zmianie systemu na windows 7 z wyżej wymienioną konfiguracją (http://img291.imageshack.us/img291/4879/83818049.jpg)wystąpiły problemy podczas odtwarzania w.w plików a mianowicie:

1) 720p bez DXVa (tylko wbudowana matroska / DXVa wyłączone) użycie proca: 40% użycie karty 0%

2) 1080p bez DXVa (-||-) użycie proca: 40% użycie karty 0% - przycinanie obrazu , rozjechany obraz z dźwiękiem , nie da się oglądać

3) 720p z DXVa (jak na screenie wyżej) użycie proca 10% użycie karty 25%

4) 1080p z DXVa użycie proca 15% użycie karty 30%.

Niestety w opcjach 3 i 4 następuję ciągłe miganie obrazu (co sekundę pojawia się i znika czarny lub zielony obraz), a w scenach rozjeżdżają się pixele (http://img703.imageshack.us/img703/3850/12312255.jpg) co także uniemożliwia oglądanie. Czy jest jakiś sposób aby obraz 3) i 4) były normalne ale nie tracąc przy tym akceleracji ze strony karty graficznej ?

Wiem że pewnie powiecie że skoro mam obie wersje mogę obejrzeć 720p bez DXVa ale problem w tym że na dysku mam całe mnóstwo filmów 1080p i zależy mi na ich płynnym oglądaniu.


(Erufenrito) #2

A jakie masz ustawienia w "Strumień wyjściowy" - powinny być w przypadku Radka wszystkie opcje gdzie jest na czerwono zakreślone zaznaczone:

P52xp.gif


(slawex1983) #3

Eru nie sądzę, aby to pomogło. Roderick założę się, że odtwarzanie przez WMP będzie przebiegało bez najmniejszych problemów. Podobno program DXVAChecker potrafi włączyć akceleracje dla innych odtwarzaczy.


(Kamilw93) #4

Ustawienia w strumieniu wyjściowym miałem podobne poza alternatywną sychnronizacją pionową. Po jej włączeniu co prawda obraz przestał znikać / migać ale efekt rozjeżdżających się pixeli się wręcz nasilił. A co do próbowania innych odtwarzaczy:

KM Player - nie udało mi się włączyć sprzętowego dekodowania - ani z DXVA ani z CoreAVC Pro.

VLC - j.w

Innych programów nawet nie próbowałem bo te 3 (KM VLC i MPC) nigdy mnie nie zawodziły a mają największy wachlarz opcji i ustawiania kodeków.

-- Dodane 08.01.2011 (So) 17:28 --

Po ponownym powrocie na XP problem rozwiązany ale nie do końca. Obraz płynny jest równo z dźwiękiem a karta graficzna robi swoje ale:

W powyższych filmach (i innych 1080p jakie mam też) dźwięk jest zapisany w formacie FLAC. Mam np. dialog dwóch postaci. Jedną słychać dobrze a żeby usłyszeć drugą muszę dać na max głos i tak na zmiane. Np. leci sobie dźwięk otoczenia ale nie słychać postaci... W MPC są 2 dekodery flaca (wbudowany i zewnętrzny), na obu ta sama sytuacja. Ktoś ma jakieś propozycje co z tym fantem zrobić ?

-- Dodane 08.01.2011 (So) 17:54 --

CCCP i K-Lite sprawdzone. Problem ten sam. Pytanie czy może to być problem spowodowany sterami do karty dźwiękowej ? Karta sound blaster live 5.1. Wcześniej na xp miałem stery creativa a teraz Kx'y.

-- Dodane 08.01.2011 (So) 17:56 --

I jeszcze jeden UP: osobno flac jako mp3 (np soundtrack z anime) nie działa wcale. Leci ale nie słychać dźwięku.