Problem z dzwiękiem 5.1 w Ubuntu 16.04 LTS 64-bit


(blumberplumber) #1

Witam!
Mam problem z dźwiękiem w Ubuntu. otóż, system nie wykrywa podłączonych głośników 5.1. Widzi tylko Stereo:(.Mam więc do Was pytanie: Co muszę zrobić, by w Ubuntu działał mi dźwięk Surround 5.1? Moja płyta główna to ASRock B75M-DGS R2.0 z dźwiękówką Realtek HD Audio. Głośniki zaś, to Logitech X-530.


(p3#ytp) #2

To jeszcze napisz jak objawia się problem:

1 - działają tylko dwie frontowe kolumny, pozostałe milczą,
2 - działają dwie kolumny frontowe, centralna i subwoofer,
3 - wszystkie 6 kolumn działa, ale to nie jest prawdziwe stereo,

Być może wystarczy wybrać odpowiednią opcję w terminalowej aplikacji “alsamixer”? Rekonfiguracja alsy też może być pomocna - czasami po tym zabiegu pojawiają się suwaki z regulacją głośności dla poszczególnych kanałów.


(blumberplumber) #3

grają tylko dwie frontowe kolumny i lekko subwoofer, ale subwoofer gra zawsze, nawet jak w Windowsie 10 (mam dwa systemy na kompie) ustawię tryb stereo.
W tym Alsamixerze przestawiłem parametr “Channel” na “6ch” i zaczęły grać centralny głośnik i tylne kolumny, czyli niby OK, ale tak nie jest, gdyż w Ustawieniach Systemowych (zakładka Dźwięk) widoczne jest stereo.
Kiedy chcę przetestować dźwięk używając przycisku “Przetestuj dźwięk” i klikam np. na ikonkę lewego głośnika, to “Front left” słychać z lewego frontowego i centralnego, a po kliknięciu na ikonkę prawego głośnika, “Front right” słychać z… tylnych kolumn. Czyli wychodzi na to, że coś jest nie tak z ze sterami audio, albo Alsamixer coś miesza.
Podłączenie głośników wygląda tak:
Zielony wtyk do zielonego gniazda;
pomarańczowy wtyk do pomarańczowego gniazda;
czarny wtyk do niebieskiego gniazda (moja płyta nie ma czarnego gniazda). Nie powinno to jednak przeszkadzać, bo w Windowsie wszystko działa, pomimo takiego podłączenia.

dołączam screena z Alsamixera:


(eskimosek) #4

https://help.ubuntu.com/community/SurroundSound

sudo gedit /etc/pulse/daemon.conf
zmien i odkomentuj

default-sample-channels = 6

; default-sample-format = s16le
; default-sample-rate = 44100
; alternate-sample-rate = 48000
; default-sample-channels = 2 <--- to zmien na 6

(blumberplumber) #5

Rozwiązałem problem w taki sposób, że w “Ustawienia systemowe” …> “Dźwięk” przestawiłem tryb ze stereo na “Analogowe 5.1”, czy jakoś tak - nie pamiętam dokładnie.
W każdym bądź razie, w plikach konfiguracyjnych nic nie trzeba było grzebać - wystarczyły graficzne konfiguratory i Alsamixer :).
Dzięki bardzo za szybką odpowiedź i pomoc:)
Pozdrawiam:)
Jak będę na Ubuntu, to zapodam jeszcze screeny z okien ustawień systemowych i ew. zawartości pliku /etc/pulse/daemon.conf, to wtedy powiecie mi, czy mam poprawną konfigurację :smiley:

edit

screen z ustawień dźwięku:

Zawartość pliku /etc/pulse/daemon.conf:

; daemonize = no
; fail = yes
; allow-module-loading = yes
; allow-exit = yes
; use-pid-file = yes
; system-instance = no
; local-server-type = user
; enable-shm = yes
; shm-size-bytes = 0 # setting this 0 will use the system-default, usually 64 MiB
; lock-memory = no
; cpu-limit = no

; high-priority = yes
; nice-level = -11

; realtime-scheduling = yes
; realtime-priority = 5

; exit-idle-time = 20
; scache-idle-time = 20

; dl-search-path = (depends on architecture)

; load-default-script-file = yes
; default-script-file = /etc/pulse/default.pa

; log-target = auto
; log-level = notice
; log-meta = no
; log-time = no
; log-backtrace = 0

; resample-method = speex-float-1
; enable-remixing = yes
; enable-lfe-remixing = yes
; lfe-crossover-freq = 120

flat-volumes = no

; rlimit-fsize = -1
; rlimit-data = -1
; rlimit-stack = -1
; rlimit-core = -1
; rlimit-as = -1
; rlimit-rss = -1
; rlimit-nproc = -1
; rlimit-nofile = 256
; rlimit-memlock = -1
; rlimit-locks = -1
; rlimit-sigpending = -1
; rlimit-msgqueue = -1
; rlimit-nice = 31
; rlimit-rtprio = 9
; rlimit-rttime = 200000

; default-sample-format = s16le
; default-sample-rate = 44100
; alternate-sample-rate = 48000
; default-sample-channels = 6
; default-channel-map = front-left,front-right

; default-fragments = 4
; default-fragment-size-msec = 25

; enable-deferred-volume = yes
deferred-volume-safety-margin-usec = 1
; deferred-volume-extra-delay-usec = 0