Problem z eksploratorem w XP


(Robdk) #1

Witam

Przy starcie systemu wszystko idzie dobrze i w momencie, kiedy powinien pojawić się pasek zadań i pulpit - wyświetlana jest tylko czysta tapeta. Poprzez menadżera zadań można uruchomić dowolny program oprócz eksploratora Windows i IE. W trybie awaryjnym jest tak samo i nic nie mogę zrobić. Przywracanie systemu nie przyniosło pożądanego efektu jak i ponowne nadinstalowanie systemu.

Jedyną, rzeczą, jaką zrobiłem przed tym faktem było usunięcie żywcem z dysku plików toolbara Google (strasznie mnie te dodatki denerwują i podziałałem impulsywnie z pianą na ustach a można było to normalnie odinstalować), po zaistniałej sytuacji usunąłem wszystkie wpisy w rejestrze odwołujące się do tego toolbara i w msconfig wywaliłem ze startu – ale to nic nie pomogło…


(De Niro) #2

kliknij ALT+CTRL+DELETE i sprawdź czy został uruchominy proces explorer.exe, pradwopodobie został uszkodzony shell explorer, który odpowiada za graficzną cześć


(Robdk) #3

Sprawdzę po południu bo to w domu jest kompek...

Jak ew. naprawić??

Edit:

Z tego co pamiętam to ten proces nie jest uruchomiony, jak chce ręcznie wywołać to nic się nie dzieje...


(De Niro) #4

Musisz podmienić plik explorer.exe z konsoli odzyskiwania

Wejdz do konsoli odzyskiwania:

ren explorer.exe explorer.old

expand X:\i386\explorer_ C:\Windows\explorer.exe

X>>> to litera Twojego CDROM'u


(Robdk) #5

Niestety ale nie mogę wykonać operacji zkonsoli odzyskiwania komendy expand :frowning: - odmowa dostępu (oczywiście na haśle administratora)

Co można więcej zrobić??

Mam nadzieję, że da się system uratować bo dużo danych jest do stracenia....


(De Niro) #6

to zrób tak aby ominąć hasło :slight_smile:

start-> uruchm-> regedit

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Setup\RecoveryConsole

następnie w wartości SecurityLevel ustaw na 1 , gdzie już nie będzie pytał o hasło :wink:


(Robdk) #7

Ale hasło mi przujmuje i wchodzę do konsoli, tylko po wykonaniu komendy expand w wyniku działania jest odmowa dostępu....


(De Niro) #8

start-> uruchom-> regedit

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Setup\RecoveryConsole

SetCommand zmien na 1 w w konsoli lecisz komendy:

AllowAllPaths = True 

AllowRemovableMedia = True

AllowWildCards = True

NoCopyPrompt = True

Następnie:


(Robdk) #9

udało się zdekompresować plik ale explorer.ex_

Ale po odpaleniu systemu nadal jest to samo... :frowning:

W procesach nie ma uruchomionego procesu explorera

Jak odpalę go ręcznie to na chwilę pokazuje się pasek i zaraz znika...

Co można jeszcze?

EDIT

Zaraz sprawdzę, bo jak pisałem posta to nie widziałem poprawdki...


(De Niro) #10


(Robdk) #11

Nie było tego klucza

Także tej wartości nie było, utworzyłem nową wartość o nazwie Explorer.exe i danych Explorer.exe tylko nie jestem pewien czy o to chodziło...


(De Niro) #12

clipboard014ph.jpg


(Robdk) #13

Gapa ze mnie...

oczywiście jest ta wartość z danymi explorer.exe tak jka być powinno a system dalej swoje...

Nie wiem co może blokować działanie explorera...

czy coś złapałem??, czy jakaś aktualizacja się wtrąciła ( w czasie ostatniej prawidłowej pracy kompa ściągała sie jakas aktualizacja


(De Niro) #14

weź go reinstaluj, gdzie wszystkie dane pozostaną, Alt+Ctrl+Delete, Aplikacje, Nowe Zadanie F:\i386\winnt32.exe /unattend


(Robdk) #15

zanim zacząłem pisać na forum to już zrobiłem :frowning:

to chyba klapa będzie

a to już drugi system padnięty na dysku (pierwszego to ja ubiłem bo wyłączyłem VGA bo nie rozpoznawał nowek grafy i oczywiście dostałem w efekcie czarny ekran a po reinstalce to instalator nie może zakończyć działania) a teraz taka plama - nie mam sił, ale cóż trudno...


(De Niro) #16

sprawdź co pokazuje podgląd zdarzeń, start-> uruchom-> eventvwr.msc


(Robdk) #17

Zrobiłem jeszcze raz reinstalkę i nic z tego nie wyszło, dalej ten sam problem.

W podglądzie zdarzeń mam coś takiego:

Może to coś da...


(De Niro) #18

start-> uruchom-> services.msc

wyłącz usługe daj na Wyłączoną

włącz wszystkie usługi które sa od niej zależne w zakłdce zależności

Panel sterowania-> opcje folderów-> widok Odznacz Ukryj rozszerzenia znanych plików

zmień rozszerzenie na old, start-> uruchom-> %windir%\system32\drivers


(Robdk) #19

jak się dostać do panelu sterowania za pomocą "otwórz z" bo tylko mam taką możliwość - brak paska i przycisku "start"


(De Niro) #20

start-> uruchom-> control