Problem z filmami z Youtube


(Ebed) #1

Proszę o pomoc w następującej sprawie:

Ściągam filmy z Youtube poprzez program Youtube Downloader. Ściąganie jest OK. Ale jak odtwarzam ten film (mam allplayera) to już nie odtwarza mi polskich napisów (np. tłumaczeń które w normalnym odtwarzaniu filmu na Youtube są widoczne). Czy ktoś wie w czym problem?


(Agatonster) #2

ebed ,

Zapoznaj się z tematem i popraw tytuł tematu na konkretny, mówiący o problemie. W celu dokonania zaleconej korekty proszę użyć przycisku Edytuj przy poście otwierającym ten temat.

Zignorowanie zalecenia będzie skutkowało usunięciem tematu do Kosza.


(manieKMP) #3

Pewnie w tym, że napisy nie są wstawione w film, a YT tłumaczy je “w locie” (tip: Automatic Captions, przycisk “CC”). Nie zagłębiając się w technikalia, na YT działa coś takiego, co albo tłumaczy “audio” na tekst (wespół z google voice), albo wyświetla tekst z oddzielnego pliku, dodanego przez osobę wystawiającą dane wideo (nazywane jest to “automatic captions timing” i działa na podobnej zasadzie co pliki tekstowe z tłumaczeniem do zwykłych filmów, czyli w takim pliku są zawarte informacje kiedy dana partia tekstu ma być wyświetlona przez player).


(scripter1) #4

Jest dokładnie tak jak pisze manieKMP , te napisy nie są wbudowane w film więc pobierając film napisy się nie pobiorą.

Natknąłem się na program który ma umożliwiać pobranie napisów z Youtube ale nestety nie udało mi się go uruchomić aby go sprawdzić: http://google2srt.sourceforge.net/en/

Jeśli by się udało tym programem pobrać napisy w formacie SRT jak to sugerują autorzy to takie napisy ALLPlayer bez problemu wyświetli.