Problem z GIFami


(micechal) #1

Mam pewien problem, otóż na moim komputerze nie ruszają się GIFy. Różne emotikonki, obrazki... Co zrobić? Dodam, że kiedyś włączyłem Mozillę i były ruchome, ale zdarzyło się tak tylko raz... :slight_smile: Help!


(kalamita) #2

a w jakim program otwierasz GIFy ?


(Cosik Ktosik) #3

Możesz przywrócić ustawienia domyślne gifów:

Windows Registry Editor Version 5.00


[HKEY_CLASSES_ROOT\.gif]

@="giffile"

"CachedFilterIID"="{c3278e90-bea7-11cd-b579-08002b30bfeb}"

"Content Type"="image/gif"

"PerceivedType"="image"


[HKEY_CLASSES_ROOT\.gif\OpenWithProgids]

"giffile"=hex(0):


[HKEY_CLASSES_ROOT\.gif\PersistentHandler]

@="{098f2470-bae0-11cd-b579-08002b30bfeb}"


[HKEY_CLASSES_ROOT\giffile]

@="GIF Image"

"EditFlags"=dword:00010000

"FriendlyTypeName"=hex(2):40,00,25,00,53,00,79,00,73,00,74,00,65,00,6d,00,52,\

  00,6f,00,6f,00,74,00,25,00,5c,00,73,00,79,00,73,00,74,00,65,00,6d,00,33,00,\

  32,00,5c,00,73,00,68,00,69,00,6d,00,67,00,76,00,77,00,2e,00,64,00,6c,00,6c,\

  00,2c,00,2d,00,33,00,30,00,32,00,00,00

"ImageOptionFlags"=dword:00000003


[HKEY_CLASSES_ROOT\giffile\CLSID]

@="{25336920-03F9-11cf-8FD0-00AA00686F13}"


[HKEY_CLASSES_ROOT\giffile\DefaultIcon]

@="shimgvw.dll,2"


[HKEY_CLASSES_ROOT\giffile\shell]


[HKEY_CLASSES_ROOT\giffile\shell\open]

"MuiVerb"="@shimgvw.dll,-550"


[HKEY_CLASSES_ROOT\giffile\shell\open\command]

@="rundll32.exe %windir%\\system32\\shimgvw.dll,ImageView_Fullscreen %1"


[HKEY_CLASSES_ROOT\giffile\shell\open\DropTarget]

"Clsid"="{E84FDA7C-1D6A-45F6-B725-CB260C236066}"


[HKEY_CLASSES_ROOT\giffile\shell\printto]


[HKEY_CLASSES_ROOT\giffile\shell\printto\command]

@="rundll32.exe %windir%\\system32\\shimgvw.dll,ImageView_PrintTo /pt \"%1\" \"%2\" \"%3\" \"%4\""

Wklejasz to do notatnika i zapisujesz fix_gif.reg

Potem klikasz na pliku dwukrotnie i scalasz z rejestrem. Zrestartuj komputer.


(tores1977) #4

Jeśli to Vista to w IE7 lub firefoxie się będą poruszać jeśli to XP to jak napisał cosik_ktosik ,


(Cosik Ktosik) #5

Dla visty też jest fix:

Windows Registry Editor Version 5.00


[HKEY_CLASSES_ROOT\.GIF]

"Content Type"="image/gif"

@="giffile"

"PerceivedType"="image"


[HKEY_CLASSES_ROOT\.GIF\OpenWithProgids]

"giffile"=""


[HKEY_CLASSES_ROOT\.GIF\PersistentHandler]

@="{098f2470-bae0-11cd-b579-08002b30bfeb}"


[HKEY_CLASSES_ROOT\giffile]

@="GIF Image"

"FriendlyTypeName"=hex(2):40,00,25,00,53,00,79,00,73,00,74,00,65,00,6d,00,52,\

  00,6f,00,6f,00,74,00,25,00,5c,00,53,00,79,00,73,00,74,00,65,00,6d,00,33,00,\

  32,00,5c,00,73,00,68,00,65,00,6c,00,6c,00,33,00,32,00,2e,00,64,00,6c,00,6c,\

  00,2c,00,2d,00,33,00,30,00,35,00,39,00,35,00,00,00

"ImageOptionFlags"=dword:00000003


[HKEY_CLASSES_ROOT\giffile\CLSID]

@="{25336920-03F9-11cf-8FD0-00AA00686F13}"


[HKEY_CLASSES_ROOT\giffile\DefaultIcon]

@=hex(2):25,00,53,00,79,00,73,00,74,00,65,00,6d,00,52,00,6f,00,6f,00,74,00,25,\

  00,5c,00,53,00,79,00,73,00,74,00,65,00,6d,00,33,00,32,00,5c,00,69,00,6d,00,\

  61,00,67,00,65,00,72,00,65,00,73,00,2e,00,64,00,6c,00,6c,00,2c,00,2d,00,37,\

  00,31,00,00,00


[HKEY_CLASSES_ROOT\giffile\shell]


[HKEY_CLASSES_ROOT\giffile\shell\Open]


[HKEY_CLASSES_ROOT\giffile\shell\Open\command]

@="\"C:\\Program Files\\Internet Explorer\\iexplore.exe\" -nohome"


[HKEY_CLASSES_ROOT\giffile\shell\Open\ddeexec]

@="\"file:%1\",,-1,,,,,"


[HKEY_CLASSES_ROOT\giffile\shell\Open\ddeexec\application]

@="IExplore"


[HKEY_CLASSES_ROOT\giffile\shell\Open\ddeexec\topic]

@="WWW_OpenURL"


[HKEY_CLASSES_ROOT\giffile\shell\printto]


[HKEY_CLASSES_ROOT\giffile\shell\printto\command]

@=hex(2):22,00,25,00,53,00,79,00,73,00,74,00,65,00,6d,00,52,00,6f,00,6f,00,74,\

  00,25,00,5c,00,53,00,79,00,73,00,74,00,65,00,6d,00,33,00,32,00,5c,00,72,00,\

  75,00,6e,00,64,00,6c,00,6c,00,33,00,32,00,2e,00,65,00,78,00,65,00,22,00,20,\

  00,22,00,25,00,53,00,79,00,73,00,74,00,65,00,6d,00,52,00,6f,00,6f,00,74,00,\

  25,00,5c,00,53,00,79,00,73,00,74,00,65,00,6d,00,33,00,32,00,5c,00,73,00,68,\

  00,69,00,6d,00,67,00,76,00,77,00,2e,00,64,00,6c,00,6c,00,22,00,2c,00,49,00,\

  6d,00,61,00,67,00,65,00,56,00,69,00,65,00,77,00,5f,00,50,00,72,00,69,00,6e,\

  00,74,00,54,00,6f,00,20,00,2f,00,70,00,74,00,20,00,22,00,25,00,31,00,22,00,\

  20,00,22,00,25,00,32,00,22,00,20,00,22,00,25,00,33,00,22,00,20,00,22,00,25,\

  00,34,00,22,00,00,00

Resztę robisz jak dla XP


(tores1977) #6

Dzięki wielkie cosik_ktosik , skorzystam :wink:


(micechal) #7

wielkie dzieki gify juz sie ruszaja THX

W dniu 23.07.2008 , o godzinie 14:43 został dopisany post przez micechal

Nie no, sorry, jednak sie nie ruszają :slight_smile: zrobiłem tak, jak mówiłeś, cosik_ktosik, ale jest tak samo (mam XP). Nie ruszają się ani emotikonki, ani np. awatary... Pomóżcie!


(Cosik Ktosik) #8

A z jakiej przeglądarki korzystasz?


(micechal) #9

używam tylko Firefoksa 2


(Cosik Ktosik) #10

Próbowałeś go reinstalować? Zrób standardową diagnostykę: http://mozillapl.org/wiki/Standardowa_D ... a:_Firefox


(micechal) #11

nie w tym problem

probowalem tez w iei tez sie nie ruszaly

to nie wina firefoksa :frowning: