Problem z instalacją Linux Mint x64 na AspireOne 532h


(jeikobu614) #1

Witam, posiadam notebooka Acer Aspire One 532h z procesorem Intel Atom N450. Z specyfikacji procesora wynika, że obsługuje on system 64-bitowy. System się instaluje ale po restarcie komputer w ogóle nie bootuje tego systemu (czarny ekran z mrugającą kreską). Próbowałem również wersje 32-bitową i działa normalnie. Prosił bym o pomoc, jeśli istnieje sposób instalacji wersji x64.


#2

 

jeikobu614, proszę zapoznaj się z tą stroną oraz tym tematem, a następnie, używając opcji EDYTUJ , później Użyj pełnego edytora , popraw tytuł tematu, tak aby mówił konkretnie o problemie. W przypadku zignorowania prośby temat poleci do śmietnika.


(roobal) #3

Jaki wybierasz układ partycji, MBR czy GPT? Instalujesz na Ext4 czy może na Btrfs?


(jeikobu614) #4

Układ partycji? Nic takiego nawet nie zauważyłem. System instaluje się na ext4.

 

Spróbowałem jeszcze inną opcje, mianowicie zainstalowałem x64 obok x32. Efekt jest taki, że grub pojawia się z x32 i opcją zaawansowane, w której jest x64 i normalnie się włącza. Zależy mi tylko na systemie x64. Więc teraz jak się pozbyć reszty?


(marcin82) #5

Podaj wynik skryptu bootinfoscript:

http://sourceforge.net/projects/bootinfoscript/ .


(jeikobu614) #6

Wynik skryptu:Klik


(enedil) #7

Masz tablicę partycji MBR. Moim zdaniem nie powinno być żadnego problemu (nie widać tam Windowsa). Pamiętej tylko o przełączeniu się na BIOS-legacy zamiast UEFI (na razie lepsze rozwiązanie na Linuksach)>


(jeikobu614) #8

Windowsa nie ma, ponieważ go odinstalowałem. Ten notebook nawet nie ma UEFI.

 

Sytuacja w tej chwili wygląda tak, że posiadam dwa systemy: jeden x32 i drugi x64. Jak teraz pozbyć się pierwszego systemu, tak by pozostał tylko x64?

Do tego próbuje zainstalować kernel Netext’73. Owszem instaluje się ale system ciągle startuje ze starym kernelem, a w menu gruba nie ma opcji jego zmiany.


(marcin82) #9

Uruchom system 64 bit, podaj wynik poleceń:

cat /etc/fstab

cat /etc/mtab

 

Zainstaluj Gruba w MBR poleceniem:

sudo grub-install --no-floppy --recheck /dev/sda

Podaj dodatkowo wyniki:

sudo os-prober

sudo update-grub

Na koniec pokaż:

cat /boot/grub/grub.cfg

(jeikobu614) #10

fstab

# /etc/fstab: static file system information.
#
# Use 'blkid' to print the universally unique identifier for a
# device; this may be used with UUID= as a more robust way to name devices
# that works even if disks are added and removed. See fstab(5).
#
# <file system> <mount point> <type> <options> <dump> <pass>
# / was on /dev/sdc1 during installation
UUID=4a7c6fbf-62d8-40da-a698-e125dc942250 / ext4 errors=remount-ro 0 1
# swap was on /dev/sdc5 during installation
UUID=b645b865-c337-4e2a-8928-137ed43092af none swap sw 0 0

 

/dev/sda1 / ext4 rw,errors=remount-ro,commit=0 0 0
proc /proc proc rw,noexec,nosuid,nodev 0 0
sysfs /sys sysfs rw,noexec,nosuid,nodev 0 0
none /sys/fs/cgroup tmpfs rw 0 0
none /sys/fs/fuse/connections fusectl rw 0 0
none /sys/kernel/debug debugfs rw 0 0
none /sys/kernel/security securityfs rw 0 0
udev /dev devtmpfs rw,mode=0755 0 0
devpts /dev/pts devpts rw,noexec,nosuid,gid=5,mode=0620 0 0
tmpfs /run tmpfs rw,noexec,nosuid,size=10%,mode=0755 0 0
none /run/lock tmpfs rw,noexec,nosuid,nodev,size=5242880 0 0
none /run/shm tmpfs rw,nosuid,nodev 0 0
none /run/user tmpfs rw,noexec,nosuid,nodev,size=104857600,mode=0755 0 0
binfmt_misc /proc/sys/fs/binfmt_misc binfmt_misc rw,noexec,nosuid,nodev 0 0
gvfsd-fuse /run/user/mini-pc/gvfs fuse.gvfsd-fuse rw,nosuid,nodev,user=mini-pc 0 0

 

No volume groups found
/dev/sda6:Linux Mint 15 Olivia (15):LinuxMint:linux

 

Generating grub.cfg ...
Found linux image: /boot/vmlinuz-3.12.6-ext73-f1-27.3-atom-ags-cfs
Found initrd image: /boot/initrd.img-3.12.6-ext73-f1-27.3-atom-ags-cfs
Found linux image: /boot/vmlinuz-3.8.0-19-generic
Found initrd image: /boot/initrd.img-3.8.0-19-generic
Found memtest86+ image: /boot/memtest86+.bin
  No volume groups found
Found Linux Mint 15 Olivia (15) on /dev/sda6
done

grub.cfg


(enedil) #11

Nie możesz po prostu usunąć starego kernela?


(jeikobu614) #12

Jak, skoro system z niego korzysta? A w grubie nie ma opcji by wybrać nowszy.


(StarterX4) #13

zaktualizuj kernela z wersji “3.8.0-19-generic” do “3.12.x-xx-generic”. znajdziesz go w repo.


(jeikobu614) #14

Okej, jakimś cudem pojawił się w końcu kernel który instalowałem i działa (ciekawe na jak długo :D) Tylko teraz jak uporać się z systemem x32? Gparted?


(marcin82) #15

Skoro instalowałeś Gruba z poziomu systemu 64-bit to teraz możesz spokojnie usunąć partycję " / " systemu 32 bit - /dev/sda6.

 

Nie zrobisz tego z systemu 64-bit, ponieważ /dev/sda6 razem z partycją swap wchodzi w skład partycji rozszerzonej /dev/sda2.

 

Uruchom dowolne livecd, odmontuj ew. wszystkie zamontowane automatycznie partycje, usuń /dev/sda6. Uruchom potem normalnie system 64-bit i wykonaj:

sudo update-grub

(jeikobu614) #16

Zrobione. Tylko czy tą partycje da się połączyć znowu w całość, czy zostanie do alokacji?


(marcin82) #17

Możesz w tym samym miejscu utworzyć nową partycję ext4, a sprawdzić co jest i jak możesz za pomocą polecenia:

sudo fdisk -l

(jeikobu614) #18

Czyli zostanie już partycją do alokacji? Trudno najwyżej coś się kiedyś obok postawi :smiley: Dzięki za pomoc :wink:


(roobal) #19

Ja kiedyś miałem podobny problem na Debianie i Ubuntu x86_64, tyle że u mnie Grub przy Btrfs nie chciał się instalować.

Możesz spróbować wykorzystać LVM.