Problem z instalacją prestashop

Witam, przy instalacji jest błąd (załączam zdjęcie). Wersja php serwera 7.2, wersja presta najnowsza, przy próbie ponownej i stacji wyskakuje błąd, „ strona nie działa „

Sprawdź w logach serwera http (apache, nginx czy co tam masz) dlaczego wywala Ci kod 500. Sprawdź też logi PHP. Baza działa? Co tam masz? MySQL, MariaDB, a może PostgreSQL?

MySQL, błąd z error logów php -
Cannot serve directory /home/----------: No matching DirectoryIndex (index.html,index.cgi,index.pl,index.php,index.xhtml,index.htm,index.html,index.htm,index.shtml,index.php,index.php3,index.php4,index.php5,index.phtml,index.cgi,index.pl,index.py,index.wml,default.html,default.htm,default.shtml,default.php,default.php3,default.php4,default.php5,default.phtml,default.cgi,default.pl,default.py,default.wml) found, and server-generated directory index forbidden by Options directive

Sprawdź czy ruszy na PHP 7.1, potem czy już najnowsza PrestaShop działa na 7.2 - 7.4 bez błędów.

Zaś webserver to? Masz włączoną obsługę plików index?

Po logach jestem zaryzykować dwa stwierdzenia:

  1. webserv to apache2
  2. dostaliśmy logi od httpd zamiast od php-ca, który sypnął 500.

Też myślę, że apache, ale po co zgadywać :wink:

Dokładnie, apache było przyczyną.

Zainstalowałeś coś innego czy przekonfigurowałeś Apache?