Problem z instalacją Ubuntu 14 64bit w VirtualBox


(hatezit) #1

Mam pytanie, pobrałem obraz ubuntu 14 na wersję 64bit ale gdy odpalam w wirtualnej maszynie, to nie mogę zainstalować, a mam procesor amd przystosowany na architekturę 64 bitową. Moglem Windows server 2012 64bit zainstalować a ubuntu nie mogę.

Też problem jest z quest additions, isntaluje ale lipa z pełnym ekranem.  Co źle robię?


(Jusko) #2

Cóż - tak się składa, że instalowałem dziś na VM akurat Ubuntu 14.04 x64 i problemów nie miałem :slight_smile: Jakiś komunikat się wyświetla przy odpalaniu systemu? A może gdzieś instalator się wykłada? Musisz opisać to bardziej.

 

Czy masz zainstalowane nagłówki (header) kernela i rzeczy potrzebne do zbudowania modułu gościa dla jądra? Czy próbujesz instalować dodatki na wersji Live (cóż, po tym przydałby się restart systemu, a wiadomo, że na Live to średnio wykonalne bo zmiany nie są zapisywane)?

 

Generalnie wina nie leży po stronie systemu, gdyż nie miałem żadnych problemów z instalacją pod VirtualBoxem i zbudowaniem modułu do jądra.


(roobal) #3

Czym ta niemożność się objawia, bo jasnowidzem nikt tu nie jest?


(S3BA_) #4

Czy z listy dostępnych systemów na pewno wybrałeś Ubuntu-64 ? Bo na Ubuntu-32 nie postawisz wersji 64.


(hatezit) #5

Witam, jedyny komunikat przy odpalaniu Ubuntu 64 bitowego to taki abym BIOS zaktualizował. Ale inne systemy 64 biyowe, np Windows Server 2012 nie dawał takich komunikatów. Wczesniej instalowalem linuxy 32 bit na biezącym 64 bitowym systemie, nie na odwrot.

a ja stąd pobrałem: http://releases.ubuntu.com/14.04/


(roobal) #6

Zainstalowałeś guest additions dla systemu 64-bitowego?


(hatezit) #7

Ja instalowalem po przez opcję jaka jest w VirtualBox czyli insert quest additions. Jak zaczyna się instalować to wyskakuje terminal i tam widzę co dzieje się. Jak pisałem wyżej, instaluje się, wszystko jest na done. Ale jeżeli poraz kolejny instaluje to wyskakuje w terminalu komunikat że drivery X Window są niekompatybilne.

 

Jeszcze jedno, jak miałem ubuntu 12 32 bit, problemów z quest addition nie miałem. A w wersji 32 i 64bit Ubuntu 14.04 miałem problem.


(Jusko) #8

Guest Additions działają - sam testowałem, nawet ponownie przed chwilą :slight_smile: I też mam 64 bitowy system, fullscreen działa :slight_smile:

 

Po restarcie sprawdziłeś oczywiście, czy masz dostępną wyższą rozdzielczość w opcjach ekranu?

 

EDIT:

 

System musi działać - nie może być tak, że innym działa, Tobie nie :wink: Problem jest gdzieś pośrodku. Jeśli mimo wszystko nie działa - instalacja dodatków gdzieś się wykłada (brak odpowiednich pakietów w systemie?). Sam wspominasz o jakiś cudach w stylu niekompatybilne drivery dla X Window, więc może warto raz jeszcze prześledzić proces (gdyż u mnie VirtualBox ze strony Oracle bez problemu zainstalował dodatki gości dla Ubuntu 14.04 x64, w tym bez problemu dla X Window).


(roobal) #9

Zainstaluj dodatki ręcznie, być może w tej wersji VB, której używasz jest jakiś błąd. Spróbuj jeszcze najpierw doinstalować VBox Extensions, co prawda one wprowadzają obsługę USB itd., ale może system ich wymaga. Ubuntu jest dziwne, więc wszystkiego można się po nim spodziewać.


(hatezit) #10

Teraz zaktualizowalem Virtualbox do nowszej wersji bo miałem komunikaty. Teraz jakoś wolno ubuntu instaluje się, pakiety pobieraja się że raz jest 13 min, raz 40min i więcej a później mniej. Cholera mnie bierze. Jak na VBox nie da się, to zobacze na VMplayer, może lepiej będzie działać lub dam sobie z ta wersją leciwą spokój i zobacze na live CD uruchamiając kompa.

 

 

Dobra mam pełny ekran:) Ale jakos ta wersja wolno działa niż poprzednie wersje ubuntu. wolniej okna się otwierają.


(Jusko) #11

A ile przydzieliłeś czasu procesora, pamięci graficznej dla systemu i RAM? Raczej tu domyślałbym się przyczyny wolnego działania Unity/systemu :wink:

 

Pakiety mogą mieć też różne czasy, zależnie od skoków transferu bądź obciążenia serwera.

 

Raczej porządnie sprawdź ustawienia maszyny wirtualnej, bo raczej nie zwróciłeś po prostu uwagi na wszystkie parametry i stąd system pracuje jak pracuje. Sprawdziłem z ciekawości Twoje problemy na 3 różnych komputerach, poustawiałem wszystko w miarę odpowiednio i na żadnej maszynie nie potwierdzam Twoich objawów, także problem leży chyba gdzieś u Ciebie w ustawieniach maszyny, bądź Twój komputer średnio wyrabia z wirtualizacją, więc w ustawieniach wirtualki jest raczej problem a nie po stronie VirtualBox jako takiego...


(roobal) #12

Jeśli twój procesor nie wspiera wirtualizacji sprzętowo, to ma prawo mulić szczególnie na słabszych procesorach. Jeśli nie masz wsparcia dla wirtualizacji ze strony procesrowa, to Ubuntu z Unity lepiej odpalić sobie na Xenie.


(hatezit) #13

Ja tworząc dysk wirtualny dałem prawie 12GB na rozmiar zaznaczając fixed size. Pamięć ram, nie całe 800RAM. Czy mój procesor wpiera wirtualizację, hmm kupowałem w 2010 roku, procesor to AMD Phenom II X4 965 3.4GHz. A co powinienem ustawić?


(Jusko) #14

Aby działało si, to RAM-u powinieneś ustawić przynajmniej 2GB i ok. 64MB pamięci graficznej (a i tak będzie się nieco wlec na takim ustawieniu, bo nawet na takim real hardware, Unity demonem by nie było) :wink: Nie dziwne, że Ubuntu działa wolno :wink: Procesor z tego co kojarzę - wirtualizację wspiera.

 

Jeśli nie ma komplikacji jeszcze gdzieś indziej - przydzieliłeś zwyczajnie zbyt mało zasobów.

 

EDIT:

 

Możesz jeszcze wejść w ustawienia maszyny z systemem, potem System --> Acceleration i zobaczyć, czy masz zaznaczoną wirtualizację sprzętową (opcje od tego są również w BIOS zazwyczaj).


(hatezit) #15

No procesor jaki mam, to dziś nie jest najwyższych lotów. Przewaznie już moi znajomi i nie tylko mają po 6 i więcej rdzeni. Dziwią się jak mogę mieć procesor z 4 rdzeniami, bo wg.nich na takim nieda się nic  zrobić. Są grafikami.

Co do akceleracji w BIOS, to mam włączone, bo musiałem włączyć gdy musiałem zainstalować Windows Server 2012 64bit aby zaliczyć przedmiot i zadania na tym opierały się. A jeżeli chodzi ile ogólnie RAM mam w kompie to 8GB na DDR3.


(Jusko) #16

Cóż - ja mam 2 rdzenie w maszynie i jakoś żyję + wirtualizuję nawet systemy :slight_smile: Jeśli Twoi znajomi renderują jakieś zaawansowane grafiki 3D, to wiele rdzeni im się przyda, jednak nawet gry komputerowe nie są w stanie obsłużyć więcej niż 4 rdzenie (to nie jest tak, że aplikacja sama z siemie umie wskakiwać na rdzenie i się ugościć jak należy, bo programista też musi to zaplanować) :slight_smile:

 

OK, zatem zaznacz maszynę na liście, potem:

 

  • Settings --> System --> Base Memory i ustaw na 3GB a co :slight_smile: 2GB też by starczyły, jednak taka ilość pamięci jest dopiero zalecana do używania Ubuntu z Unity i dopiero wzwyż praca zaczyna być komfortowa

 

  • Settings --> System --> Processor --> Processor(s) i przydziel np. 2 rdzenie do obsługi wirtualki (choć u mnie i z jednym rdzeniem na obsługę daje radę, choć czuć opóźnienia). Execution Cap powinno być na 100% - suwak ten tak po ludzku oznacza, ile "mocy" procesora ma iść w przetwarzanie maszyny

 

  • Settings --> System --> Display i ustaw od 64MB w górę (polecam od 128MB lub tę ilość). W Extended Features możesz również zaznaczyć akcelerację.

 

Po takim ustawieniu maszyna nie może działać powolnie :slight_smile:


(hatezit) #17

A to teraz czaję, czemu wcześniejsze wersje linuxa działały płynnie a wersja 14 tnie się troszkę. I przty 32 bit też tak by było? Spróbuje dać 2GB RAM, zobaczę jak będzie. Mam nadzieje, że nie spowolni mi kompa gdy w VirtualBox tak ustawię. Ja w grafice nie siedzę i jakos w 3d nie zamierzam nić tworzyć. Wolę apliakcje internetowe tworzyc i bazy danych:)


(Jusko) #18

Wielkiej różnicy dla wersji x86 by nie było - Ubuntu z Unity tak czy siak ma swoje wymagania (głównie Unity). Mając 8GB RAM nie musisz się bać o spowolnienia - ja mam 4GB i daję radę :slight_smile: Oczywiście jak zaczniesz odbiążać mocno maszynę wirtualną jakimiś operacjami + komuter też czymś będzie obciążony, no to wtedy coś będzie chrupać, ale to logiczne.


(hatezit) #19

I lepiej działa gdy dalem na 3 GB RAM i włączyłem akcelerację w Extended Features. Ale komunikat dostałem przy zamykaniu ubuntu na VBOX'ie, że program przestał działać i nastąpi zamknięcie. Ale wersja 12 ubuntu linuxa też mi się spodobała, a 14 tylko chce przetestować kilka dni i return to ubuntu 12.


(roobal) #20

Możesz sprawdzić poleceniem w terminalu.

grep svm /proc/cpuinfo

Jeśli nic się nie wyświeli, oznacza to, że procesor nie ma wsparcia dla wirtualizacji.