Problem z internetem w kali linux


(Szkielko2012) #1

Zainstalowałam kali linux na virtualboxie. W ustawieniach wybrałam połączenie mostkowe, które jest wymagane do połaczenia z internetem. Niestety mimo wszystko nie mam internetu. Proszę o pomoc.


(Juche) #2

Poprawnie skonfigurowałeś sieć w tym zwirtualizowanym Kali? Jeśli wirtualizujesz jakikolwiek OS, to połączenie w nim ustawiasz po DHCP, niezależnie od tego, co masz w systemie-gospodarzu. A i jeszcze jedno: Guest Additions zainstalowane?


(nintyfan) #3

Pewnie wybrałaś “połączenie mostkowe” w systemie gościu. Jakie masz opcje sieciowe w VirtualBox? Wszystko powinno działać out-of-the-box. Czy system-gość widzi wirtualną kartę sieciową?

Guest additions chyba nie są potrzebne do kontaktu z internetem.


(Szkielko2012) #4

 

 

 

Niestety nie pomogło. Kiedy wejdę w ,Sieć" mam tam ,Sieć Windows".


(marcin82) #5

Wybierz “NAT” w ustawieniach VBox.


(fedora24x) #6

Virtualbox domyslnie udostępnia internet wirtualizownym systemą a jak nie ma to dodajesz NAT.


(Szkielko2012) #7

 

Niestety to również nie pomaga. Wyskakuje mi, że nie można automatycznie skonfigurować sieci.

 


(nintyfan) #8

Może Linux nie obsługuje jakiejś wirtualizowanej karty sieciowej, choć wątpię. Jako typ karty sieciowej wybrałaś w ustawieniach maszyny wirtualnej?


(Szkielko2012) #9

 

 

Wybrałam Intel PRO/1000 MT Dektop (82540EM).


(roobal) #10

Wybierz domyślną kartę sieciową (pierwszą z listy). Czasami VirtualBox ma problem z połączeniem na gigabitowej karcie, zwłaszcza jak karta fizyczna to fast ethernet.


(Szkielko2012) #11

 

 

Użyłam domyślnej karty sieciowej i również nie działa.


(marcin82) #12

Sprawdź jeszcze czy program VirtualBox nie jest blokowany przez zaporę sieciową, pakiet antywirusowy (aplikacja zaufana / niezaufana), może jakiś program typu MBAM itp., itd.

 

Sprawdziłem livecd na hoście linuksa i wszystko gra - internej jest. Karta sieciowa w VBox ustawiona na NAT.


(roobal) #13

Dokładnie, podczas instalacji system pyta czy zezwolić adapterom sieciowym na dostęp do sieci.


(Szkielko2012) #14

Po ustawieniu NAT udało mi się zainstalować kaliego bezproblemowo i mam internet, ale po wpisaniu w konsolę ,iwconfig" nadal nie wyświetla się wlan0.


(roobal) #15

Widzę następny h@ki3r. Na VMce bez pass-through nie będziesz miał dostępu do karty wlan. Musisz wpiąć sobie kartę na usb lub uruchomić system na fizycznej maszynie. Tak poza tym Kali nie powstał jako narzędzie do hackowania, lecz jako system do pentestów.


(Szkielko2012) #16

Dziękuję za odpowiedź.