Problem z kodem HTML - serwis Allegro


(Stratus84) #1

(Kontakt) #2

Najprawdopodobniej dodajesz kod w edytorze wizualnym i wtedy szablon allegro dodaje sobie twarde spacje ( ).

Cały szablon wklej w edytorze tekstowym (tak gdzie wklejasz, możesz sobie przełączyć:wink: )


(Stratus84) #3

Właśnie od samego początku cały kod wklejam do edytora tekstowego a nie wizualnego a później sprawdzałem na podglądzie i całą środkową część oprawy graficznej przesuwa na lewą stronę. Dziwne bo jak otwieram ten kod w przeglądarce to wszystko jest dobrze.


(Kontakt) #4

Ja widzę, to tak:

8a6cd425fc.jpg

Tak ma być?


(Stratus84) #5

Tak jak widzisz jest prawidłowo. Ja też tak widzę gdy otwieram to przez przeglądarkę natomiast gdy kopiuje kod do allegro i daję podgląd strony to wygląda to tak: http://fotozrzut.pl/zdjecia/34722f08f8.jpg. I w tym jest właśnie problem. Jeśli się nie da tego poprawić lub ja robię coś źle (bo jest taka ewentualność)to trudno najwyżej poszukam jakiegoś innego szablonu. Dzięki za odpowiedzi i zainteresowanie :slight_smile:


(Kontakt) #6

Ja po prostu skopiowałem Twój kod i wkleiłem go w edytor tekstowy (nie wiem, może tutaj masz błąd: jak masz włączony edytor tekstowy to widzisz przycisk edytor wizualny (nie edytor tekstowy) )i tak go zobaczyłem, więc styl jest na pewno dobry :wink:


(ra-v) #7

Allegro wywala tego typu kody

więc trzema wszystko robić ręcznie

................

Na javascript też nie ma co liczyć.


(IcyMat) #8

Nie możliwe - ja normalnie używam

i działa. Więc to nie może być problemem...


(ra-v) #9

Hmmmm - z tego co wiem i próbowałem to mi wywala. Wszystko robię akurat przy pomocy php (zmienne to klasy itd itd), więc mam i tak mniej pisania, potem kopiuje źródło do Allegro.pl. Bo generalnie jakbyś zmienił jakiś rodzimy styl allegro (np. *{float:left;}) to by była kaszanka na Allegro.

A w jaki sposób udało ci się to zrobić? możesz pokazać przykład:)? bo sam jestem zaciekawiony, przydało by się to. Może jednak ostatnio coś zmienili? I przede wszystkim czy WSZYSTKIE style działają?


(Kontakt) #10

Mi też jak sprzedawałem na allegro nie wywalało :wink: Zwyczajnie dodawałem style do pliku przez


(Monczkin) #11

stratus84 , nazwij temat konkretnie, zgodnie z zasadami nazywania tematów na forum. Przeczytaj regulamin.


(Stratus84) #12

Dzięki za odpowiedzi. Zrezygnowałem z tamtego szablonu bo jakoś ciągle "rozrzucało" mi układ graficzny szablonu. Tak jak pisał użytkownik: "ra-v" Allegro wywala niektóre kody.

W moim przypadku po skasowaniu z źródła HTML:

oraz

Allegro już nie informuje o złym kodzie i można bez problemu użyć szablonu do tworzonej aukcji:)

Pozdrawiam.

-- Dodane 19.01.2010 (Wt) 9:28 --

Już poprawiłem - mam nadzieję, że teraz jest lepiej:)