Problem z kompatybilnością w buildzie 7057


(Grzegorz Osator) #1

Witam!

Mam program korzystający z bazy SQL. Na buildzie 7000, 7022 wszystko ok - chodzi normalnie.

Na buildzie 7057 po pierwsze nie da sie go zainstalować (nawet przy wyłączonym UAC) - program tworzy nowego użytkownika z uprawnieniami administratora i to pewnie się systemowi nie podoba.

W przypadku aktualizacji - program bedzie, ale najpierw trzeba mu pozwolić na share z kontem administracyjnym programu, czyli udostępnić share. ok. Ale po nadaniu wszelkich możliwych uprawnień podaje komunikat, że fix15.exe trzeba zaktualnić do najnowszej wersji. Tyle, że jest w najnowszej. Nie wiem, czy to jakiś błąd uprawnień, czy co mu jeszcze dodać...

-- Dodane 19.03.2009 (Cz) 8:28 --

Już chyba wiem - chodzi o to, że UAC nie pozwala procesowi niższego rzędu na podniesienie uprawnień.

Ktoś wie jak to obejść - bo wyłączenie UAC i zapory na niewiele się zdaje...


(Emlo16) #2

Uruchomić niższy proces z prawami admina. Nic innego do głowy nie przychodzi.


(Grzegorz Osator) #3

Nic to nie daje - nie puszcza.


(Raq 88) #4

Jaki to program ?


(Grzegorz Osator) #5

RCS Selector