Problem z komunikacją z poprawnie zainst. urządzeniem USB


(Radda32) #1

Witam

Pytanie dotyczy portów COM czy też wirtualnych portów, które to oprogramowanie "tworzy" do komunikacji z zewnętrznym urządz. podpiętym przez usb.

Chodzi o program Sporttracks, który po zainstalowaniu odpowiedniego plugina ( program rozpoznaje urządzenie i wyświetla je w spisie obsługiwanych urządzeń ) w momencie próby sciągnięcia danych z pulsometru nie widzi kabla usb ( komunikat - Usb cable clip not found ) Dodam, że u innego użytkownika/ów wszystko działa.

Pulsometr ma swój natywny soft z którym współpracuje bez problemu. Soft ten instaluje dwa rodzaje driverów.

  • Windows Driver Package - Sunplus (SPCP825K) Ports

  • Silicon Lab. CP210x VCP Drivers USB to UART Bridge

!!

34oonzb.jpg

natomiast u użytkownika gdzie wszystko śmiga:

w17o74.jpg

Dlaczego przy podłączeniu w jednym przypadku odwołanie jest do ster. Sunplus a w drugim SilLabs ?

Jest to jedyna dostrzgalna przeze mnie różnica ( te same pulsometry, to samo opragramowanie, myślałem że to może kwestia sys. operac. i sprawdziłem na Win 7 ale bez zmian )

U wspomnianego użytkownika w Dodaj/Usuń Programy także są zainst. sterowniki SiliconLab i Sunplus.

Program prawidłowo inicjuje włączenie plugina jednak ten nie może skomunikować się z portem ?

29ik9t.jpg

Wydaje mi się że wtyczka odwoluje się przy pomocy ster. Sunplus.

Próbowałem odinstalować SilLabs i zostawić Sunplus, ale wtedy jest komunikat ( w oprogramowaniu natywnym ) że nie można ustanowić wirtualnego portu.

Byłbym wdzięczny za wszelką pomoc.