Problem z lagami poraz etny


(Sir Dzik~) #1

Ping z http://www.wp.pl:

c1f960603991365a.jpg

Ping w sumie nie jest źle, ale np. w grze "Tibia" mam straszne przycinki, sam nie wiem czy to spowodowany lagami czy czym, ale raczej wina neta, bo mam także "freezy". Dzieje się to już od ponad miesiąca ;/ Nie wiem czym to może być spowodowane. Mam łącze 320 kbit, może nie za szybkie, ale wcześniej nie miałem problemu lagów. Log z HijackThis już dawałem i komp jest czysty. Programem SpyBot Search Destroy też wywałem niepotrzebne rzeczy, które znalazł. Więc w czym problem? ;/ Pomóżcie.


(Boner3773) #2

lagi w tibii są spowodowane przeciążeniem serverów, lub jeżeli masz neostradę na grasz na serwerze amerykańskim to będziesz mieć lagi bo sygnał musi trafić do usa, i to chwile trwa...

popytaj na forum czy nie mają lagów...


(Sir Dzik~) #3

Kilku kumplu akurat nie ma ;/ A ja mam już od miesiąca... Nawet z samego rana mam lagi/freezy, ale wieczorem to już chodzić się nie da ;/

Złączono Posta : 08.10.2006 (Nie) 10:34

Czy to możliwe, że te lagi są spowodowane przez to, że jeden z DNSów nie odpowiada? gdy pinguje dnsy to w pierwszym mam ping 3-15, a w drugim "Upłynął limit czasu żądania". I co z tym zrobić?


(De Niro) #4

zeby zmiejszyć ping należy wyłączyć, antywirusa, firwall, komunikatory oraz programem które łączą się z siecią LAN.

zrób tak, start-> uruchom-> cmd /C ping -n 10 wp.pl >C:\ping.txt&&netstat -an >C:\netstat.txt

i podaj dwa pliki netstat i ping na forum :wink:


(Sir Dzik~) #5

Proszę bardzo:

ping.txt

Badanie wp.pl [212.77.100.101] z uľyciem 32 bajt˘w danych:




Odpowied« z 212.77.100.101: bajt˘w=32 czas=18ms TTL=120


Odpowied« z 212.77.100.101: bajt˘w=32 czas=19ms TTL=120


Odpowied« z 212.77.100.101: bajt˘w=32 czas=18ms TTL=120


Odpowied« z 212.77.100.101: bajt˘w=32 czas=22ms TTL=120


Odpowied« z 212.77.100.101: bajt˘w=32 czas=24ms TTL=120


Odpowied« z 212.77.100.101: bajt˘w=32 czas=18ms TTL=120


Odpowied« z 212.77.100.101: bajt˘w=32 czas=21ms TTL=120


Odpowied« z 212.77.100.101: bajt˘w=32 czas=23ms TTL=120


Odpowied« z 212.77.100.101: bajt˘w=32 czas=18ms TTL=120


Odpowied« z 212.77.100.101: bajt˘w=32 czas=19ms TTL=120




Statystyka badania ping dla 212.77.100.101:


    Pakiety: Wysane = 10, Odebrane = 10, Utracone = 0 (0% straty),


Szacunkowy czas bĄdzenia pakiet˘w w millisekundach:


    Minimum = 18 ms, Maksimum = 24 ms, Czas redni = 20 ms

netstat.txt

Aktywne poĄczenia


  Protok˘ Adres lokalny Obcy adres Stan

  TCP 0.0.0.0:135 0.0.0.0:0 NASťUCHIWANIE

  TCP 0.0.0.0:445 0.0.0.0:0 NASťUCHIWANIE

  TCP 0.0.0.0:1025 0.0.0.0:0 NASťUCHIWANIE

  TCP 0.0.0.0:1550 0.0.0.0:0 NASťUCHIWANIE

  TCP 127.0.0.1:1029 0.0.0.0:0 NASťUCHIWANIE

  TCP 127.0.0.1:1942 127.0.0.1:1943 USTANOWIONO

  TCP 127.0.0.1:1943 127.0.0.1:1942 USTANOWIONO

  TCP 127.0.0.1:12025 0.0.0.0:0 NASťUCHIWANIE

  TCP 127.0.0.1:12080 0.0.0.0:0 NASťUCHIWANIE

  TCP 127.0.0.1:12110 0.0.0.0:0 NASťUCHIWANIE

  TCP 127.0.0.1:12119 0.0.0.0:0 NASťUCHIWANIE

  TCP 127.0.0.1:12143 0.0.0.0:0 NASťUCHIWANIE

  TCP 192.168.46.3:139 0.0.0.0:0 NASťUCHIWANIE

  TCP 192.168.46.3:1930 217.17.45.143:8074 USTANOWIONO

  UDP 0.0.0.0:445 *:*                    

  UDP 0.0.0.0:500 *:*                    

  UDP 0.0.0.0:1035 *:*                    

  UDP 0.0.0.0:1092 *:*                    

  UDP 0.0.0.0:1201 *:*                    

  UDP 0.0.0.0:1394 *:*                    

  UDP 0.0.0.0:3776 *:*                    

  UDP 0.0.0.0:4500 *:*                    

  UDP 127.0.0.1:123 *:*                    

  UDP 127.0.0.1:1900 *:*                    

  UDP 127.0.0.1:1929 *:*                    

  UDP 127.0.0.1:1931 *:*                    

  UDP 127.0.0.1:1933 *:*                    

  UDP 127.0.0.1:1934 *:*                    

  UDP 127.0.0.1:1936 *:*                    

  UDP 127.0.0.1:1937 *:*                    

  UDP 127.0.0.1:1938 *:*                    

  UDP 127.0.0.1:1939 *:*                    

  UDP 192.168.46.3:123 *:*                    

  UDP 192.168.46.3:137 *:*                    

  UDP 192.168.46.3:138 *:*                    

  UDP 192.168.46.3:1900 *:*

(De Niro) #6

czas średni nie jest zły :!:

Zamknij porty TCP 135 , TCP 445 programem Windows Worms Doors Cleaner

Kolejną sprawą sprawdzenie MTU , start-> uruchom

gdzie następnie treść pliku MTU podaj na forum :wink:


(Sir Dzik~) #7

Plik Mtu.txt

Badanie wp.pl [212.77.100.101] z uľyciem 1492 bajt˘w danych:




Pakiet musi by† podzielony na fragmenty, ale ustawiono opcj© DF.


Pakiet musi by† podzielony na fragmenty, ale ustawiono opcj© DF.


Pakiet musi by† podzielony na fragmenty, ale ustawiono opcj© DF.


Pakiet musi by† podzielony na fragmenty, ale ustawiono opcj© DF.




Statystyka badania ping dla 212.77.100.101:


    Pakiety: Wysane = 4, Odebrane = 0, Utracone = 4 (100% straty),

te 100% straty mi się nie podoba :stuck_out_tongue:


(De Niro) #8

to już Ci mowie co masz zrobić, musisz znaleź liczbe (pakiet) który bedzie podzielny, czyli jak masz obecnie pakiet 1492 to go zmniejszaj o tyle aby był podzielny, w moim przypadku jest 1368

start-> uruchom-> CMD ping /f /l 1368 wp.pl

gdzie 1369 jest niepodzielny

start-> uruchom-> CMD

ping /f /l 1369 wp.pl


(Sir Dzik~) #9

No to znalazłem taki pakiet, w moim przypadku to 1472.

No i log z MTU nowy:

Badanie wp.pl [212.77.100.101] z uľyciem 1472 bajt˘w danych:




Odpowied« z 212.77.100.101: bajt˘w=1472 czas=35ms TTL=120


Odpowied« z 212.77.100.101: bajt˘w=1472 czas=32ms TTL=120


Odpowied« z 212.77.100.101: bajt˘w=1472 czas=33ms TTL=120


Odpowied« z 212.77.100.101: bajt˘w=1472 czas=34ms TTL=120




Statystyka badania ping dla 212.77.100.101:


    Pakiety: Wysane = 4, Odebrane = 4, Utracone = 0 (0% straty),


Szacunkowy czas bĄdzenia pakiet˘w w millisekundach:


    Minimum = 32 ms, Maksimum = 35 ms, Czas redni = 33 ms

I co teraz? :slight_smile:

Złączono Posta : 08.10.2006 (Nie) 16:51

Moze dodam, że ta gra korzysta z portu 7171

Złączono Posta : 08.10.2006 (Nie) 21:37

No i serwer gry znajduje się w Niemczech :stuck_out_tongue_winking_eye: może to coś ma do rzeczy :wink:


(De Niro) #10

następnie należy ustawić MTU w rejestrze, start-> uruchom-> regedit

utwórz nową wartość DWORD MTU a wartość w Twoim przypadku ma być 1444 (zapis dziesiety) a to dlatego ze od wartości w której pakiet jest podzielny należy odjąć 28. Restart kompa

I teraz spróbuj pingować jakiś adres aby sprawdzić czy przynisło rezultat.

Jeżeli chcesz odblokować dany port w Firwallu systemowy nalezy wbić w uruchom


(Sir Dzik~) #11

Dobrze to zrobiłem? :stuck_out_tongue:

a096f46346c60bef.jpg

Jeżeli tak to jutro powiem czy zadziałało :stuck_out_tongue_winking_eye: Bo musze już iść spać :stuck_out_tongue:

Złączono Posta : 24.10.2006 (Wto) 18:54

Eh.... i problem nadal się powtarza. Juz całkiem niewiem od czego... format tu coś pomoże? ;/

Złączono Posta : 24.10.2006 (Wto) 18:55

Chociaż że wolałbym uniknać formatowania :frowning:


(De Niro) #12

jeżeli system masz czysty od syfu, to format nic nie pomoże, użyj DNS'a wyłącz firwall, antywirusa oraz inne programy działające w tle, a kóre mają połączenie z siecią Web np. komunikatory :wink:


(Sir Dzik~) #13

A czy to możliwe by było to spowodowane z winy providera? i jak to sprawdzić ? Może macie jakieś serwery z różnych krajó, któe mógłbym spingować by sprawdzić czy lagi są tlyko na zagranicznych serwerach, bo gdy pinguje onet to mam bardz dobre pingi... a gra w ktorej mam lagi jest na niemieckim serverze.