Problem z localami


(Daris91) #1

Mój kolejny problem polega na tym że większość instalowanych programów jest po angielsku - nawet doinstalowywane gnome. (wyjątkiem chyba było kadu i firefox)

W konsoli przy instalacji jakiś programów mam:

locale: Nie można ustawić LC_ALL na domyślną lokalizację: Nie ma takiego pliku ani katalogu

Zainstalowałem language-pack-gnome-pl i language-pack-gnome-pl-base i wraz jest po angielsku. Wynik polecenia locale

darek@darek-desktop:~$ locale

locale: Nie można ustawić LC_ALL na domyślną lokalizację: Nie ma takiego pliku ani katalogu

LANG=pl_PL.UTF-8

LANGUAGE=pl_PL:pl

LC_CTYPE="pl_PL"

LC_NUMERIC="pl_PL"

LC_TIME="pl_PL"

LC_COLLATE="pl_PL"

LC_MONETARY="pl_PL"

LC_MESSAGES="pl_PL"

LC_PAPER="pl_PL"

LC_NAME="pl_PL"

LC_ADDRESS="pl_PL"

LC_TELEPHONE="pl_PL"

LC_MEASUREMENT="pl_PL"

LC_IDENTIFICATION="pl_PL"

LC_ALL=pl_PL

Jak miałem ustawione inne kodowanie to nie było ó (zamiast ó miałem dwa prostokąciki)


(Bionicman) #2

Przekonfiguruj locale:

dpkg-reconfigure locales albo dpkg-reconfigure localeconf.


(Daris91) #3
darek@darek-desktop:~$ sudo dpkg-reconfigure locales

Password:

perl: warning: Setting locale failed.

perl: warning: Please check that your locale settings:

        LANGUAGE = "pl_PL:pl:en_GB:en",

        LC_ALL = "pl_PL",

        LANG = "pl_PL.UTF-8"

    are supported and installed on your system.

perl: warning: Falling back to the standard locale ("C").

locale: Nie można ustawić LC_ALL na domyślną lokalizację: Nie ma takiego pliku ani katalogu

Generating locales...

  en_US.UTF-8... up-to-date

  pl_PL.ISO-8859-2... up-to-date

  pl_PL.UTF-8... up-to-date

Generation complete.

Current default timezone: 'Europe/Warsaw'.

Local time is now: Sat Mar 17 14:09:34 CET 2007.

Universal Time is now: Sat Mar 17 13:09:34 UTC 2007.

Run 'tzconfig' if you wish to change it.

darek@darek-desktop:~$ sudo dpkg-reconfigure localeconf

perl: warning: Setting locale failed.

perl: warning: Please check that your locale settings:

        LANGUAGE = "pl_PL:pl:en_GB:en",

        LC_ALL = "pl_PL",

        LANG = "pl_PL.UTF-8"

    are supported and installed on your system.

perl: warning: Falling back to the standard locale ("C").

locale: Nie można ustawić LC_ALL na domyślną lokalizację: Nie ma takiego pliku ani katalogu

/usr/bin/locale: Nie można ustawić LC_ALL na domyślną lokalizację: Nie ma takiego pliku ani katalogu

Generating locales...

  en_US.UTF-8... up-to-date

  pl_PL.ISO-8859-2... up-to-date

  pl_PL.UTF-8... up-to-date

Generation complete.

Złączono Posta : 17.03.2007 (Sob) 14:16Nawet uruchamiane aplikacje mają błędy dot locali:

darek@darek-desktop:~$ nautilus


(nautilus:11343): Gtk-WARNING **: Locale not supported by C library.

        Using the fallback 'C' locale.


(nautilus:11343): Gdk-WARNING **: locale not supported by C library

(Bionicman) #4
Nie ma takiego pliku ani katalogu

Hmm... Wygląda na to, że brakowało pliku konfiguracyjnego.

Generating locales...

Generation complete.

Chyba się wygenerował teraz. Polskie locale powinny być iso8859-2, a nie jak widzę ,w niektórych miejscach UTF-8. Spróbuj jeszcze raz dpkg-reconfigure locales. Sprawdź też co masz w pliku ~/.Xdefaults

*font: misc-fixed-medium-r-normal--*-*-*-*-c-*-iso8859-2

(Daris91) #5

Jak miałem ustawione kodowanie na iso to w większości programów z kde zamiast ó miałem dwa prostokąty i później dopóki kursor nie przeszedł do następnej linii to uciekał jakieś parę pikseli do przodu i trudno było wtedy pisać - już nie wspomnę o poprawianiu czegoś co miało w linijce ó. Działo się to w konquerorze, kadu itp. W Firefoxie wszystko było dobrze.

Jest jeden problem - nie ma ani takiego pliku ani folderu