Problem z Microsoft update w WINDOWS VISTA!


(Patryk Bigos102) #1

Witam! Mam taki problem, a mianowicie w Windows Vista chce zmienić windows update na Microsoft update, a nie mogę ponieważ kiedy kliknę żeby pokazał licencje to pisze że sprawdza ActiveX i mi potem taki komunikat występuje:

Byłem już na tych stronach:

http://support.microsoft.com/kb/310794/pl

http://support.microsoft.com/kb/922582/pl

http://support.microsoft.com/kb/935807/pl

Ale tu są powody dla których to mi nie działa:

1) Nie mam komputera dell.

2) Nie uległ zmianie domyślny dostawca zabezpieczeń.

3) Nie uległa zmianie litera dysku systemowego.

4)

nie mam podfolderu Providers.

5)

nie mam podfolderu Cryptography.

6) Nie ma u mnie minifiltrów.

7)

w tym artykule nie ma nic ciekawego.

8.) NAJWAŻNIEJSZE MAM WINDOWS VISTA A NIE XP! !!

Proszę o szybką odpowiedź i z góry dziękuję.

Jakbym czegoś nie podał to proszę pisać.


(Piotr P.) #2

Są, trzeba troche poszukać:

http://support.microsoft.com/gp/wusupport

http://support.microsoft.com/ph/6527

http://windowshelp.microsoft.com/window ... f1045.mspx

lub wykonaj jak niżej:

Wklej do notatnika ponizsza zawartośc:

net stop wuauserv

net stop cryptsvc

ren %systemroot%\System32\Catroot2 oldcatroot2

ren %SYSTEMROOT%\SoftwareDistribution SoftwareDistribution.old

regsvr32 comcat.dll /s

regsvr32 shdoc401.dll /s

regsvr32 shdoc401.dll /i /s

regsvr32 asctrls.ocx /s

regsvr32 oleaut32.dll /s

regsvr32 shdocvw.dll /I /s

regsvr32 shdocvw.dll /s

regsvr32 browseui.dll /s

regsvr32 browseui.dll /I /s

regsvr32 msrating.dll /s

regsvr32 mlang.dll /s

regsvr32 hlink.dll /s

regsvr32 mshtmled.dll /s

regsvr32 urlmon.dll /s

regsvr32 plugin.ocx /s

regsvr32 sendmail.dll /s

regsvr32 scrobj.dll /s

regsvr32 mmefxe.ocx /s

regsvr32 corpol.dll /s

regsvr32 jscript.dll /s

regsvr32 msxml.dll /s

regsvr32 imgutil.dll /s

regsvr32 thumbvw.dll /s

regsvr32 cryptext.dll /s

regsvr32 rsabase.dll /s

regsvr32 inseng.dll /s

regsvr32 iesetup.dll /i /s

regsvr32 cryptdlg.dll /s

regsvr32 actxprxy.dll /s

regsvr32 dispex.dll /s

regsvr32 occache.dll /s

regsvr32 occache.dll /i /s

regsvr32 iepeers.dll /s

regsvr32 urlmon.dll /i /s

regsvr32 cdfview.dll /s

regsvr32 webcheck.dll /s

regsvr32 mobsync.dll /s

regsvr32 pngfilt.dll /s

regsvr32 licmgr10.dll /s

regsvr32 icmfilter.dll /s

regsvr32 hhctrl.ocx /s

regsvr32 inetcfg.dll /s

regsvr32 tdc.ocx /s

regsvr32 MSR2C.DLL /s

regsvr32 msident.dll /s

regsvr32 msieftp.dll /s

regsvr32 xmsconf.ocx /s

regsvr32 ils.dll /s

regsvr32 msoeacct.dll /s

regsvr32 inetcomm.dll /s

regsvr32 msdxm.ocx /s

regsvr32 dxmasf.dll /s

regsvr32 l3codecx.ax /s

regsvr32 acelpdec.ax /s

regsvr32 mpg4ds32.ax /s

regsvr32 voxmsdec.ax /s

regsvr32 danim.dll /s

regsvr32 Daxctle.ocx /s

regsvr32 lmrt.dll /s

regsvr32 datime.dll /s

regsvr32 dxtrans.dll /s

regsvr32 dxtmsft.dll /s

regsvr32 WEBPOST.DLL /s

regsvr32 WPWIZDLL.DLL /s

regsvr32 POSTWPP.DLL /s

regsvr32 CRSWPP.DLL /s

regsvr32 FTPWPP.DLL /s

regsvr32 FPWPP.DLL /s

regsvr32 WUAPI.DLL /s

regsvr32 WUAUENG.DLL /s

regsvr32 ATL.DLL /s

regsvr32 WUCLTUI.DLL /s

regsvr32 WUPS.DLL /s

regsvr32 WUWEB.DLL /s

regsvr32 wshom.ocx /s

regsvr32 wshext.dll /s

regsvr32 vbscript.dll /s

regsvr32 scrrun.dll mstinit.exe /setup /s

regsvr32 msnsspc.dll /SspcCreateSspiReg /s

regsvr32 msapsspc.dll /SspcCreateSspiReg /s

regsvr32 wucltui.dll /s

regsvr32 wuweb.dll /s

regsvr32 msxml.dll /s

regsvr32 msxml2.dll /s

regsvr32 msxml3.dll /s

regsvr32 urlmon.dll /s

regsvr32 jscript.dll /s

regsvr32 oleaut32.dll /s

regsvr32 wuapi.dll /s

regsvr32 wups.dll /s

regsvr32 wups2.dll /s

regsvr32 wuaueng.dll /s

regsvr32 wuaueng1.dll /s

net start cryptsvc

net start wuauserv

Po zapisaniu do pliku *.bat odpal go jako administrator


(Patryk Bigos102) #3

Niestety, to nie pomogło, tylko mi wykasowało listę aktualizacji a propo co do twoich linków pierwsze 2 są takie same (i są tam tysiące kodów a patrzyłem tam) a na tym trzecim linku byłem już wcześniej, też tak zrobiłem i nadal nic :frowning: . :frowning: :frowning: :frowning: . No nic spróbuje wejść w tryb awaryjny.

EDIT

Byłem w trybie awaryjnym i tam też nie było tego folderu Provides :frowning: :frowning: :frowning: :frowning: :frowning: :frowning: :frowning: :frowning: :frowning: :frowning: ja już nie wiem, format nie wchpdzi w gre bo to się zrobiło po formacie...

Co jeszcze doradzacie?