Problem z najnowszą wersją Vertrigo Serv - problem z serwerem Apache


(hatezit) #1

Hej,

Do tej pory Vertrigo działał dobrze, ale dziś postanowiłem zainstalować nowszą wersję, ponieważ nie które funkcje w php nie są obsługiwane w wersji php 5.3 a taką miałem. Zainstalowałem nową wersję uruchomiłem i pojawia się błąd serwera apache, że port 80 jest zajęty:

W takim razie co zrobiłem:

Zmieniłem na inny port np: 8080,

W skype odznaczyłem używania portów 80 i 443,

Zapisałem i nic!

Wyłączyłem firewalla, aby sprawdzić, czy przypadkiem nie blokuje i uruchomiłem vertrigo, nadal jest błąd o używaniu portu 80.

Sprawdziłem w usługach czy mam IIS, ale nie miałem takich usług, jedynie był uruchomiony serwer, wyłączyłem.  Uruchomiłem ponownie vertrigo i to samo jest. Na wszelki wypadek zrestartowałem kompa. Nie pomogło.

Nie chcę instalować na XP proff xampp, bo już kiedyś miałem i wolno na tym systemie mi działał, mam na win 7 i starczy. Obawiam się, że nawet gdy wamp zainstaluje, to może być tak samo.

Problem rozwiązany!

Sprawdziłem na wirtualnej maszynie, czy będzie taki sam objaw i niestety tak było. wskazuje na to, że plik apache.exe wymaga bibliotek, aby były zgodne z Win32. Wyszukałem starszą wersję Vertrigo 233 i zainstalowałem. Wszystko działa jak i te funkcje php, które w wersji jaką miałem, nie były obsługiwane.

 


(john_szchr) #2

Rzeczywiście, gdy po raz pierwszy zainstalowałem Vertrigo 2.44, to nie pojawiał się ekran powitalny, a komunikat o braku prawa dostępu do katalogu www. Jednak ku mojemu zdziwieniu odinstalowanie, oczyszczeniu rejestru i resztek z programu pomogło. Ponowne zainstalowanie zaskutkowało poprawnym działaniem.