Problem z OpenOffice Calc - procenty


(Robert Warszawa) #1

Nie znam sięzbytnio na Ecelu, ani na Calcu, ale pilnie muszę coś zrobić.

Pod adresem: http://images2.fotosik.pl/293/c6a971d7fabc9ab6med.jpg

zamieszczam obrazek, który przedstawia wynik, który miał wyjść w procentach, a wyszły tylko kratki #! Za każdym razem, gdy chcę wyliczyć procent to pojawiają mi się te kratki...! Nie wiem, nie znam się za bardzo na Excelu no i na Calcu.

Tak więc pomóżcie... Dodam, iż w szkole miałem podobny problem na Excelu

Mało mam do czynienia z tymi aplikacjami!


(goomish) #2

Te "krzyżyki" oznaczają, że wartość tej komórki nie zmieściła się w całości - nie może być cała wyświetlona. Kliknij podwójnie linię podziału między kolumnami C i D (na przykładzie powyższego obrazka). Albo przeciągnij wskaźnikiem myszy ten podział w prawo.


(Heniu133) #3

Niekoniecznie, jeżeli jest źle wpisana formuła tez to wyskoczy.

W komórkę C1 wpisz:

=(B1*100)/$B$4


(goomish) #4

Hm... U mnie (pusty arkusz i tylko ta formuła w C1) wyskoczył "zwykły" błąd #DZIEL/0! :slight_smile:

Natomiast Pomoc Excela 2007 twierdzi, że to błąd występujący gdy kolumna jest zbyt wąska albo daty i godziny są liczbami ujemnymi -> link. Zresztą - jak widać na zrzucie nie jest to błąd typu #N/D!, #ARG! itd, itp.


(Heniu133) #5

Tam są tylko 3 kratki (#),a szerokość kolumny C jest większa, jeżeli liczba składała się z większej liczby cyfr to by było więcej kratek.

@robert_warszawa najedź na komórke C1 i napisz co tam masz.


(Duncaen) #6

Jesli masz pusty arkusz to i komórka B4 do której odwołuje sie działanie:

=(B1*100)/$B$4

jest pusta, więc traktuję ją jak 0 (zero), a skoro ma przez nią podzielić to pokazuję błąd dzielenia przez 0 Złączono Posta : 14.12.2006 (Czw) 22:59 robert_warszawa koniecznie poszerz zdecydowanie kolumne C i wtedy zobaczysz. Zapewne wtedy pokaże ci sie prawdziwy bład który teraz nie mieści się w tej kolumnie, np błąd:

#WARTOŚĆ!

Te krzyżyki # oznaczają że to co ma być wyświetlone w komórce nie mieści się w niej, może to być liczba - jeśli tak to poprostu po rozszerzeniu bedziesz już miał wynik (jeśli wszystko jest wpisane poprawnie) lub może to byc komunikat błędu i po rozsunięciu dowiesz się co to za błąd.

Ale najlepiej podaj co masz wpisane (jakie działanie) w komórce C1


(Robert Warszawa) #7

goomish miał rację, dzięki...

A odstopie trochę od tematu... ale dlaczego makra w OO nie działają...poprawnie?


(goomish) #8

Jeżeli makra utworzone w OO nie działają poprawnie - to albo nie dopatrzyłeś czegoś w opcjach, albo napisałeś czy też wyklikałeś błędne makro :slight_smile:

jeżeli zaś w OO nie działają (poprawnie) makra utworzone w MS Office - no cóż, mimo, że z wersji na wersję jest coraz lepiej OO nie jest jeszcze w stu procentach zgodny z MSO, niestety. Część makr będziesz musiał poprawić albo nawet napisać od nowa.

To samo zresztą obowiązuje w drugą stronę OO -> MSO.