Problem z Oprogramowanie do bluetooth


(Grzeg44) #1

Witam

Mam problem z oprogramowaniem BlueSoleil, przed wczoraj wszystko działało a dziś podpinam bluetooth, włączam ten program

BlueSoleil i wyskakuje błąd .Od instalowałem i zainstalowałem z powrotem, to samo . Ktoś ma pomysły o co chodzi .

Pozdrawiam.

Fotka

capture1hd.th.jpg


(Tomj) #2

witaj- mi zawsze ten program się nie podobał i sprawiał problemy, więc lepiej wybierz inny i się z tym nie męcz, polecam Windcom prosty i dobry programik :smiley:


(Grzeg44) #3

JA od roku używałem i wszystko było w porządku aż do dziś, gdy podpięłam Bluetooth. Spróbuję jeszcze ze starszą wersją Bluesoleil (2,3), jak to nic nie da zainstaluję to co polecasz, tylko czy będzie współpracować ?


(scripter1) #4

Mi jakoś BlueSoleil nigdy problemów nie stwarzał.

Przyczyny szukaj gdzie indziej.

Zgodnie z komunikatem biblioteka kernel32.dll nie może zostać załadowana więc najpierw sprawdź czy masz ją w ogóle na dysku, jak się nie mylę to jest to plik systemowy i powinien chyba być w c:\windows\system32 (ale głowy nie daję, lepiej użyj wyszukiwania plików).

Jeśli plik jest na dysku to może jakiś antywirus lub firewall blokuje program BlueSoleil i nie daje mu dostępu do tego pliku.

Jeszcze podobne problemy mogą powodować wirusy.


(Grzeg44) #5

Zainstalowałem starszą wersję i jest w porządku , co do tego kernel32.dll to nie mam go na dysku, wcześniej był.


(scripter1) #6

No to już masz przyczynę, bez tego pliku również inne programy mogą nie działać jak trzeba.

Jak już wspomniałem brak tego pliku może być wynikiem działania wirusa, zalecałbym przeskanowanie systemu dobrym antyvirem i OTL (instrukcję znajdziesz w dziale Bezpieczeństwo).


(Xpanel) #7

download kernel32.dll(windows/system32):

http://www.dll-download-system.com

HTH.


(helios26) #8

Witam.

To ja się podłączę do tematu.

Kupiłem niedawno nowego laptopa bez wbudowanego BT więc dokupiłem do niego moduł BT właśnie z oprogramowaniem Bluesoleil. To oprogramowanie nie dało się w ogóle wgrać system Win7 64bit pokazywał błąd bodajże 113. Śćiągnąłem inną wersję ta z kolei zainstalowała się lecz moduł nie wykrywa mojego starego laptopa, który ma wbudowany BT ani mojego telefonu. I odwrotnie też ani telefon ani stary laptop nie wykrywają tego nowego.

U mnie te plik kerenel32 jest. Nie mam pojęcia jak to rozsupłać?

Dzięki za jakieś sugestie.


(scripter1) #9

helios26 , upewnij się w urządzeniach które próbujesz wyszukać masz włączoną widoczność w ustawieniach bluetooth (może to być różnie nazwane np. w BlueSoleil ta opcja nazywa się "Pozwól innym urządzeniom na znalezienie tego urządzenia").


(helios26) #10

Witam.

Tak oczywiście mam tak poustawiane zarówno w telefonie, w starym laptopie (też Asus) jaki w nowym w bluesoleil też tak ustawiłem.

Podejrzewałem również że może jest uszkodzony sam moduł usb BT u znajomego po zainstalowaniu Bluesoleil jego telefon Nokia jakiś starszy model jest wykryty i łączność jest nawiązana, jednak mojego telefonu Nokia N95 8GB nie wykrywa.

Dziwne to na starym laptopie z wbudowanym BT takich problemów nie było wykrywane było każde urządzenie. A oprogramowaniem tam było Toshiba Stock BT.


(scripter1) #11

Może zainstalowałeś starszą wersję BlueSoleil która nie działa poprawnie z tym układem bluetooth który masz.


(helios26) #12

Ten moduł BT to produkt 4World i do niego była dołączona płytka z oprogramowaniem Bluesoleil którego nie dało się zainstalować a system pokazuje błąd 113. O czym pisałem wyżej. Ściągnąłem inną wersję ta dała się zainstalować lecz nie wykrywa żadnych urządzeń.

Mój nowy laptop to Asus N61Jv zainstalowałem na nim Win7 Ultimate 64bit.


(scripter1) #13

helios26 , te informacje nic nam nie dają bo jak ci już napisałem pewnie problem tkwi w tym jaką wersję zainstalowałeś.

Bo jak dostałeś przykładowo wersję 5.0 której nie mogłeś z jakiegoś powodu zainstalować a zainstalowałeś przykładowo wersje 2.6 to jest wysoce prawdopodobne że ta starsza wersja nie obsługiwała jeszcze tego układu (istotne jest na jakim układzie jest dany moduł bluetooth a nie jakiej jest on firmy).


(helios26) #14

Oj nie wiem czy takie dane wystarczą z opisu na opakowaniu:

Protokół bluetooth v2,1 + EDR szybkość transmisji do 3Mbit/sek, plug&play, Windows2000/XP/Vista/7

a załączona płytka to bluesoleil 2.6.249 i ona się nie instaluje a dokładnie nie pamiętam jaką wersję instalowałem z internetu

ale też było coś 2.6. a dalej nie wiem.

To tyle informacji jakie posiadam.


(scripter1) #15

O, i tu chyba jest pies pogrzebany bo jak mnie pamięć nie myli to wersje do 2.6 włącznie były licencjonowane na każdy pojedynczy układ (chip) montowany w adapterze i licencjonowanie odbywało się właśnie poprzez oryginalny nośnik z programem dla danej sztuki.

Upewnij się że ta wersja którą zainstalowałeś nie jest niższa od tej którą dostałeś.

Poszukaj sposobu aby jakoś zainstalować program z płyty, poszukaj w necie informacji na temat tego błędu który ci wywala.

Oczywiście zakładam że kupiłeś od uczciwego sprzedawcy bo teraz jest na rynku dużo szjsowatych adapterów które nie mają swoich indywidualnych legalnych adresów MAC i często dołączają do nich Bluesoleil ale w wersji trial, często zdarza się że nawet ta wersja Bluesoleil którą dają nie działa z tym adapterem do którego ją dają.


(helios26) #16

Witam.

Oczywiście kupowałem laptopa wraz z tym adapterem BT i myszką w dość renomowanym sklepie X-KOM.PL wprawdzie nie daleko ode mnie (ok 30km.) ale kupowałem przez internet przed świętami 15 grudnia odebrałem przesyłkę. I dopiero nie dawno wziąłem się za sprawdzanie Bluetootha. Zacząłem szukać w google jak wystąpiły z tym problemy i znalazłem się również na tym forum.

Co do tego błędu 183 też szukałem i tyle co znalazłem to wgrać nowsze Bluesoleil wgrało się jednak nic nie działa. A wersja jest wyższa. Znaczy była bo odinstalowałem.

Ale dziwi mnie i to pomijając już oprogramowanie że z poziomu systemu również nic się nie dzieje. System zainstalował sterowniki adapter widziany jest w menadżerze urządzeń bez żadnych żółtych trójkącików, podobnie jest w panelu sterowania w sekcji urządzenia i drukarki, a brak ikonki w zasobniku po kliknięciu pokaż ukryte ikony.


(scripter1) #17

A może to właśnie w tym problem że masz sterowniki systemowe, mogą się one kłócić z tymi które próbujesz zainstalować a na systemowych bluesoleil może nie działać.

Odinstaluj sterowniki bluetooth przez menedżera urządzeń i spróbuj zainstalować oprogramowanie dołączone do adaptera przy odłączonym adapterze.

Jeszcze tak sobie pomyślałem że może masz jakiegoś antywirusa lub firewalla i on blokuje bluesoleil.


(helios26) #18

Kurcze już mam zawrót głowy.

Gdy odłączę adapter to z menadżera urządzeń znika to wszystko. To bluesoleil ściągnąłem jeszcze raz i jest to wersja 6.4.314 zainstalowałem i głucho nic nie wykrywa. Ani starego laptopa ani telefonu odwrotnie też nic.

Mam avasta ale ten nic nie krzyczy że blokuje tak samo systemowa zapora też nic nie powiadamia a tak mam ustawione na powiadomienia.

Próbowałem również z Widcomm 5.0.1.802 też nic. zainstaluje się ale nie działa poustawiałem na wykrywaj wszystkie urządzenia i nic. Oj właśnie ale przy instalacji tego programiku system krzyczy że brak podpisu i coś tam jeszcze jednak gdy wciskałem anuluj to on i tak się zainstalował.

Też jeszcze mam chyba nowszy Widcomm ale to jest plik exe a tu z kolei gdy zaczyna się instalacja to jest tak w kilku etapach chyba bo przy pierwszym kroku na dole pokazuje się komunikat "Please plug in tom on your Bluetooth device"

i na tym staje kręci się kółeczko koniec możliwości dalszych postępów.

Nie wiem jak tu wstawić zrzut ekranu.

W każdym razie d.... blada. A te zabiegi robiłem kilka chwil temu.


(scripter1) #19

Po pierwsze to w menedżerze urządzeń musisz dać odinstaluj a nie wyłącz.

Po odinstalowaniu sterowników spróbuj jeszcze raz zainstalować ten co dostałeś (z płyty) a nie ten ściągnięty.

Jak przy instalacji system ci krzyczy że nie ma podpisu to zapewne chodzi o sterownik i jak mu dasz anuluj to nie zainstaluje go i nie będzie ci działało, musisz dać "instaluj mimo to" (lub coś w tym stylu).

A jak masz info typu "proszę podłączyć" ("Please plug in tom on your Bluetooth device") to w tym momencie należy podłączyć adapter aby poszło dalej, ale nie wcześniej (chyba że wywali coś w rodzaju "nie znaleziono zgodnych urządzeń").


(helios26) #20

Witam ponownie.

Trochę odpuściłem tego BT bo w żaden sposób nie mogę tego przeskoczyć.Postanowiłem jednak dalej coś robić.

Znalazłem również w sieci sterownik z oprogramowaniem Toshiby do BT sytuacja taka sama, a mianowicie sterownik i oprogramowanie bez problemów się zainstalowało oczywiście w trakcie instalacji instalator zawołał o podłączenie adaptera(urządzenia) system dodatkowo zainstalował stery do adaptera i dalej poszła instalacja Toshiby BT Stack.

I teraz niby adapter jest widziany w oprogramowaniu jednak jak poprzednio nie wykrywa żadnych urządzeń tzn telefonu i starego lapka. Podaje tylko komunikat że nie odnaleziono urządzeń. I to też wydaje mi się dziwne bo nie widzę ikonki adaptera, natomiast ikonka BT Toshiby jest i współpracuje z systemem.

W końcu wydaje mi się że ten mój moduł usb BT nie chodzi pod Win7 64bit. A jeszcze dziwniejsze jest to że na starym lapku mam XP-ka też nic nie działa. A poszedłem do pobliskiego sklepiku z komputerami i facet ma u siebie Vistę 32 bit i u niego działa wykrywa jego telefon ale mojego już nie. Czyli adapter jest sprawny.

Ręce uszy i wargi opadają.