Problem z pingiem na laptopie po formacie


(Kijana 15) #1

Witam,

problemem jest skaczący ping na lapku. Wszystko było ok póki miałem viste ale przyszedł czas na formata i przy okazji zmiana na siódemkę no i tadaaaaa! problemy z pingiem :slight_smile: co mnie zdziwiło nie jest to tylko problem gier a ogólnego uzytkowania neta (strony, filmy, muzyka no i oczywioscie gry). Wygląda to tak ze wszystko jest cacy pięknie i co kilka minut (regularnie) ping na kilka sekund skacze w kosmos.

Ustawienia routera są takie same jak i przed formatem.

Jeżeli ktoś wie lub może wiedzieć ocb to bardzo proszę o pomoc i odpisywanie w ludzkim języku :smiley:

aha i edit :stuck_out_tongue_winking_eye: w google grzebie juz drugi dzien niestety takich objawów i dolegliwości nie znalazłem :slight_smile: wszystko odnosiło sie do gier itd.

dzieki :))


(ADR1991) #2

Przyczyny problemu szukałbym w sterownikach. Pobaw się instalując starsze/nowsze wersje.


(bachus) #3

Pokaż z ciekawości wynik komend:

netsh interface ipv4 show subinterfaces

ping google.com -l 1500

ping google.com -l 1452

ping google.com -l 1400

Niektóre sterowniki/Windows7 z uporem maniaka ustawiają MTU na 1500


(Kijana 15) #4

bardzo chętnie ale jak juz wspomnialem :smiley: po polsku prosze :> tzn gdzie to wklepac xD jestem naprawde lewy jezeli chodzi o takie rzeczy :wink:


(ADR1991) #5

Proszę bardzo: www.forum.dobreprogramy.pl/kopiowanie-w ... 99881.html


(Kijana 15) #6

nie wiem czy to tak miało być czy też nie, ale mam takie coś xD

Microsoft Windows [Wersja 6.1.7601]

Copyright © 2009 Microsoft Corporation. Wszelkie prawa zastrzeżone.

C:\Users\Kijanczers>netsh interface ipv4 show subinterfaces

MTU MediaSenseState Bajty odbr Bajty wysł Interfejs


4294967295 1 0 9257335 Loopback Pseudo-Interface 1

1500 1 4422915458 453771187 Wireless Network Connection

1500 5 0 0 Local Area Connection

C:\Users\Kijanczers>ping google.com -l 1500

Badanie google.com [173.194.41.161] z 1500 bajtami danych:

Odpowiedź z 173.194.41.161: bajtów=1500 czas=37ms TTL=56

Odpowiedź z 173.194.41.161: bajtów=1500 czas=37ms TTL=56

Odpowiedź z 173.194.41.161: bajtów=1500 czas=36ms TTL=56

Odpowiedź z 173.194.41.161: bajtów=1500 czas=36ms TTL=56

Statystyka badania ping dla 173.194.41.161:

Pakiety: Wysłane = 4, Odebrane = 4, Utracone = 0

(0% straty),

Szacunkowy czas błądzenia pakietów w millisekundach:

Minimum = 36 ms, Maksimum = 37 ms, Czas średni = 36 ms

C:\Users\Kijanczers>ping google.com -l 1452

Badanie google.com [173.194.41.161] z 1452 bajtami danych:

Odpowiedź z 173.194.41.161: bajtów=1452 czas=35ms TTL=56

Odpowiedź z 173.194.41.161: bajtów=1452 czas=35ms TTL=56

Odpowiedź z 173.194.41.161: bajtów=1452 czas=35ms TTL=56

Odpowiedź z 173.194.41.161: bajtów=1452 czas=35ms TTL=56

Statystyka badania ping dla 173.194.41.161:

Pakiety: Wysłane = 4, Odebrane = 4, Utracone = 0

(0% straty),

Szacunkowy czas błądzenia pakietów w millisekundach:

Minimum = 35 ms, Maksimum = 35 ms, Czas średni = 35 ms

C:\Users\Kijanczers>ping google.com -l 1400


(bachus) #7

Mimo, że MTU na obu intefrejsach (wifi i LAN) to 1500, ping wygląda dobrze... Rozumiem, że korzystasz po Wifi?

Dla testu mimo wszystko bym troszkę zmniejszył MTU. Z linii komend (z uprawnieniami administratora) wydaj poniższą komednę i zobacz, czy coś to pomoże:

netsh interface ipv4 set subinterface "Wireless Network Connection" mtu=1458 store=persistent

Dla pewności, czy to nie wina np. sterownika Wifi, podepnij się testowo po kalbu, zmień też ustawienia dla karty sieciowej "kablowej":

netsh interface ipv4 set subinterface "Local Area Connection" mtu=1458 store=persistent

Możesz też wyłączyć zarządzanie energią dla karty Wifi. Sterowniki masz te od "Microsoft"? Próbowałeś ze strony producenta sprzętu?


(Kijana 15) #8

na razie zastosowałem tą pierwszą zmianę zobaczymy czy pomoże :slight_smile: chwila testów i niedługo się odezwę :wink:) a z ta drugą metodą bedzie wiekszy problem bo kabla brak a modem piętro niżej ;p

Edit :slight_smile: nie pomogło tak jakbym chciał, ale tak jakby te skoki zdarzały się rzadziej :stuck_out_tongue_winking_eye: takze dzieki :slight_smile: z kablem na razie nie bd kombinowal :smiley:


(bachus) #9

Jak skoki rzadziej, to jeszcze zmniejsz:

netsh interface ipv4 set subinterface "Wireless Network Connection" mtu=1400 store=persistent