Problem z podmontowaniem partycji ntfs w Ubuntu 19.10

Witam!
Mam problem z dostaniem się do partycji NTFS z poziomu Ubuntu 19.10. Na tej partycji mam różne dane i multimedia. Próbowałem dodać je do fstab, aby były montowane przy starcie systemu i teraz nie mogę się tam w ogóle dostać.
Plik fstab wygląda u mnie tak:

# /etc/fstab: static file system information.
#
# Use 'blkid' to print the universally unique identifier for a
# device; this may be used with UUID= as a more robust way to name devices
# that works even if disks are added and removed. See fstab(5).
#
# <file system> <mount point>   <type>  <options>       <dump>  <pass>
# / was on /dev/nvme0n1p5 during installation
UUID=ceb95188-a534-40d0-8524-7474547050ba /               ext4    errors=remount-ro 0       1
# /boot/efi was on /dev/nvme0n1p2 during installation
UUID=3458-1225  /boot/efi       vfat    umask=0077      0       1
/swapfile                                 none            swap    sw              0       0
/dev/sda2 /media/Dysk D ntfs-3g defaults,rw,auto,utf8 0 0
/dev/sda3 /media/Dysk G ntfs-3g defaults,rw,auto,utf8 0 0

Liczę na pomoc.

weź to napisz porządnie z użyciem
Tekst sformatowany
bo oczopląsu można dostać

1lajk

Stawiam, że chodzi o spacje w nazwach katalogów.

Ciekawy jestem, jak to ominąć. Programy czytające z fstab obsługują jakoś sekwencje ucieczki. Zawsze można utworzyć ukryty katalog, gdzie będą katalogi stanowiące punkt montowania, a do nich, w innym katalogu potworzyć dowiązania symboliczne, np.

/dev/sda2 /.do_podmontowania/Dysk_D ntfs-3g defaults,rw,auto,utf8 0 0
/dev/sda3 /.do_podmontowania/Dysk_G ntfs-3g defaults,rw,auto,utf8 0 0

I wykonać (spod root-a):

umount /media/Dysk\ D
umount /media/Dysk\ G
read a
#Tutaj przeczytaj komunikaty i przerwij, jeżeli konieczne (CTRL+C). Jeżeli wszystko ok, to możesz nacisnąć enter. To tak, gdyby coś poszło nie tak 
rm -r /media/Dysk\ D
rm -r /media/Dysk\ G
ln -s /.do_podmontowania/Dysk_D /media/Dysk\ D
ln -s /.do_podmontowania/Dysk_G /media/Dysk\ G

To jednak tylko rozwiązanie połowniczne.

Zmieniając nazwę katalogu?

1lajk

Spróbuj wstawić “\040” zamiast spacji, czyli
/dev/sda2 /media/Dysk\040D ntfs-3g defaults,rw,auto,utf8 0 0
/dev/sda3 /media/Dysk\040G ntfs-3g defaults,rw,auto,utf8 0 0

Pomogło mi to! Dzięki :slight_smile:
Teraz jednak pojawia mi się okienko:

jest to coś z aktualizacjami, bo błąd tyczy się “update-notifier”.

Załączam jeszcze to:

Bo Gnome to zuo, chyba Ty mi kiedyś tak napisałeś. W KDE nie ma takich problemów.
Dolphin podpina wszystko z automatu. a to biedne coś z gnome…jakaś paranoja. Chcą zrobić z linuxa maca?

nawet zapomniałem, że mam płytę w CD