Problem z połączeniem się ze swoim serwerem Minecraft


(StarterX4) #1

Mam problem ze stworzeniem swojego serwera minecraft bo nie mogę się z nim połączyć, za każdą próbą wyskakuje tylko to:

Reinstalacja Javy, reinstalacja sterowników z routera, reinstalacja systemu... nie pomagają :frowning: nie wiem już co robić, problem ten się pojawił zaraz po przesiadce z linuksa na windowsa, przed linuksem na windowsie nie było problemów..

do łączenia się na serwer próbowałem już programów Hamachi, NO-IP.org, a nawet zwykłego IP mojego routera.. za każdym razem tylko ten błąd, udałó mi się połączyć na serwer, ale tylko przez localhost , serwer to bukkit, to samo jest z pluginami jak i bez, na początku myślałem że to wina hamachi, ale okazuje się że nie, na Google już szukałem o tym i pisali tylko by zreinstalować jawę, u mnie to nie pomaga :frowning: inni także nie mogą wejść na mój serwer.

Przekierowywanie portów na hamachi nie pomaga, też tak samo.

system to Windows 8 PRO, na Windows 7, Windows XP też tak jest..

Router to ZTE ZXDSL-831VII, internet mam z TP.

Pomocy! !!


(Jimasek) #2

Firewall systemowy (zapora) nie blokuje przypadkiem ruchu z i na serwer?


(StarterX4) #3

Zapora na pewno nie bo już próbowałem i też ten błąd wyskakuje :frowning:


(Piesek64) #4

Wyłącz firewalla. Daj log serwera. Nikt nie wejdzie na serwer jeśli jest na twoim lokalnym IP.


(StarterX4) #5

Tu są logi: http://pastebin.com/T7cmpYK6 i wyłączenie zapory nie pomaga.


(Piesek64) #6

Zauważyłem błąd polskich znaków (pluginu). Plugin jest nie aktualny i jego kod trochę się "buntuje".

Ktoś się połączył lecz nie zalogował.

Vault czeka po załadowaniu PermissionsEx. Ale do tego polecał bym plugin pusty z samym onEnable, ale z oczekiwaniem aż włączą się podstawowe pluginy. Czy można się połączyć z serwerem przez bezpośrednie? Minecraft oryginalny? Po kolorze okna minecrafta widzę że masz windows 8. Pamiętaj że Minecraft i serwer jego nie działa poprawnie na windows 8 gdyż wiekszośc programów odmówiła wsparcia. Zainstalowane javy takie jak: JDK 7.21 i JRE 7.21? Wybrałeś wersję deweloperską, która nie jest skończona ani działająca poprawnie. LWC nie może połączyć się z SQL. Usuń LWC i zastąp Lockette


(StarterX4) #7

Błąd ten wyskakuje też gdy serwer jest bez pluginów, jawę zainstalowałem zaraz po instalacji Windows 8 i zainstalowaną stąd: http://www.java.com/pl/download/win8.jsp?locale=pl

a na Windows 7 też to samo miałem...

//edit

Dodam jeszcze że ten błąd mi wyskakuje tylko na Bukkicie, na zwykłym serwerze ze strony http://minecraft.net nie mam tego błędu.. dlaczego tak jest?! :-o

Teraz postanowiłem pobrać ten zwykły i sprawdzić czy też ten błąd jest..


(Piesek64) #8

Połącz się z serwerem przez bezpośrednie połączenie gdyż możesz się połączyć. Wybrałeś wersję development. Zamień ją na betę. Czy problem występuje na starszej wersji bukkita i starszym minecraftcie np. 1.0.0?