Problem z przedłużaczami USB 3.0

Chciałbym prosić o pomoc w rozwiązaniu następującego problemu. Nabyłem kilka przedłużaczy o długości 1,8 m z zamiarem ułatwienia dostępu do złącz umiejscowionych w tylnej części komputera biurkowego. Niestety próby skorzystania z podłączenia za pośrednictwem wyprowadzonych gniazd nie zawsze są skuteczne. Jeżeli w gnieździe przedłużacza umieszczę zwykły napęd USB, to urządzenie to jest bez trudu wykrywane i działa bez zastrzeżeń. Problem pojawia się wówczas, gdy do gniazda w przedłużaczu zamierzam podłączyć dysk twardy w obudowie i z niezalanym zasileniem. Długość przewodu łączącego dysk twardy z gniazdem przedłużacza to 1 m. Efekt jest taki, że albo dysk w ogóle jest niewykrywany w systemie operacyjnym lub po niedługim czasie następuje samoczynne rozłączenie, co z oczywistych powodów jest nieakceptowalne. Jeżeli zaś rzeczony dysk podłączę bez pośrednictwa przedłużacza, to opisane problemy nie występują. Czy można w związku z tym zaradzić temu problemowi? Czy remedium mogłoby być zastosowanie krótszych lub wyższej klasy przedłużaczy?

Hasło - klucz: aktywny HUB USB.

Dysponuję takim przedłużaczem, lecz jego zastosowanie nie przynosi oczekiwanego skutku. Mało tego – zauważyłem, że gdy podłączam inny dysk o pojemności 4TB w zasilanej obudowie, to nawet bez stosowania zasilanego osobno koncentratora dysk jest wykrywany w systemie operacyjnym. Jednak, gdy podłączam dysk 1,5 TB podłączony zasilanym mostkiem USB, to system go nie wykrywa. Sprawa jest o tyle zadziwiająca, że ten sam dysk, podłączany rzeczonym mostkiem do gniazda w komputerze przenośnym jest wykrywany. W komputerze biurkowym jednak problem niewykrywania tego dysku pozostaje. Jak to zdiagnozować?

Sam sobie odpowiedziałeś. Spróbuj na 0,5 mb.

Rzecz w tym, że nawet gdy podłączę dysk 1,5 TB poprzez mostek USB do innego komputera biurkowego, nawet bez pośrednictwa przedłużacza, to dysk ten nie jest widoczny w systemie operacyjnym.

a dale coś napomykasz coś o koncentratorze. To nie ta bajka. @Veers miał na myśli coś takiego:


Kup, zastosuj a problem rozwiążesz!

Żeby nie było - mam i wiem o czym mówię!

Słowo „hub” nie należy do języka polskiego . Poniższe źródło podaje jego tłumaczenie jako „koncentrator”

https://www.diki.pl/slownik-angielskiego?q=hub

Dlatego więc użyłem tego określenia.

A wracając do sprawy zasadniczej, to mam podobne zasilane urządzenie i jego zastosowanie nie zmienia sytuacji w tym zakresie – dysk 1,5 TB podłączony przez mostek USB bezpośrednio do gniazda w jednym z komputerów biurkowych działa, a w innym tego tupu komputerze – nie (w komputerze przenośnym – działa). Gniazdo musi być sprawne bo dysk 4TB w zasilanej obudowie działa w tym komputerze, w którym dysk 1,5 TB poprzez mostek USB odmawia posłuszeństwa.
jest

Może głupie pytanie, ale czy w PC podpinasz to do USB 3.x? Czy nie prowadzisz przewodu w pobliżu kabli zasilających, lub urządzenia mogącego generować duże zakłócenia elektromagnetyczne?

Cały czas mowa o złączach generacji 3.0. Jedyny kabel zasilający w pobliżu to ten prowadzący od zasilacza do mostka. Zaczynam podejrzewać, że anomalie tkwią właśnie w rzeczonym mostku. Mówię tak, gdyż podłączyłem dysk 4TB w zasilanej obudowie i napęd ten wykrywany jest zarówno przy jego podłączeniu wprost do gniazda USB jak i poprzez przedłużacz.