Problem z repozytoriami po uaktualnieniu Kubuntu do 22.10

Witam!
Jak w temacie. Po aktualizacji distro do wersji 22.10 w terminal wpisuję:

sudo apt update

Wpisuję hasło i dostaję to:

sudo apt update
[sudo] hasło użytkownika dawid:
Stary:1 Index of /ubuntu/ kinetic InRelease
Stary:2 Index of /ubuntu/ kinetic-updates InRelease
Stary:3 Index of /ubuntu/ jammy-updates InRelease
Stary:4 http://deb.anydesk.com all InRelease
Stary:5 Index of /ubuntu/ kinetic-backports InRelease
Stary:6 Index of /graphics-drivers/ppa/ubuntu kinetic InRelease
Stary:7 http://repository.spotify.com stable InRelease
Ign.:8 Index of /wine-builds/ubuntu kinetic InRelease
Stary:9 https://dl.google.com/linux/chrome/deb stable InRelease
Stary:10 Index of /repos/edge/ stable InRelease
Błąd:11 Index of /wine-builds/ubuntu kinetic Release
404 Not Found [IP: 151.101.2.217 443]
Stary:12 Index of /libreoffice/ppa/ubuntu kinetic InRelease
Ign.:13 Index of /danielrichter2007/grub-customizer/ubuntu kinetic InRelease
Stary:14 Index of /ubuntu kinetic-security InRelease
Stary:15 Index of /ubuntu jammy-security InRelease
Błąd:16 Index of /danielrichter2007/grub-customizer/ubuntu kinetic Release
404 Not Found [IP: 185.125.190.52 443]
Czytanie list pakietów… Gotowe
E: The repository ‘Index of /wine-builds/ubuntu kinetic Release’ does not have a Release file.
N: Updating from such a repository can’t be done securely, and is therefore disabled by default.
N: See apt-secure(8) manpage for repository creation and user configuration details.
W: http://deb.anydesk.com/dists/all/InRelease: Key is stored in legacy trusted.gpg keyring (/etc/apt/trusted.gpg), see the DEPRECATION section in apt-key(8) for details.
E: The repository ‘Index of /danielrichter2007/grub-customizer/ubuntu kinetic Release’ does not have a Release file.
N: Updating from such a repository can’t be done securely, and is therefore disabled by default.
N: See apt-secure(8) manpage for repository creation and user configuration details.

O co chodzi?

Mirrory Żeś też aktualizował.

??

Ja tam miałem repo od Chrome’a, Wine, i kilka innych. Potrzebne zapewne inne linki do repo…

Odświeżam temat.

Jak to naprawić, bo system zgłasza błędy.

Nie mam Ubuntu zainstalowanego, ale powyższe mówi, że masz wywołać, w terminalu: man 8 apt-key. Analogicznie do apt-secure. Z tego, co wywnioskowałem, masz ustawić odpowiednią informację w pliku konfiguracyjnym, by apt instalował z tego repa, albo znaleźć repo, które byłoby bardziej bezpiecznym dostawcą paczek.

Może się zmienił odcisk palca?

Wpisałe w terminal to:

man 8 apt-key

i dostałem to:
man apt key.txt (3,8 KB)

Przeczytałeś chociaż to co wywaliło w terminalu?

Błąd:11 [Index of /wine-builds/ubuntu ](https://dl.winehq.org/wine-builds/ubuntu) kinetic Release 404 Not Found [IP: 151.101.2.217 443]

Błąd:16 [Index of /danielrichter2007/grub-customizer/ubuntu](https://ppa.launchpadcontent.net/danielrichter2007/grub-customizer/ubuntu) kinetic Release 404 Not Found [IP: 185.125.190.52 443]

Co oznacza błąd 404 jak wchodzisz na jakąkolwiek stronę internetową? Że nie istnieje. Autorzy PPA nie przygotowali jescze pakietów dla wydania Ubuntu o nazwie kodowej Kinetic Kudu.

Co trzeba zrobić?

Wyłączyć te repozytoria albo przez klikadło albo przez prosta edycję jednego lub kilku plików tekstowych. Wszystko ci pokazywałem w kilometrowym wątku, gdzie ustawiałem ci repozytoria - odnajdź sobie.

Co do AnyDesk - usuń to repozytorium i dodaj jeszcze raz, ale wg tego schematu:
https://computingforgeeks.com/how-to-install-anydesk-on-ubuntu/ .

Widzisz różnicę gdzie ląduje klucz publiczny gpg i z czego wynika błąd?

Fakt, przeoczyłem.

Co do Wine, to może faktycznie będzie działać paczka z poprzedniego wydania? Wine wymaga mało zależności.

Odświeżam.
Wpisałem jeszcze:

man apt-secure

…i dostałem to:
apt-secure.txt (3,4 KB)

Czyli tak:

  • wyłączyć repo od Chrome, Edge i inne? Po prostu jeszcze nie ma repo do 22.10, tak?