Problem z routerem dl-524 i grą MW 2


(Mihalowy) #1

Witam

Chciałem sobie pograc online w Call of Duty Modern Warfare 2, ale tam pokazuje ze mam zablokowane porty w routerze (Dl-524 B4), pisze zeby odwiedzic strone http://www.infinityward.com/nat.php, wchodzę na to a tam pisze

"Log into your router and turn on UPnP (Universal Plug and Play), most routers have this option in the Administration tab.

The goal is to have an OPEN NAT in order to host Spec Ops games and get a wider selection of MP matches to join."

To UPnP ma włączone, dalej zobaczyłem na stronie http://portforward.com czy bedzie tam rozwiazanie mojego problemu, znalazłem coś takiego:

"The DI-524 will not allow you to forward enough ports, to run Call of Duty - Modern Warfare 2. You should try using the DMZ portion of this router if it is available. Alternatively you can try switching the router to bridged mode. You will need to contact your ISP to switch to bridged mode, so they can make the required changed on their end."

Próbowałem zrobić to z tym DMZ ale nie pomogło.

A i dodam ze jak puszcze nie po routerze tylko prosto po kablu to działa, ale niestety taka opcja nie wchodzi w gre.


(Dimatheus) #2

Hej,

Łącząc obie informacje można stwierdzić, że uruchomienie usługi UpnP jest potrzebne, gdyż klasycznie przekierowania portów nie umożliwią grania w sieci. Jeśli to nie działa, faktycznie zostaje DMZ.

A czy przy konfiguracji podałeś adres IP w sieci wewnętrznej komputera, na którym chcesz grać w CoD??

Dlaczego taka opcja nie wchodzi w grę?? Jeśli chcesz do gry sieciowej zaprząc więcej niż jeden komputer, to rozwiązanie z DMZ też niestety nie zda rezultatu...

:arrow: Czy i jakiego używasz firewalla??

:arrow: Czy w opcjach konfiguracyjnych pozwoliłeś, by CoD łączył się z internetem??

Pozdrawiam,

Dimatheus


(Mihalowy) #3

A więc tak:

:arrow: UPnP mam włączone, DMZ też wlaczałem i to nie pomaga

:arrow: Przy tej konfiguracji podałem adres ip 192:168:0:130 czyli tak jak w ipconfig w cmd wyświetlil mi się przy Ipv4.

:arrow: Nie wchodzi w gre bo trzebuje neta na routerze zeby mieć neta na dole gdzie caly czas jest potrzebny, a wgl ja mam tak ze od routera mam kabel do kompa więc to tak jakby jest przewodowo ale wcześniej przechodzi przez router

:arrow: Wydaje mi sie ze firewall i konfiguracje tu nie grają roli bo gdy podlączyłem kompa bezpośrednio kablem to wtedy działało, ale jakby co to mam Eset smart security 4


(Monczkin) #4

mihalowy , nazwij temat konkretnie. Inaczej temat zostanie usunięty. Przypomnę, że rejestrując się na forum potwierdziłeś znajomość regulaminu i zobowiązałeś się do jego przestrzegania. Przenoszę do odpowiedniego działu.


(Dimatheus) #5

Hej,

A czy po aktywowaniu opcji uruchamiałeś ponownie router?? W niektórych modelach do wprowadzenia większych zmian konieczne jest ponowne uruchomienie urządzenia...

Rozumiem, że w routerze w konfiguracji zamiast znaku ":" użyłeś "."??

Racja - inaczej faktycznie nie działałoby... :expressionless:

Pozdrawiam,

Dimatheus


(Mihalowy) #6

A więc

:arrow: U mnie w routerze mam tak ze jak zmieniam jakąś opcje to sie restartuje sam

:arrow: Nie zamienialem bo tam jest coś takiego ze jest juz napisane "192.168.0." i wtedy jest okienko i tam wpisujesz ciąg dalszy, w moim przypadku było to "130"

Dzieki że pomagasz

Pozdrawiam,

mihalowy


(Dimatheus) #7

Hej,

Czyli konieczność robienia tego ręcznie odpada... :slight_smile:

Czyli też jest OK... :expressionless: Zastanawiający tylko, dlaczego nie działa poprawnie.

Z informacji wyszperanych w necie wychodzi na to, że w większości przypadków po włączeniu UPnP oraz przekierowaniu portów możliwa jest gra. Nie wiem, jak wiele przekierowań możesz zrobić na router'ze (w instrukcji niestety nie podano), ale spróbuj przekierować poniższe porty na swój komputer (Virtual Server) - czyli tak jak pisałeś na IP zakończone liczbą 130.

:arrow: UDP 28960,

:arrow: TCP 28960,

:arrow: UDP 1500,

:arrow: UDP 3005,

:arrow: UDP 3101.

Jeśli to nie zadziała, a będziesz miał możliwość dodania dodatkowych portów, to według informacji producenta warto dodać też:

:arrow: UDP 27000 do 27015,

:arrow: UDP 27015 do 27030,

:arrow: TCP 27014 do 27050,

:arrow: TCP 27015.

Na próbę wyłącz także wbudowany w router Firewall - zakładka o takiej samej nazwie - i uruchom DMZ.

Pozdrawiam,

Dimatheus


(Mihalowy) #8

Te pierwsze odblokowałem i nie pomogło

Z tymi nastepnymi to bylo by troche cięzko bo u mnie nie moge wpisywac takich zakresów portów tylko kazdy pojedynczo, wiec gdybym juz wpukal te 50 portów co by troche zajelo (wliczajac ze po kazdym jest restart, przy kazdym musze wpisaywac ip) a później by sie okazało ze to nie pomogło to było by licho.

A firewall nie wiem jak wyłączyć, bo jak tam wchodzę to nie moge tego usunąc ani edytować ani wyłączyć

Pozdrawiam

EDIT: Ale chwileczke jest tam taka zkładka "Application" i psze tam ze to słuzy do aplikacji ktore wykorzystuja wile portów, tylko nie wiem co tam dokładnie wpisać bo mam tak:

Name []

Trigger port []-[]

Triger type [TCP albo UDP albo Both]

Public ports []

Public type [TCP lub UDP albo Both]

Wstawiam fote jak to wygląda

d8033117002c36f14b7598ec


(Dimatheus) #9

Hej,

Wiesz - niekiedy pojedyncze rozwiązanie niewiele daje. Czasami potrzebne jest, by wykonać kilka kroków - w tym przypadku i UPnP, DMZ oraz przekierowanie portów.

No to faktycznie - szkoda, że w oprogramowaniu nie ma możliwości przekierowania zakresu portów; to byłoby przydatne...

Dziwne - powinna być możliwość wyłączenie firewall'a poleceniem Disable. Jeśli normalnie się nie da, spróbuj zaraz po ponownym uruchomieniu routera.

Niestety, to nie do końca tak działa. Zakładka aplikacji pozwala na zdefiniowanie portów, które nie mają być blokowane przez router. Nie ma w niej natomiast możliwości przekierowania wspomnianych portów na konkretną jednostkę w sieci lokalnej...

Pozdrawiam,

Dimatheus