Problem z rozpakowywaniem plików *.exe


(darekols) #1

Witam, mam problem z instalacją, rozpakowywaniem jakichkolwiek plików exe. Odnoszę wrażenie, że są kasowane natychmiast w folderze plików tymczasowych TEMP. Nie działa mi przywracanie systemu z żadnym z dostępnych punktów przywracania. Firewall wiecznie włączony ale nie mam żadnego programu antywirusowego ponieważ żaden nie chce się zainstalować.

Mój system operacyjny to Windows XP Professional SP2

Kilka zdjęć z błędami:

Rozpakowanie archiwum 7-Zip'em

14bab826fa84a730m.jpg

Instalacja Panda Antivirus 2007

54807ee6ac516967m.jpg

Rozpakowanie AntiVir Personal Classic WinRAR'em

c09b6c0bf81d1c82m.jpg

Po zainstalowaniu avast!a linki nie działają

dd9ce0f93fa17418m.jpg

Sam instalator AntiVir'a też sobie nie radzi

c5d6f3f9595de0bfm.jpg


(Mail) #2

Pracujesz na końcie Administratora?


(darekols) #3

tak, zawsze


(rozwalkompa) #4

?!


(goomish) #5

Jak dla mnie to nie jest kwestia "znikania" plików z TEMPa tylko brak uprawnień do zapisu w w/w folderze. Sprawdź, czy przypadkiem (!?) nie usunąłeś użytkownika lub jego grupy z listy ACL dla folderu %temp%.


(darekols) #6

Wyciągnięcie pliku exe z archiwa rar, zip, czegokolwiek, setup.exe też.

Instalator rozpakowuje pliki do zainstalowania pierw do folderu TEMP, następnie przenosi je do folderu docelowego. Wszystkie programy chyba tak działają. Tylko czemu pliki *.exe nie trafiają do folderu docelowego?

@ goomish

Jak to zrobić/sprawdzić? :slight_smile:


(goomish) #7

Start -> Uruchom -> %temp%

Prawoklik w pustym miejscu -> Właściwości -> Zabezpieczenia

W górnej części okna powinna być nazwa użytkownika, na którego logujesz się do systemu albo jego grupy (w Twoim przypadku Administratorzy) W dolnej - zaznaczone 'Pełna kontrola'. Zaznaczenie może być wyszarzone (nieaktywne) jeżeli uprawnienie jest odziedziczone po folderze nadrzędnym. Tak też jest OK.

5118d36651e19567m.png


(darekols) #8

We Właściwościach folderu TEMP niema nigdzie przycisku/karty "Zabezpieczenia"


(goomish) #9

No tak, zapomniałem napisać... Jeżeli to XP Prof, musisz wyłączyć proste udostępnianie w Opcjach folderów, natomiast jeżeli to Home - musisz zalogować się w trybie awaryjnym. Normalnie tej zakładki włączyć się nie da (w uproszczeniu, bo są na to sposoby).


(darekols) #10

Na wszystko mam zezwolenie, a więc TEMP odpada.

Więc co może być przyczyną nie instalowania/wypakowywania się plików exe?


(Matusz1m) #11

miałem podobnie, tylko u mnie to był wirus i musiałem cały dysk formatować (nie partycje tylko cały dysk) u mnie sama wymiana systemu nic nie dawała :slight_smile:

jak coś to link do mojego postu:

http://forum.dobreprogramy.pl/viewtopic.php?t=201880


(darekols) #12

Problemu nie rozwiązałem, plików exe niedało się wypakowywać z achiwów, wykonałem formata.

Przedtem sprawdziłem system skanerami online (ponieważ nie mogłem zainstalować niczego coby mnie ratowało). Jedynie co znalazłem to FlashGet ma Win32/Cyboor'a zaimplementowanego w siebie.

Uznałem, że to rootkit'y, użyłem Rootkit Revealer 1.71 i okazało się, że pliki takie jak srosa.sys i witems.exe uruchamiały Internet Explorera w tle i wysyłały w świat wszystkie moje hasła, i dane z formularzów. Być może blokowały instalacje czegokolwiek. Szkoda, że tak późno się zorientowałem.

Dziękuję za zainteresowanie się wątkiem,

Pozdrawiam.