Problem z USB 3.0 w laptopie


(Theoluk98) #1

Witam forumowiczów,
chciałbym poprosić Was o radę. Jestem posiadaczem laptopa Toshiba Satellite M50D-A-10W i borykam się od paru dni z problemem związanym z magistralą USB.
W laptopie tym są ogółem 3 wejścia na usb: 2 wejścia USB 3.0 oraz jedno wejście USB 2.0. Od jakiegoś czasu porty USB 3.0 przestały reagować na podłączenie np. pendrive'a, przy podłączeniu telefonu widnieje tylko komunikat (na telefonie) że bateria jest ładowana, czyli napięcie wciąż jest obecne w ów wejściu. Sprawdziłem, czy aby system operacyjny nie jest tutaj winny. W tym celu włożyłem pendrive ze zbootowanym distro Linuxa, chciałem zobaczyć czy w BIOS'ie będę miał opcję bootowania z pendrive'a podłączonego do gniazda USB 3.0, jednak i tutaj nie było takiej opcji, czyli wykluczam błąd software'u. Nie wiem co może być na rzeczy, być może jest to czysto mechaniczne uszkodzenie, nie wiem, dlatego zwracam się o pomoc.


(h188862) #2

Jeżeli bios nie widzi to uszkodzony kontroler usb albo mostek, raczej mostek.


(JNJN) #3

Lub porty USB3.0 w biosie wyłączone?

 

Sprawdź w menadżerze urządzeń w kontrolerach uniwersalnej magistrali szeregowej, czy masz zainstalowane USB3.0?


(thommy181) #4

Objaw może być całkiem normalny jeśli pendrive jest przygotowany pod legacy bios, a system próbuje się zbootować poprzez UEFI. Po pierwsze sprawdź czy w systemie jest sterownik USB 3.0. Jeśli go nie ma również normalnym objawem jest brak wykrycia urządzenia podłączonego pod USB.


(Theoluk98) #5

W BIOSie przywróciłem ustawienia default, dalej to samo. Wcześniej nie było problemu z tymi wejściami, niezależnie od ustawień, a to chyba niemożliwe, żeby ustawienia w BIOSie zmieniły się same bez mojej wiedzy. Może się mylę.

Problem jest taki, że wcześniej ta sama instalka działała na tym wejściu (3.0), a teraz nie widać jakiejkolwiek reakcji, poza napięciem, dlatego tym bardziej nie wiem co jest grane. Boot-pendrive’a podpiąłem potem pod USB 2.0 i nie było tego problemu. Przedtem zawsze używałem wejścia z USB 3.0 ze względu na szybkość.
Wątpię też, żeby system miał coś do rzeczy, skoro BIOS również nie widzi pendrive. Dlatego wykluczam opcję z brakiem sterowników.
Nie mam już pomysłu :frowning:

Czy można to jakoś naprawić we własnym zakresie i czy jest to wymagająca wiedzy czynność? Jeśli lepiej nie eksperymentować to ile mogłaby kosztować naprawa w jakimś serwisie?


(JNJN) #6

Serwis

 

Bootujesz z USB 2.0

 

Aby działało USB3.0 trzeba zainstalować stery.


(Theoluk98) #7

Nie do końca rozumiem. Skoro w BIOSie nie widzi USB 3.0 to jakie stery mam pobrać?


(JNJN) #8

 

Wpis w biosie dotyczący portów USB może być różny - wcale nie musi pisać USB3.0.

 

Wklej zdjęcia biosu z opcjami USB zobaczymy.

 

W menadżerze nie masz jakiś urządzeń niezainstalowanych?

 

Windows Update i zaktualizuj system do najnowszego.


(Theoluk98) #9

Zaraz porobię zdjęcia, a co do Windowsa to może być problem, bo korzystam aktualnie z Linux Mint’a w wersji Xfce :smiley: